Gnash menu launcher (/usr/share/applications/gnash.desktop file) doesn't start any application, also gnash isn't asociated with SWF mimetype

Bug #84526 reported by Mantas Kriaučiūnas
14
Affects Status Importance Assigned to Milestone
gnash
Triaged
Medium
Unassigned
gnash (Baltix)
Confirmed
Medium
Mantas Kriaučiūnas
gnash (Ubuntu)
Fix Released
Medium
Unassigned

Bug Description

Binary package hint: gnash

Currently no programs opens if user press on Gnash menu launcher ("Gnash SWF Viewer" in Applications->AudioVideo category, see /usr/share/applications/gnash.desktop file).
This is because in gnash.desktop is a line "Exec=/usr/bin/gnash", but when you run /usr/bin/gnash in terminal you see, that this command displays only help if started without arguments.

Simply solution would be to create a one-line shell script, which displays a file-selection dialog and starts gnash when user selects a file:

/usr/bin/gnash `zenity --title="Select a Flash (.swf) file to display" --file-selection`

Also there is missing a MimeType line in gnash.desktop - you should add this line:

MimeType=application/x-shockwave-flash;

I'm attaching fixed gnash.desktop file (Lithuanian translation is added as bonus ;) to this bugreport.

Tags: packaging

Related branches

Changed in gnash:
importance: Undecided → Wishlist
status: Unconfirmed → Confirmed
Revision history for this message
Sam Cater (wraund-deactivatedaccount) wrote :

I have added the new gnash.desktop into a copy of the source of gnash, i have done this as part of my MOTU mentoring with gpocentek. Im not sure whether this bug has been fixed commercially, if so let me know. Otherwise I have a fixed version on my PC.

Changed in gnash:
assignee: nobody → sacater
Changed in gnash:
assignee: sacater → nobody
status: Confirmed → Unconfirmed
Changed in gnash:
assignee: nobody → sacater
Changed in gnash:
assignee: sacater → nobody
Revision history for this message
Jonh Wendell (wendell) wrote :

In order to solve this issue, bug #79063 needs to be fixed first.
I'm not unable to build gnash because some packages fail do install.

Revision history for this message
Jonh Wendell (wendell) wrote :

Ok, i quit. I'm removing tag bitesize from this bug, because it's not really for novices. (it requires chroot/pbuilder)

Alexander Sack (asac)
Changed in gnash:
status: Unconfirmed → Rejected
status: Unconfirmed → Rejected
Revision history for this message
Mantas Kriaučiūnas (mantas) wrote :

Gnash isn't associated with .sfw files and menu launcher still doesn't work in Baltix GNU/Linux 2.7rc4 :(

Changed in gnash:
assignee: nobody → mantas
importance: Undecided → Medium
status: Invalid → Confirmed
Revision history for this message
Mantas Kriaučiūnas (mantas) wrote : Improved Gnash menu launcher (gnash.desktop file) with added MimeType line and Lithuanian translation
Revision history for this message
Alexander Sack (asac) wrote :

this is an upstream bug. the gnash viewer binary should start regardless of having a argument or not. otherwise having this in the menu doesnt make much sense.

Changed in gnash:
status: Invalid → Triaged
importance: Undecided → Medium
status: New → Triaged
importance: Wishlist → Medium
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnash - 0.8.4-0ubuntu1

---------------
gnash (0.8.4-0ubuntu1) intrepid; urgency=low

  * LP: #84526 - Gnash menu launcher (/usr/share/applications/gnash.desktop
    file) doesn't start any application, also gnash isn't asociated with SWF
    mimetype; we dont show gnash in the .desktop launcher; we add
    NoDisplay=true, add a GenericName and Comment for the sake of
    completeness. Also we add the proper MimeType value, remove Encoding,
    don't use absolute paths for icon and exec and dont use specific icon
    file format suffix.
    - update debian/gnash.desktop

 -- Alexander Sack <email address hidden> Tue, 14 Oct 2008 16:06:54 +0200

Changed in gnash:
status: Triaged → Fix Released
Revision history for this message
John Rose (johnaaronrose) wrote :

This is back again in 14.04. Gnash is not found by Dash. There is a desktop file in /usr/share/applications. Copy of file is attached. Running gnash-gtk-launcher (Exec parameter in desktop file) in Terminal works OK.

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Duplicates of this bug

Other bug subscribers