no longer works with YouTube

Bug #738605 reported by Martin-Éric Racine on 2011-03-20
16
This bug affects 1 person
Affects Status Importance Assigned to Milestone
gnash (Ubuntu)
Medium
Micah Gersten

Bug Description

Binary package hint: gnash

Since a few weeks, Gnash can no longer play Youtube content. It keeps on showing "An error occured, please try again later."

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: browser-plugin-gnash 0.8.8-6ubuntu2
ProcVersionSignature: Ubuntu 2.6.38-7.36-generic 2.6.38
Uname: Linux 2.6.38-7-generic i686
Architecture: i386
Date: Sun Mar 20 11:33:11 2011
ProcEnviron:
 LANGUAGE=fi_FI:fi_FI.UTF-8:fi
 PATH=(custom, user)
 LANG=fi_FI.UTF-8
 SHELL=/bin/bash
SourcePackage: gnash
UpgradeStatus: Upgraded to natty on 2009-09-14 (551 days ago)

Related branches

CVE References

Martin-Éric Racine (q-funk) wrote :
Micah Gersten (micahg) wrote :

I was hoping to not have to pull in the git snapshot, but I guess it's unavoidable.

Changed in gnash (Ubuntu):
assignee: nobody → Micah Gersten (micahg)
importance: Undecided → Medium
milestone: none → ubuntu-11.04-beta-1
status: New → Triaged
Martin-Éric Racine (q-funk) wrote :

Sadly, both Gnash and the YouTube plugin for Totem fall into the same category of "packages endangered by Google's ever-changing API" and until Google learns to really play ball with the Free Software community by avoiding API changes between distro releases, there's not much that we can do.

WeBeJanT (webejant) wrote :

Until then, you can use Minitube. They have fixed the problem and youtube plays flawlessly. You can also download HD in one click. Search for it in repos.

Changed in gnash (Ubuntu):
milestone: ubuntu-11.04-beta-1 → ubuntu-11.04-beta-2
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnash - 0.8.9-1ubuntu1

---------------
gnash (0.8.9-1ubuntu1) natty; urgency=low

  * Merge from debian unstable. (LP: #739869, #738605) Remaining changes:
    - Use mozilla-flashplugin as the alternative for now
    - Set alternative priority to 50 so that it matches Adobe Flash's priority
  * Change xulrunner-dev build dep to firefox-dev (try to reduce dependency on
    xulrunner)
    - update debian/control
  * Add build-dep on libspeexdsp-dev and libxv-dev; Fixes FTBFS
    - update debian/control
  * Remove configure code for libpthread check; Fixes FTBFS w/multiarch paths
    - add debian/patches/no_configure_check_for_libpthread.patch
    - update debian/patches/series

gnash (0.8.9-1) unstable; urgency=low

  * New upstream release.
  * Add xulrunner-dev to B-D.
  * Remove gnash-dbg deps on all gnash binaries.
  * Add 01mysqltypo patch to fix mysql extension linking.

gnash (0.8.9~git20110220-1) unstable; urgency=low

  * Git snapshot.
    + KDE plugin dir uses lib64 only on Fedora; fixes FTBFS.
      (Closes: #614229)
  * debian/control: Add self to Uploaders.

gnash (0.8.9~git20110217-1) unstable; urgency=low

  * Git snapshot.
  * d/copyright: conversion to DEP-5.
  * d/control: Vcs* fields to git.
  * d/rules: switch to override_dh_* targets.

gnash (0.8.8-9) unstable; urgency=low

  * Add epoch to swfdec-gnome transitional package.

gnash (0.8.8-8) unstable; urgency=low

  * Fixed spelling in long descriptions (Closes: #608911).
  * Fixed binnmu-ability.
  * lintian: added browser-plugin-gnash override.
  * Removed .po files regeneration from build process (Closes: #605352).
  * Added patches
    + 08_sectempfiles: Create configure temporary files in a secure way
      (CVE-2010-4337).
    + fixmanpage: Update command options in manpage.

gnash (0.8.9~git20101219-1) experimental; urgency=low

  * Git snapshot.
  * Added binary packages:
    + gnash-dev (development files)
    + python-gtk-gnash (python bindings)
    + gnash-ext-fileio (fileio extension)
    + gnash-ext-mysql (mysql extension)
    + gnash-ext-lirc (lirc extension)
  * Debhelper compatibility to 7.

gnash (0.8.8-7) unstable; urgency=low

  * Added patch 07_jemalloc to make kfreebsd-* archs treated like *bsd oses
    (Closes: #604573).
  * Transitional packages architecture from any to all (Closes: #603609).
  * Added patch to fix texinfo docs.
 -- Micah Gersten <email address hidden> Tue, 05 Apr 2011 12:08:24 -0500

Changed in gnash (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers