FFe: Please merge gnash 0.8.8-5 (universe) from Debian experimental (main)

Bug #636667 reported by Micah Gersten on 2010-09-12
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
gnash (Ubuntu)
Wishlist
Unassigned

Bug Description

Please merge gnash 0.8.8-5 (universe) from Debian experimental (main)

Explanation of FeatureFreeze exception:
Current package doesn't work well with youtube and other sites that require an updated flash.

Changelog entries since current maverick version 0.8.7-0ubuntu1:

gnash (0.8.8-5) unstable; urgency=low

   [ Gabriele Giacone ]
   * Fixed Section and Priority fields in debian/control

   [ Miriam Ruiz ]
   * Uploading package to unstable

 -- Miriam Ruiz <email address hidden> Sun, 12 Sep 2010 21:45:04 +0200

gnash (0.8.8-4) experimental; urgency=low

   * Added epoch to swfdec-gnome dummy package for transition.
   * Renamed mozilla-plugin-gnash package to browser-plugin-gnash.
   * Reworded short and long descriptions.

 -- Gabriele Giacone <email address hidden> Wed, 08 Sep 2010 15:55:21 +0200

gnash (0.8.8-3) experimental; urgency=low

  [ Gabriele Giacone ]
  * Added reference and user manuals to gnash-common (Closes: #477477).
    + Added xsltproc, docbook-xsl as Build-Depends.
  * Added patch fixtypos.patch to fix typos.
  * Escaped dashes in man pages (lintian tag hyphen-used-as-minus-sign).
  * Added parallel=n build option.
  * Added -dbg package for debug symbols.
  * Added -doc package for API documentation.
    + Added doxygen as Build-Depends.
  * Added swfdec-mozilla and swfdec-gnome dummy packages for swfdec transition.
  * Source format to 3.0 (quilt).
    + Removed quilt from Build-Depends.

 -- Gabriele Giacone <email address hidden> Sun, 29 Aug 2010 23:07:12 +0200

gnash (0.8.8-2) unstable; urgency=low

  [ Miriam Ruiz ]
  * Added support for MIME for ShockWave Flash and FutureSplash Flash
  * Changed Section from utils to video
  * Removed Robert Millan from uploaders
  * Added Gabriele to uploaders

 -- Miriam Ruiz <email address hidden> Sun, 29 Aug 2010 05:33:18 +0200

gnash (0.8.8-1) experimental; urgency=low

  [ Miriam Ruiz ]
  * New Upstream Release
    - 100% of all YouTube videos should work. If you have problems,
      delete all YouTube cookies and refresh.
    - Gnash can switch at runtime between the Cairo, OpenGL, and AGG
      renderers.
    - Gnash can switch media handlers at runtime, too, between FFmpeg
      and Gstreamer,
    - Gnash can now decode video quickly on hardware compatible with the
      VAAPI library (a few NVidia, ATI, and Intel graphics processors).
    - Gnash now compiles faster due to reduced internal dependencies.
      Scriptable Plugin support so Javascript in the browser can
      work with ActionScript in Gnash.
    - Improved input device handling when using a raw framebuffer.
  * Refreshed patches. Removed patch: build_on_ia64.patch, no longer needed
  * Modified ./configure parameters: --enable-media='gst,ffmpeg'
  * Removed get-bzr-source target from debian/rules. Upstream has moved to git
  * Changed Maintainer to <email address hidden>

  [ Gabriele Giacone ]
  * New desktop files translations.
    + German (Closes: #557108)
    + Japanese (Closes: #560706)
    + Vietnamese (Closes: #576139)
  * Added Vcs-* fields.

 -- Miriam Ruiz <email address hidden> Sun, 22 Aug 2010 23:19:46 +0200

gnash (0.8.8~bzr20100809.2250-1) experimental; urgency=low

  * New Upstream Release. Downloaded from Bazaar.
  * Added --enable-hwaccel=none to ./configure
  * Removed the -opengl packages
  * Removed --enable-avm2, it doesn't compile otherwise

 -- Miriam Ruiz <email address hidden> Tue, 10 Aug 2010 00:57:51 +0200

gnash (0.8.7-3) unstable; urgency=low

  [ Miriam Ruiz ]
  * Fixed dependencies so that it compiles against latest boost.
    Closes: #587967. Closes: #590370
  * Fixed problem with libtool. CLoses: #523902
  * Upgraded Standards Version from 3.8.4 to 3.9.1

 -- Miriam Ruiz <email address hidden> Wed, 04 Aug 2010 22:30:19 +0200

gnash (0.8.7-2) unstable; urgency=low

  [ Miriam Ruiz ]
  * Cleaned up debian/rules a bit
  * Added patch build_on_ia64.patch. Closes: #571319
  * Removed csound from recommeds. Closes: #570212
  * Changed short descriptions so that "aptitude search flash" finds this
    package. Closes: #522865
  * Fix debian/*.desktop.in files. Closes: #475853
  * Thanks to Petter Reinholdtsen <email address hidden>
  * debian/rules: Added --without-included-ltdl to ./configure. See #559808
  * Added support for Renesas SH4. Closes: #563167
  * Updated debian/*.local files. Closes: #548282

 -- Miriam Ruiz <email address hidden> Fri, 19 Feb 2010 23:25:26 +0100

gnash (0.8.7-1) unstable; urgency=low

  [ Miriam Ruiz ]
  * New upstream release
    + Automatic and spontaneous screenshots support in all GUIs
    + Significant memory savings in parsing large XML trees and in
      some function calls
    + Enhancements in video streaming
    + Non blocking load of bitmaps, movies, data
    + Refactoring to eliminate most static data and get closer to
      re-entrant VM
    + Cygnal now supports multiple network connections, handling multiple
      video streams
    + Cygnal now supports plugins for server side scripting in C/C++
  * Refreshed patches
  * Upgraded Standards-Version from 3.8.3 to 3.8.4
  * Removed dh_desktop from debian/rules (deprecated)
  * Upgraded build dependencies
  * Fixed Watch file. Closes: #570323. Thanks to Sindhudweep Sarkar.
  * Replaced --enable-media=ffmpeg by --enable-media=gst in ./configure

 -- Miriam Ruiz <email address hidden> Mon, 15 Feb 2010 11:12:23 +0100

Related branches

Micah Gersten (micahg) on 2010-09-12
Changed in gnash (Ubuntu):
importance: Undecided → Wishlist
Iulian Udrea (iulian) wrote :

Have you performed any testing on this package in Maverick? Does it build/run well?

Please see https://wiki.ubuntu.com/FreezeExceptionProcess.

Changed in gnash (Ubuntu):
status: New → Incomplete
Scott Kitterman (kitterman) wrote :

@micahg: Ping. I suspect this is something we want, but we really need some testing done.

Andrius Štikonas (stikonas) wrote :

I have been using gnash 0.8.8 since it appeared in Debian (I've rebuilt it on my own Kubuntu 10.10 machine) and I did not notice any regressions compared to 0.8.7. But I haven't done any more testing thant just the general use.

Scott Kitterman (kitterman) wrote :

Thanks. Based on that, FFe approved. Leaving at New for sponsor review.

Changed in gnash (Ubuntu):
status: Incomplete → New
StefanPotyra (sistpoty) wrote :

Hi Micah,

hm... I just tried to review it from a sponsors perspective, and found that there is an ubuntu delta which e.g. adds libgnashagg.so to gnash-common. Actually only afterwards I realized that you should be able to upload yourself . Maybe you can clearify the Ubuntu delta little bit more for the convenience of the archive admins?

Thanks,
    Stefan.

Benjamin Drung (bdrung) wrote :

I have tested gnash 0.8.8-5 on maverick. Upgrading works. Youtube videos work (but with high CPU load) compared to not working in 0.8.7-0ubuntu1. One thing that needs to be checked before the sync: Do we really don't drop any Ubuntu change? The diff between Ubuntu and Debian is quite huge.

summary: - FFe: Sync gnash 0.8.8-3 (universe) from Debian experimental (main)
+ FFe: Sync gnash 0.8.8-5 (universe) from Debian experimental (main)
description: updated

<bdrung_> ScottK: does the FFe for gnash applied to 0.8.8-5 too
<ScottK> bdrung_: If the difference between what I approved and this is bugfix, yes.
<bdrung_> ScottK: there's one "new feature": Renamed mozilla-plugin-gnash package to browser-plugin-gnash.
<bdrung_> ScottK: i have tested the upgrade and it works
<ScottK> bdrung_: OK. Ack for that then.

Micah Gersten (micahg) wrote :

Unsubscribed sponsors until this is ready for upload.

summary: - FFe: Sync gnash 0.8.8-5 (universe) from Debian experimental (main)
+ FFe: Please merge gnash 0.8.8-5 (universe) from Debian experimental
+ (main)
Micah Gersten (micahg) wrote :

I won't be able to look at this for a few days if anyone else is interested in finishing this. Otherwise, I'll try to pick it up over the weekend.

description: updated
Chris Coulson (chrisccoulson) wrote :

Ok, I've uploaded this now. The only adjustments I made were:

* Dropped the touch .autoreg bit from the postinst script, as we don't need that for plugins
* Shipped the directories where we install alternatives to, so that update-alternatives doesn't fail

Changed in gnash (Ubuntu):
status: New → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnash - 0.8.8-5ubuntu1

---------------
gnash (0.8.8-5ubuntu1) maverick; urgency=low

  [ Micah Gersten <email address hidden> ]
  * FFe - LP: #636667
  * Merge from debian unstable. Remaining changes:
    + Add Ubuntu flash alternatives in postinst and prerm
      - update debian/browser-plugin-gnash.postinst
      - update debian/browser-plugin-gnash.prerm

  [ Chris Coulson <email address hidden> ]
  * Ensure the directories we are installing alternatives too exist
    already
    - add debian/browser-plugin-gnash.dirs
 -- Micah Gersten <email address hidden> Tue, 28 Sep 2010 23:38:37 -0500

Changed in gnash (Ubuntu):
status: Fix Committed → Fix Released
madbiologist (me-again) wrote :

Thanks Micah and Chris. Could you please take a look at bug #624742 ?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers