gtk-gnash crashed with SIGSEGV in _savegpr_30()

Bug #446866 reported by EzerchE on 2009-10-09
44
This bug affects 12 people
Affects Status Importance Assigned to Milestone
gnash (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: gnash

an error appeared whıle trıed to watchıng a vıdeo on facebook page

ProblemType: Crash
Architecture: powerpc
Date: Fri Oct 9 04:57:50 2009
DistroRelease: Ubuntu 9.10
ExecutablePath: /usr/bin/gtk-gnash
Package: gnash 0.8.6-0ubuntu1
ProcCmdline: /usr/bin/gtk-gnash -x 69220261 -j 400 -k 300 -u http://b.static.ak.fbcdn.net/rsrc.php/z4HBM/hash/3krgnmig.swf -F 101 -U http://www.facebook.com/home.php -P allowfullscreen=true -P allowscriptaccess=always -P bgcolor=#000000 -P flashvars=video_src=http%3A%2F%2Fvideo.ak.facebook.com%2Fvideo-ak-sf2p%2Fv10816%2F22%2F111%2F127527207899_28413.mp4&stage_width=400&stage_height=300&motion_log=%2Fvideo%2Fmotion_log.php&histogram_is_on=1&video_id=127527207899&video_length=139910&video_seconds=139&video_category=0&video_rotation=0&video_href=http%3A%2F%2Fwww.facebook.com%2Fvideo%2Fvideo.php%3Fv%3D127527207899&fbt_play_again=Play+Again&fbt_go_to_video=Go+to+Video&fbt_next_video=Next+Video&fbt_share=Share&play_context=1&connect_to_owner=&share_id=s%3D11%26appid%3D2392950137%26p%5B%5D%3D127527207899&video_player_type=video_player_stream&video_width=400&video_height=300&mvp_connect=1&thumb_url=http%3A%2F%2Fvthumb.ak.fbcdn.net%2Fvthumb-ak-sf2p%2Fv10819%2F46%2F99%2F618217899%2Fb618217899_127527207899_1327.jpg&video_autoplay=1&string_table=http://static.ak.fbcdn.net/js_strings.php/t87156/en_US&swf_id=so_video_4ace988a6c8a23aad2f35 -P height=300px -P id=so_video_4ace988a6c8a23aad2f35 -P name=so_video_4ace988a6c8a23aad2f35 -P quality=high -P scale=showall -P src=http://b.static.ak.fbcdn.net/rsrc.php/z4HBM/hash/3krgnmig.swf -P style= -P type=application/x-shockwave-flash -P width=400px -P wmode=window -
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-12.41-powerpc64-smp
Signal: 11
SourcePackage: gnash
StacktraceTop:
 _savegpr_30 () from /usr/lib/libfontconfig.so.1
 ?? ()
 ?? ()
 _init ()
 __libc_csu_init ()
Title: gtk-gnash crashed with SIGSEGV in _savegpr_30()
Uname: Linux 2.6.31-12-powerpc64-smp ppc64
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

EzerchE (ezerche) wrote :
Marcus Comstedt (marcus-mc) wrote :

This happens to me as well.

Analyzing the problem, I found that the called function "_savegpr_30" has a non-standard calling convention; it takes its input parameter in r11. However, the call to the function goes through the PLT (a dynamic call), which clobbers r11. This looks like a GCC bug.

The following GCC patch might be relevant: http://gcc.gnu.org/ml/gcc-patches/2008-10/msg00264.html

Marcus Comstedt (marcus-mc) wrote :

As a workaround, changing

  CFLAGS += -Os

to

  CFLAGS += -O

in debian/rules produces a working gnash.

Marcus Comstedt (marcus-mc) wrote :

-O2 also works fine, it's just -Os that is bugged.

Does this still occur with the version of gcc in lucid?

Can you please test with the latest version of the gnash package in the gnash team PPA (https://edge.launchpad.net/~gnash/+archive/ppa?field.series_filter=)?

Disregard my brainfart. Obviously the ppa doesn't produce packages for ppc.

Marcus Comstedt (marcus-mc) wrote :

Well, I tried the 0.8.6-0ubuntu2 package published in Lucid, an that one seems to work at least.

Marcus Comstedt (marcus-mc) wrote :

Also, the gcc bug has been fixed in karmic-updates (by gcc-4.4 version 4.4.1-4ubuntu9),
so building the karmic package from source on an up-to-date karmic system also produces
a working binary.

dino99 (9d9) wrote :

This version is outdated and no more supported

Changed in gnash (Ubuntu):
status: New → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers