package mozilla-plugin-gnash 0.8.5-0ubuntu1 failed to install/upgrade: subprocess installed pre-removal script returned error exit status 2

Bug #398213 reported by sam tygier
100
This bug affects 15 people
Affects Status Importance Assigned to Milestone
gnash (Ubuntu)
Fix Released
Medium
Chris Coulson

Bug Description

Binary package hint: gnash

got this while removing gnash

ProblemType: Package
AptOrdering:
 mozilla-plugin-gnash-dbgsym: Remove
 mozilla-plugin-gnash: Remove
 gnash: Remove
 gnash-common: Remove
Architecture: amd64
Date: Sat Jul 11 18:09:54 2009
DistroRelease: Ubuntu 9.10
ErrorMessage: subprocess installed pre-removal script returned error exit status 2
Package: mozilla-plugin-gnash 0.8.5-0ubuntu1
ProcVersionSignature: Ubuntu 2.6.31-2.17-generic
SourcePackage: gnash
Title: package mozilla-plugin-gnash 0.8.5-0ubuntu1 failed to install/upgrade: subprocess installed pre-removal script returned error exit status 2
Uname: Linux 2.6.31-2-generic x86_64

Revision history for this message
sam tygier (samtygier) wrote :
Changed in gnash (Ubuntu):
assignee: nobody → Chris Coulson (chrisccoulson)
importance: Undecided → Medium
status: New → In Progress
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnash - 0.8.5-0ubuntu2

---------------
gnash (0.8.5-0ubuntu2) karmic; urgency=low

  * debian/mozilla-plugin-gnash.prerm:
    - Remove redundant "update-alternatives --list" test, which exits with
      an error now when there are no alternatives left. The test doesn't
      return 0 lines anyway, so the check doesn't work. This stops the prerm
      script exiting with an error on removal (LP: #398213).

 -- Chris Coulson <email address hidden> Sun, 12 Jul 2009 11:51:11 +0100

Changed in gnash (Ubuntu):
status: In Progress → Fix Released
Revision history for this message
Alexander Sack (asac) wrote :

i think we need to do it differently. The --remove-all is essential to workaround dpkg bugs.

if the error code is the problem we can do something like;

update-alternatives --list flashplugin-... | wc -l || true

to check whether there are no alternatives left.

Changed in gnash (Ubuntu):
status: Fix Released → In Progress
Revision history for this message
Kai Mast (kai-mast) wrote :

How am I supposed to upgrade this package if it can't be removed?

Revision history for this message
sam tygier (samtygier) wrote :

if you install swfdec then the broken uninstall script in gnash will not fail. that lets you remove/upgrade gnash

Revision history for this message
Chris Coulson (chrisccoulson) wrote :

There is no reason that the upgrade should fail now anyway. The prerm script from the new version should run if the old one fails, which should handle the upgrade case.

Revision history for this message
Chris Coulson (chrisccoulson) wrote :

Closing this now, as the --remove-all doesn't seem to be needed anymore.

Changed in gnash (Ubuntu):
status: In Progress → Fix Released
Revision history for this message
ludovic_f (ludovic-ferre) wrote :

Sorry guys, but the problem still exists...

Here is the issue I get now:

dpkg: error processing /var/cache/apt/archives/mozilla-plugin-gnash_0.8.5-0ubuntu2_i386.deb (--unpack):
 subprocess new pre-removal script returned error exit status 1
postinst called with argument `abort-upgrade'
dpkg: error while cleaning up:
 subprocess installed post-installation script returned error exit status 1
Errors were encountered while processing:
 /var/cache/apt/archives/mozilla-plugin-gnash_0.8.5-0ubuntu2_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

Revision history for this message
Chris Coulson (chrisccoulson) wrote :

Ok, I can see what is happening there.

Changed in gnash (Ubuntu):
status: Fix Released → In Progress
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnash - 0.8.5-0ubuntu3

---------------
gnash (0.8.5-0ubuntu3) karmic; urgency=low

  * fix LP: #422745 - no alternatives for iceape-flashplugin; ignore
    upgrade failures from << 0.8.5-0ubuntu3 (caused by LP: #398213)
    - update debian/mozilla-plugin-gnash.prerm

 -- Alexander Sack <email address hidden> Fri, 11 Sep 2009 13:21:54 +0200

Changed in gnash (Ubuntu):
status: In Progress → Fix Released
Revision history for this message
ludovic_f (ludovic-ferre) wrote :

Where can I get this file to test it out?

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers