konqueror-plugin-gnash contains no binaries

Bug #322141 reported by Blackpaw
20
This bug affects 3 people
Affects Status Importance Assigned to Milestone
gnash (Ubuntu)
Fix Released
Undecided
Sindhudweep Sarkar

Bug Description

Installation of konqueror-plugin-gnash on Kubuntu 8.10 (KDE 4.2) reveals it contains no binaries.

Description: Ubuntu 8.10
Release: 8.10

Qt: 4.4.3
KDE: 4.2.00 (KDE 4.2.0)
kde4-config: 1.0

Related branches

Revision history for this message
Schmirrwurst (schmirrwurst) wrote : apport-collect data

Architecture: amd64
DistroRelease: Ubuntu 9.10
NonfreeKernelModules: nvidia
Package: gnash 0.8.5-0ubuntu2
PackageArchitecture: amd64
ProcEnviron:
 SHELL=/bin/bash
 LANG=fr_FR.UTF-8
 LANGUAGE=
ProcVersionSignature: Ubuntu 2.6.31-3.19-generic
Uname: Linux 2.6.31-3-generic x86_64
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

Revision history for this message
Schmirrwurst (schmirrwurst) wrote :
tags: added: apport-collected
Revision history for this message
Schmirrwurst (schmirrwurst) wrote :

I'm experiencing the same problem under karmic, after installing the package, konqueror is acting as having no plugin... when showing in the setting, no gnash plugin is appearing...
Only after installing the mozilla gnash plugin...

Revision history for this message
karaluh (karaluh) wrote :

Confirmed for Karmic

Changed in gnash (Ubuntu):
status: New → Confirmed
Revision history for this message
Martin Rehn (minpost) wrote :

Still the case for current Karmic, 0.8.5-0ubuntu3. The package only contains a changelog file.

Revision history for this message
Philipp Edelmann (tukss) wrote :

The reason can be found in the changelog for version 0.8.4~~bzr9980-0ubuntu2

  * disable kde gui until klash/qt4 has been fixed; keep kde packages as empty
    packages for now.
    - update debian/rules
    - debian/klash.install
    - debian/klash.links
    - debian/klash.manpages
    - debian/konqueror-plugin-gnash.install

Does anyone know if the original problem is still there?
Debian's packages seem to be functional. I will try building them in my PPA. If they work, Ubuntu should sync the packages from Debian, I think.

Revision history for this message
rsavoye (rob-welcomehome) wrote :

In the current Gnash sources, there is support for correctly packaging klash4 (kde4) and the Konqueror plugin in gnash/packaging/debian. I use these to build snapshots on both Ubuntu and Debian. There are also many recent cleanups to these files to keep linitian happy.

Revision history for this message
Sindhudweep Sarkar (sindhudweep-sarkar) wrote :

rsavoye: thanks I will try and make sure those changes are merged in.

Changed in gnash (Ubuntu):
assignee: nobody → Sindhudweep Sarkar (sindhudweep-sarkar)
Changed in gnash (Ubuntu):
status: Confirmed → In Progress
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnash - 0.8.7-0ubuntu1

---------------
gnash (0.8.7-0ubuntu1) lucid; urgency=low

  * new upstream release 0.8.7 (LP: #522254)
    - modified debian/gnash-common.install to ship new library libgnashagg.so.*
    - modified .bzr-builddeb/default.conf to point to new upstream location.
  * enable decoding of speex encoded audio
    - modified debian/control.
  * fix LP: #318849 - Deprecated klash kde3 binaries removed and not
    replaced with gnash-kde4.
    - modified debian/klash.desktop to point to kde4-gnash binary instead of klash.
    - modified debian/klash.install to install files necessary for kde4-gnash.
    - modified debian/rules to enable the kde4 gui.
    - modified debian/control to include kdelibs5-dev
  * fix LP: #322141 - konqueror-plugin-gnash contains no binaries
    - modified debian/konqueror-plugin-gnash.install to install files necessary for the gnash kpart.
    - modified debian/rules to build gnash kpart.
 -- Sindhudweep Narayan Sarkar <email address hidden> Mon, 08 Mar 2010 09:57:54 -0500

Changed in gnash (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers