Ubuntu

gnash crash! ...gnash 0.8.1~trunk.070802-0ubuntu3 failed to install/upgrade: subprocess post-installation script returned error exit status 2

Reported by hotani on 2007-08-11
42
Affects Status Importance Assigned to Milestone
gnash (Ubuntu)
Undecided
Mario Đanić

Bug Description

Binary package hint: gnash

running via "apt-get dist-upgrade" produces the following:
----
Setting up mozilla-plugin-gnash (0.8.1~trunk.070802-0ubuntu3) ...
/var/lib/dpkg/info/mozilla-plugin-gnash.postinst: 7: Syntax error: "do" unexpected (expecting ";;")
dpkg: error processing mozilla-plugin-gnash (--configure):
 subprocess post-installation script returned error exit status 2
Errors were encountered while processing:
 mozilla-plugin-gnash
E: Sub-process /usr/bin/dpkg returned an error code (1)
-----

ProblemType: Package
Architecture: amd64
Date: Sat Aug 11 13:07:45 2007
DistroRelease: Ubuntu 7.10
ErrorMessage: subprocess post-installation script returned error exit status 2
Package: mozilla-plugin-gnash 0.8.1~trunk.070802-0ubuntu3
PackageArchitecture: amd64
SourcePackage: gnash
Title: package mozilla-plugin-gnash 0.8.1~trunk.070802-0ubuntu3 failed to install/upgrade: subprocess post-installation script returned error exit status 2
Uname: Linux gutsy-test 2.6.22-9-generic #1 SMP Fri Aug 3 00:20:35 GMT 2007 x86_64 GNU/Linux

hotani (hotani) wrote :
Changed in gnash:
assignee: nobody → mario-danic
status: New → Confirmed
apache2 (sullr) wrote :

Using gusty tribe 4 here. I am also having problems with mozilla-plugin-gnash. Would like to get this fixed. It appears there is something wrong with the deb, not sure, here is my output when I try to remove mozilla-plugin-gnash:

ryan@ryan-laptop:~$ sudo apt-get remove mozilla-plugin-gnash
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages will be REMOVED:
  mozilla-plugin-gnash
0 upgraded, 0 newly installed, 1 to remove and 0 not upgraded.
1 not fully installed or removed.
Need to get 0B of archives.
After unpacking 205kB disk space will be freed.
Do you want to continue [Y/n]?
(Reading database ... 135378 files and directories currently installed.)
Removing mozilla-plugin-gnash ...
/var/lib/dpkg/info/mozilla-plugin-gnash.prerm: 17: for p in iceape iceweasel mozilla firefox xulrunner; do update-alternatives --remove "$p-flashplugin" /usr/lib/gnash/libgnashplugin.so done: not found
dpkg: error processing mozilla-plugin-gnash (--remove):
 subprocess pre-removal script returned error exit status 127
/var/lib/dpkg/info/mozilla-plugin-gnash.postinst: 7: Syntax error: "do" unexpected (expecting ";;")
dpkg: error while cleaning up:
 subprocess post-installation script returned error exit status 2
Errors were encountered while processing:
 mozilla-plugin-gnash
E: Sub-process /usr/bin/dpkg returned an error code (1)

Policy:

ryan@ryan-laptop:~$ apt-cache policy mozilla-plugin-gnash
mozilla-plugin-gnash:
  Installed: 0.8.1~trunk.070802-0ubuntu3
  Candidate: 0.8.1~trunk.070802-0ubuntu3
  Version table:
 *** 0.8.1~trunk.070802-0ubuntu3 0
        500 http://us.archive.ubuntu.com gutsy/universe Packages
        100 /var/lib/dpkg/status

what can I do to remove this? frusterating seeing that error every time I use apt-get

Mario Đanić (mario-danic) wrote :

I am aware of the problem, and will fix it.

apache2 (sullr) wrote :

I got it to remove in a very forcefull way. I'm not to keen on scripting or how dpkg works, so you might not listen to me BUT, if you want to remove mozilla-plugin-gnash (for now until it is fixed):

You have to remove 1 line from 2 different files.

Remove [ for p in iceape iceweasel mozilla firefox xulrunner; do update-alternatives --remove "$p-flashplugin" /usr/lib/gnash/libgnashplugin.so done ]

from
/var/lib/dpkg/info/mozilla-plugin-gnash.prerm &
/var/lib/dpkg/info/mozilla-plugin-gnash.postinst

then
sudo apt-get remove mozilla-plugin-gnash

and to be safe, manually run update-alternatives as both files wanted to do:

sudo update-alternatives --remove iceape-flashplugin /usr/lib/gnash/libgnashplugin.so
sudo update-alternatives --remove iceweasel-flashplugin /usr/lib/gnash/libgnashplugin.so
sudo update-alternatives --remove mozilla-flashplugin /usr/lib/gnash/libgnashplugin.so
sudo update-alternatives --remove firefox-flashplugin /usr/lib/gnash/libgnashplugin.so
sudo update-alternatives --remove xulrunner-flashplugin /usr/lib/gnash/libgnashplugin.so

Mario Đanić (mario-danic) wrote :

I've got the fix, and soon it'll be uploaded into repositories. Thank you for your patience.

apache2 (sullr) wrote :

Thanks Mario! Appreciated!

SameerS (sameer-srivastava) wrote :

I am using gutsy.. I couldnt update till i did follw the steps as mentioned by apache2. Its working fine now. Thanks

Mario, it seems that the problem isn't fixed yet, at least for me. I've downloaded the new packages, but when I install the mozilla-plugin package, I get the following error message:

Preparing to replace mozilla-plugin-gnash 0.8.1~trunk.070802-0ubuntu3 (using mozilla-plugin-gnash_0.8.1~trunk.070802-0ubuntu4_amd64.deb) ...
/var/lib/dpkg/info/mozilla-plugin-gnash.prerm: 17: for p in iceape iceweasel mozilla firefox xulrunner; do update-alternatives --remove "$p-flashplugin" /usr/lib/gnash/libgnashplugin.so done: not found
dpkg: warning - old pre-removal script returned error exit status 127
dpkg - trying script from the new package instead ...
prerm called with argument `failed-upgrade'
dpkg: error processing mozilla-plugin-gnash_0.8.1~trunk.070802-0ubuntu4_amd64.deb (--install):
 subprocess new pre-removal script returned error exit status 1
/var/lib/dpkg/info/mozilla-plugin-gnash.postinst: 7: Syntax error: "do" unexpected (expecting ";;")
dpkg: error while cleaning up:
 subprocess post-installation script returned error exit status 2
Errors were encountered while processing:
 mozilla-plugin-gnash_0.8.1~trunk.070802-0ubuntu4_amd64.deb

Christian Schuerer, if you had installed the broken package before the fixed
release, you will _still_ have problems upgrading. You need to remove it
first. I posted above how to manually remove.

"
I got it to remove in a very forcefull way. I'm not to keen on
scripting or how dpkg works, so you might not listen to me BUT, if you
want to remove mozilla-plugin-gnash (for now until it is fixed):

You have to remove 1 line from 2 different files.

Remove [ for p in iceape iceweasel mozilla firefox xulrunner; do
update-alternatives --remove "$p-flashplugin"
/usr/lib/gnash/libgnashplugin.so done ]

from
/var/lib/dpkg/info/mozilla-plugin-gnash.prerm &
/var/lib/dpkg/info/mozilla-plugin-gnash.postinst

then
sudo apt-get remove mozilla-plugin-gnash

and to be safe, manually run update-alternatives as both files wanted to do:

sudo update-alternatives --remove iceape-flashplugin
/usr/lib/gnash/libgnashplugin.so
sudo update-alternatives --remove iceweasel-flashplugin
/usr/lib/gnash/libgnashplugin.so
sudo update-alternatives --remove mozilla-flashplugin
/usr/lib/gnash/libgnashplugin.so
sudo update-alternatives --remove firefox-flashplugin
/usr/lib/gnash/libgnashplugin.so
sudo update-alternatives --remove xulrunner-flashplugin
/usr/lib/gnash/libgnashplugin.so "

once you've done that, then upgrade and let me know if it went through
smooth

-ryan

On 8/12/07, Christian Schuerer <email address hidden> wrote:
>
> Mario, it seems that the problem isn't fixed yet, at least for me. I've
> downloaded the new packages, but when I install the mozilla-plugin
> package, I get the following error message:
>
> Preparing to replace mozilla-plugin-gnash 0.8.1~trunk.070802-0ubuntu3(using mozilla-plugin-gnash_0.8.1~trunk.070802-0ubuntu4_amd64.deb) ...
> /var/lib/dpkg/info/mozilla-plugin-gnash.prerm: 17: for p in iceape
> iceweasel mozilla firefox xulrunner; do update-alternatives --remove
> "$p-flashplugin" /usr/lib/gnash/libgnashplugin.so done: not found
> dpkg: warning - old pre-removal script returned error exit status 127
> dpkg - trying script from the new package instead ...
> prerm called with argument `failed-upgrade'
> dpkg: error processing
> mozilla-plugin-gnash_0.8.1~trunk.070802-0ubuntu4_amd64.deb (--install):
> subprocess new pre-removal script returned error exit status 1
> /var/lib/dpkg/info/mozilla-plugin-gnash.postinst: 7: Syntax error: "do"
> unexpected (expecting ";;")
> dpkg: error while cleaning up:
> subprocess post-installation script returned error exit status 2
> Errors were encountered while processing:
> mozilla-plugin-gnash_0.8.1~trunk.070802-0ubuntu4_amd64.deb
>
> --
> gnash crash! ...gnash 0.8.1~trunk.070802-0ubuntu3 failed to
> install/upgrade: subprocess post-installation script returned error exit
> status 2
> https://bugs.launchpad.net/bugs/131864
> You received this bug notification because you are a direct subscriber
> of the bug.
>

--
Mechanical Engineering Undergraduate
CSU American Society of Engineers
CSU Engineering College Council
CSU American Institute of Aeronautics and Astronautics

Download full text (3.3 KiB)

Thanks for you help, ryan, I could update the package successfully now.

~Christian

On Monday 13 August 2007, apache2 wrote:
> Christian Schuerer, if you had installed the broken package before the
> fixed release, you will _still_ have problems upgrading. You need to
> remove it first. I posted above how to manually remove.
>
> "
> I got it to remove in a very forcefull way. I'm not to keen on
> scripting or how dpkg works, so you might not listen to me BUT, if you
> want to remove mozilla-plugin-gnash (for now until it is fixed):
>
>
> You have to remove 1 line from 2 different files.
>
> Remove [ for p in iceape iceweasel mozilla firefox xulrunner; do
> update-alternatives --remove "$p-flashplugin"
> /usr/lib/gnash/libgnashplugin.so done ]
>
> from
> /var/lib/dpkg/info/mozilla-plugin-gnash.prerm &
> /var/lib/dpkg/info/mozilla-plugin-gnash.postinst
>
> then
> sudo apt-get remove mozilla-plugin-gnash
>
>
> and to be safe, manually run update-alternatives as both files wanted to
> do:
>
> sudo update-alternatives --remove iceape-flashplugin
> /usr/lib/gnash/libgnashplugin.so
> sudo update-alternatives --remove iceweasel-flashplugin
> /usr/lib/gnash/libgnashplugin.so
> sudo update-alternatives --remove mozilla-flashplugin
> /usr/lib/gnash/libgnashplugin.so
> sudo update-alternatives --remove firefox-flashplugin
> /usr/lib/gnash/libgnashplugin.so
> sudo update-alternatives --remove xulrunner-flashplugin
> /usr/lib/gnash/libgnashplugin.so "
>
> once you've done that, then upgrade and let me know if it went through
> smooth
>
> -ryan
>
> On 8/12/07, Christian Schuerer <email address hidden> wrote:
> > Mario, it seems that the problem isn't fixed yet, at least for me. I've
> > downloaded the new packages, but when I install the mozilla-plugin
> > package, I get the following error message:
> >
> > Preparing to replace mozilla-plugin-gnash
> > 0.8.1~trunk.070802-0ubuntu3(using
> > mozilla-plugin-gnash_0.8.1~trunk.070802-0ubuntu4_amd64.deb) ...
> > /var/lib/dpkg/info/mozilla-plugin-gnash.prerm: 17: for p in iceape
> > iceweasel mozilla firefox xulrunner; do update-alternatives --remove
> > "$p-flashplugin" /usr/lib/gnash/libgnashplugin.so done: not found dpkg:
> > warning - old pre-removal script returned error exit status 127 dpkg -
> > trying script from the new package instead ...
> > prerm called with argument `failed-upgrade'
> > dpkg: error processing
> > mozilla-plugin-gnash_0.8.1~trunk.070802-0ubuntu4_amd64.deb (--install):
> > subprocess new pre-removal script returned error exit status 1
> > /var/lib/dpkg/info/mozilla-plugin-gnash.postinst: 7: Syntax error: "do"
> > unexpected (expecting ";;")
> > dpkg: error while cleaning up:
> > subprocess post-installation script returned error exit status 2
> > Errors were encountered while processing:
> > mozilla-plugin-gnash_0.8.1~trunk.070802-0ubuntu4_amd64.deb
> >
> > --
> > gnash crash! ...gnash 0.8.1~trunk.070802-0ubuntu3 failed to
> > install/upgrade: subprocess post-installation script returned error exit
> > status 2
> > https://bugs.launchpad.net/bugs/131864
> > You received this bug notification because you are a direct subscriber
> > of the bug.
>
> --
> Mechanical Engineering Undergrad...

Read more...

gnash (0.8.1~trunk.070802-0ubuntu4) gutsy; urgency=low

  * Fixed postinst and prerm procedures

 -- Mario Danic <email address hidden> Sun, 12 Aug 2007 00:56:48 +0200

Changed in gnash:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers