youtube crashes firefox

Bug #131451 reported by Ross Peoples on 2007-08-10
8
Affects Status Importance Assigned to Milestone
gnash (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: gnash

Going to youtube.com after installing the gnash mozilla plugin crashes firefox with a message saying gnash was unexpectedly terminated. Running Ubuntu Gusty 7.10 Tribe 4 with restricted ATI drivers (fglrx), using XGL + Compiz Fusion

Changed in gnash:
importance: Undecided → Medium
Andreas Braml (a-strich-b) wrote :

Happens here too, with "01:00.0 VGA compatible controller: Silicon Integrated Systems [SiS] 661/741/760 PCI/AGP or 662/761Gx PCIE VGA Display Adapter".
If I'm lucky, it happens the way the original reporter described. More often than not it hangs X entirely, no apport popup window, mouse and keyboard dead, CTRL+Fn don't work either. I cannot try to ping the machine, as I don't have a second machine (and no home network), so I can't tell if the machine stalls entirely or just X.
I can reproduce this, so tell me if any logs, coredumps etc. are needed. This is a testing environment (dualbooting with Feisty), so let's break my Ubuntu

On Sun, Aug 12, 2007 at 03:49:32AM -0000, Andreas Braml wrote:
> Happens here too, with "01:00.0 VGA compatible controller: Silicon Integrated Systems [SiS] 661/741/760 PCI/AGP or 662/761Gx PCIE VGA Display Adapter".
> If I'm lucky, it happens the way the original reporter described. More often than not it hangs X entirely, no apport popup window, mouse and keyboard dead, CTRL+Fn don't work either. I cannot try to ping the machine, as I don't have a second machine (and no home network), so I can't tell if the machine stalls entirely or just X.
> I can reproduce this, so tell me if any logs, coredumps etc. are needed. This is a testing environment (dualbooting with Feisty), so let's break my Ubuntu
>

First: what gnash package version are you using?

 - Alexander

Ross Peoples (deejross) wrote :

The one in the Gusty repositories

Andreas Braml (a-strich-b) wrote :

Sorry, I still forget to add the most important bits. So let's see:

[mozilla|konqueror]-plugin-gnash: 0.8.1~trunk.070802-ubuntu4
gstreamer-fluendo-mp3 and -ffmpeg are installed

This is pure Tribe 4, -backports and -proposed repositories inactive.

I looked a bit close in this, starting firefox from a console window. First it does not entirely hang Firefox, but it makes it very, very, very slow. The output in the console gets redrawn line by line, and I mean _pixel_ lines here!
Than X hangs entirely, no mouse pointer visible, Ctrl-Alt-Backspace doesn't work.

When I use konqueror, Flash embedded windows show, but the movies don't play; instead, I get the "Replay" and "Share" buttons that usually show after a movie has played immediately. Odd.

Would the output in the console be of any help? Tell me, and I send the script session output.

exactt (giesbert) wrote :

still facing the problems?

Mario Capurso (m-capurso) wrote :

I had the same problem with the VESA driver.
The gnash plugin used with some sites (try with YouTube) hangs Firefox and the computer.
The only solution working for me is removing the gnash AND the Adobe plugin, going to YouTube WITHOUT any flash plugin, clicking on the DOWNLOAD PLUGIN, getting the tar.gz package and installing it as root.

Andreas Braml (a-strich-b) wrote :

The bug no longer occurs under Hardy i386 as of 2008-03-19 12:00 UTC, intel driver, compiz enabled.

Hew (hew) wrote :

Closing this bug based on the previous comment.

Changed in gnash:
status: New → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers