Playing error : Resource not found. at /usr/bin/../share/gmusicbrowser/gmusicbrowser_gstreamer-0.10.pm line 135.

Bug #892333 reported by Jiri Grönroos on 2011-11-18
40
This bug affects 9 people
Affects Status Importance Assigned to Milestone
gmusicbrowser (Ubuntu)
Undecided
Unassigned

Bug Description

I have thousands of MP3 and FLAC songs on my library. I usually play music on Oneiric 64-bit in random order and sometimes when gmusicbrowser automatically changes the song, sound just stops and I just receive an error "Playing error : Resource not found. at /usr/bin/../share/gmusicbrowser/gmusicbrowser_gstreamer-0.10.pm line 135."

I need to skip the song and double-click it the song in order to play it.

???@i5:~$ apt-cache show gmusicbrowser
Package: gmusicbrowser
Priority: optional
Section: universe/sound
Installed-Size: 3504
Maintainer: Ubuntu Developers <email address hidden>
Original-Maintainer: Debian Multimedia Maintainers <email address hidden>
Architecture: all
Version: 1.1.7-2
Depends: perl, libgtk2-perl, libgtk2.0-0 (>= 2.6), mpg321 | flac123 | ogg123
Recommends: liblocale-gettext-perl (>= 1.04), libnet-dbus-perl, libgtk2-trayicon-perl, libgtk2-notify-perl, libgstreamer-perl
Suggests: mplayer, vorbis-tools, mpg321, alsa-utils, libgstreamer-interfaces-perl, libgtk2-mozembed-perl
Filename: pool/universe/g/gmusicbrowser/gmusicbrowser_1.1.7-2_all.deb

???@i5:~$ apt-cache show gstreamer0.10-plugins-ugly
Package: gstreamer0.10-plugins-ugly
Priority: optional
Section: universe/libs
Installed-Size: 1392
Maintainer: Onkar Shinde <email address hidden>
Original-Maintainer: Maintainers of GStreamer packages <email address hidden>
Architecture: amd64
Source: gst-plugins-ugly0.10
Version: 0.10.18-3ubuntu1
Replaces: gstreamer0.10-lame, gstreamer0.10-plugins-bad (<< 0.10.10.2), gstreamer0.10-plugins-good (<< 0.10.9.2), gstreamer0.10-plugins-ugly-multiverse (<= 0.10.17-1), gstreamer0.10-x264
Depends: liba52-0.7.4, libc6 (>= 2.7), libcdio10, libdvdread4, libgcc1 (>= 1:4.1.1), libglib2.0-0 (>= 2.24.0), libgstreamer-plugins-base0.10-0 (>= 0.10.26), libgstreamer0.10-0 (>= 0.10.26), libid3tag0 (>= 0.15.1b), libmad0 (>= 0.15.1b-3), libmp3lame0, libmpeg2-4, libopencore-amrnb0, libopencore-amrwb0, liborc-0.4-0 (>= 1:0.4.14), libsidplay1, libstdc++6 (>= 4.1.1), libtwolame0, libx264-116
Conflicts: gstreamer0.10-lame, gstreamer0.10-plugins-bad (<< 0.10.5.2), gstreamer0.10-x264
Filename: pool/universe/g/gst-plugins-ugly0.10/gstreamer0.10-plugins-ugly_0.10.18-3ubuntu1_amd64.deb

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gmusicbrowser (Ubuntu):
status: New → Confirmed
Maciej Marczewski (barszczmm) wrote :

It also happens in version 1.1.9ppa2

Jeffrey Tees (jeff-tees) wrote :

Playing error : Resource not found. at /usr/bin/../share/gmusicbrowser/gmusicbrowser_gstreamer-0.10.pm line 135.

 I got this error frequently in Ubuntu 11.10. Just got it after sorting out update to 12.04.

Quentin Sculo (squentin) wrote :

"Resource not found" means either gstreamer can't open the file, or it can't open the audio output.
As you can play the file on a second try, It means it is the latter.

It may be caused by the audio driver not allowing multiple connections, and somehow the connection from the previous file was not yet closed when opening the connection for the next file.

You can try changing the output device in the audio tab, to pulseaudio or alsa.
You can also try enabling the gapless option in the advanced options for gstreamer, also in the audio tab.

Gary M (garym) on 2012-05-13
tags: added: oneiric precise
Aixa Ardin (aixaardin) wrote :

Well I got this problem too. Just installed a fresh 12.04 and it worked ok. Then I did a few installs including enabling all this

non-free-codecs libxine1-ffmpeg gxine mencoder flac faac faad sox ffmpeg2theora libmpeg2-4 uudeview libmpeg3-1 mpeg3-utils mpegdemux liba52-dev mpeg2dec vorbis-tools id3v2 mpg321 mpg123 libflac++6 ffmpeg totem-mozilla icedax tagtool easytag id3tool lame nautilus-script-audio-convert libmad0 libjpeg-progs libdvdcss2 w32codecs libavcodec53 libavutil51 ubuntu-restricted-extras app-install-data-medibuntu apport-hooks-medibuntu

and now it won play, not even at a second try. Unisntalled (Completly remove) and re-installed with no sucess. Maybe one of the things I installed broke it.

Aixa Ardin (aixaardin) wrote :

Tried something else:

Removed completely with synaptic.
Reinstalled with Software Center.
Now it works correctly and also displays the green music icon instead of the cool camel.

So Synaptic install is what seems to break it.

Aixa Ardin (aixaardin) wrote :

The problem kept coming back after logoff or restart. Removing library folders and adding them again solved the problem. Finally, figured that the partitions were the music was were not auto-mounting. If I mount the volumes manually the problem disappears. So at least, for me, it is not bug. Now to tweak the automount.

I'm also on Ubuntu/precise and got the same results as Aixa Ardin. My music is on a partition that for some reason didn't automount like it normally does. That caused gmusicbrowser to give this same error. The same thing happens in v1.1.10. Remounting the partition fixed the issue.

NiklasW (post-y) wrote :

While this issue isn't entirely just because of an error in gmusicplayer, wouldn't it seem like a really good idea to look over the start-up process of gmusicplayer, and make sure it automounts all usb drivers? I was tearing my hair out before i figured out what was wrong myself.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers