Encoding errors in gmusicbrowser_1.1.10-0ubuntu1

Bug #1234448 reported by Sean Davis
26
This bug affects 4 people
Affects Status Importance Assigned to Milestone
gmusicbrowser (Ubuntu)
Fix Released
Undecided
Unassigned

Bug Description

There is an encoding error in the songtree. The fix is a simple patch that I am attaching.

Tags: patch
Revision history for this message
Sean Davis (bluesabre) wrote :

The patch is for the shimmer-layouts debian patch shipped in Ubuntu 13.10

Revision history for this message
Ubuntu Foundations Team Bug Bot (crichton) wrote :

The attachment "shimmer-layouts patch" seems to be a patch. If it isn't, please remove the "patch" flag from the attachment, remove the "patch" tag, and if you are a member of the ~ubuntu-reviewers, unsubscribe the team.

[This is an automated message performed by a Launchpad user owned by ~brian-murray, for any issues please contact him.]

tags: added: patch
Revision history for this message
Sean Davis (bluesabre) wrote :

This seems to be a problem across the entire package, with encoding errors in the application, translations, and more.

summary: - Encoding error in songtree.layout
+ Encoding errors in gmusicbrowser_1.1.10-0ubuntu1
Revision history for this message
Quentin Sculo (squentin) wrote :

I don't think there is an encoding problem in gmusicbrowser as nobody has complained to me about that, and I haven't made any change that could cause that in a really long time.
Also I've downloaded the debian patch and I don't see the same extra characters, Though there is those strange "Â"s which I don't think should be there at all. By the way the whole shimmer layout patch seems to be wrong, the layouts it adds are already there (I've checked in the gmusicbrowser_1.1.10.orig.tar.gz), though without the strange "Â"s.

So I don't know what is going on there, what are your locale environment variables ? And where else do you see encoding problems other than those strange things added by the layout patch ?

Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gmusicbrowser (Ubuntu):
status: New → Confirmed
Revision history for this message
Alexander Behringer (alexander-behringer-deactivatedaccount) wrote :

The the following commit introduced the characters "ÂÂ":

http://bazaar.launchpad.net/~ubuntu-branches/ubuntu/saucy/gmusicbrowser/saucy/revision/16/layouts/songtree.layout

The characters can also be found in the "shimmer-layouts" patch in the same commit:

http://bazaar.launchpad.net/~ubuntu-branches/ubuntu/saucy/gmusicbrowser/saucy/revision/16/debian/patches/shimmer-layouts

This commit is related to bug #1213158.

Revision history for this message
Alessio Treglia (quadrispro) wrote :

Fixed in Debian.

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gmusicbrowser - 1.1.10-2

---------------
gmusicbrowser (1.1.10-2) unstable; urgency=low

  * Fix encoding error in shimmer-layouts patch. (LP: #1234448)

 -- Alessio Treglia <email address hidden> Fri, 11 Oct 2013 19:12:33 +0100

Changed in gmusicbrowser (Ubuntu):
status: Confirmed → Fix Released
Revision history for this message
Paul Madore (henrypaulmadore) wrote :

Confirmed: the quickest way to fix this bug is to go to http://gmusicbrowser.org, download the 1.1.10-2 or most recent package, and install it. The slowest way is to wait for it to come in an update package of its own volition.

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers