gmp doesn't build on ia64

Bug #11055 reported by Debian Bug Importer on 2004-12-10
4
Affects Status Importance Assigned to Milestone
gmp (Debian)
Fix Released
Unknown
gmp (Ubuntu)
High
Unassigned

Bug Description

Automatically imported from Debian bug report #285006 http://bugs.debian.org/285006

Debian Bug Importer (debzilla) wrote :

Automatically imported from Debian bug report #285006 http://bugs.debian.org/285006

Debian Bug Importer (debzilla) wrote :

Message-Id: <email address hidden>
Date: Fri, 10 Dec 2004 03:04:24 +0100
From: Adrian Bunk <email address hidden>
To: Debian Bug Tracking System <email address hidden>
Subject: gmp doesn't build on ia64

Package: gmp
Version: 4.1.4-5
Severity: serious

buildd.debian.org lists the following build error on ia64:

<-- snip -->

...
g++ -shared -nostdlib /usr/lib/gcc-lib/ia64-linux/3.3.5/../../../crti.o /usr/li
b/gcc-lib/ia64-linux/3.3.5/crtbeginS.o .libs/dummy.o cxx/.libs/isfuns.o cxx/.l
ibs/ismpf.o cxx/.libs/ismpq.o cxx/.libs/ismpz.o cxx/.libs/osdoprnti.o cxx/.libs
/osfuns.o cxx/.libs/osmpf.o cxx/.libs/osmpq.o cxx/.libs/osmpz.o -Wl,--rpath -W
l,/build/buildd/gmp-4.1.4/.libs ./.libs/libgmp.so -L/usr/lib/gcc-lib/ia64-linu
x/3.3.5 -L/usr/lib/gcc-lib/ia64-linux/3.3.5/../../.. -lstdc++ -lm -lgcc_s -lc -
lgcc_s -lc /usr/lib/gcc-lib/ia64-linux/3.3.5/crtendS.o /usr/lib/gcc-lib/ia64-l
inux/3.3.5/../../../crtn.o -Wl,-z -Wl,defs -Wl,-soname -Wl,libgmpxx.so.3 -o .l
ibs/libgmpxx.so.3.0.5
cxx/.libs/ismpf.o(.text+0x9b2): In function `operator>>(std::basic_istream<char
, std::char_traits<char> >&, __mpf_struct*)':
/build/buildd/gmp-4.1.4/cxx/ismpf.cc:45: undefined reference to `_Unwind_Resume
'
cxx/.libs/ismpq.o(.text+0xa92): In function `operator>>(std::basic_istream<char
, std::char_traits<char> >&, __mpq_struct*)':
/build/buildd/gmp-4.1.4/cxx/ismpq.cc:33: undefined reference to `_Unwind_Resume
'
cxx/.libs/ismpz.o(.text+0x722): In function `operator>>(std::basic_istream<char
, std::char_traits<char> >&, __mpz_struct*)':
/build/buildd/gmp-4.1.4/cxx/ismpz.cc:33: undefined reference to `_Unwind_Resume
'
cxx/.libs/osdoprnti.o(.text+0x312): In function `__gmp_doprnt_integer_ostream(s
td::basic_ostream<char, std::char_traits<char> >&, doprnt_params_t*, char*)':
./gmp-impl.h:3099: undefined reference to `_Unwind_Resume'
cxx/.libs/osmpf.o(.text+0x2e2): In function `operator<<(std::basic_ostream<char
, std::char_traits<char> >&, __mpf_struct const*)':
./gmp-impl.h:3099: undefined reference to `_Unwind_Resume'
collect2: ld returned 1 exit status
make[3]: *** [libgmpxx.la] Error 1
make[3]: Leaving directory `/build/buildd/gmp-4.1.4'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/build/buildd/gmp-4.1.4'
make[1]: *** [all] Error 2
make[1]: Leaving directory `/build/buildd/gmp-4.1.4'
make: *** [build-stamp] Error 2

<-- snip -->

reassign 285006 binutils
thanks

I have reason to believe that the build failure of gmp (bts 285006) is
caused by the binutils patch applied to fix bts 278836.

Gmp revision 4.1.4-4 was successfully built on 2004-10-24
http://buildd.debian.org/fetch.php?&pkg=gmp&ver=4.1.4-4&arch=ia64&stamp=1098614396&file=log&as=raw

but revision -5 failed on 2004-11-28
http://buildd.debian.org/fetch.php?&pkg=gmp&ver=4.1.4-5&arch=ia64&stamp=1101659366&file=log&as=raw

The change in GMP was simply to NOT run the test suite when
cross-compiling. For the ia64 build, obviously, there was
no change.

The only toolchain difference between the two was binutils:
binutils_2.15-4 in October but binutils_2.15-5 in November. This
change corresponds to fixing 278836, which had something to do
with "unwind". Gmp failed to find symbol _Unwind_Resume. I figure
the patch must be buggy.

When this bug is fixed, would the ia64-powers-that-be please
schedule a build of gmp.

Thanks,
-Steve

Debian Bug Importer (debzilla) wrote :

Message-id: <email address hidden>
Date: Fri, 10 Dec 2004 00:41:27 -0500
From: "Steve M. Robbins" <email address hidden>
To: <email address hidden>, <email address hidden>
Cc: <email address hidden>

reassign 285006 binutils
thanks

I have reason to believe that the build failure of gmp (bts 285006) is
caused by the binutils patch applied to fix bts 278836.

Gmp revision 4.1.4-4 was successfully built on 2004-10-24
http://buildd.debian.org/fetch.php?&pkg=gmp&ver=4.1.4-4&arch=ia64&stamp=1098614396&file=log&as=raw

but revision -5 failed on 2004-11-28
http://buildd.debian.org/fetch.php?&pkg=gmp&ver=4.1.4-5&arch=ia64&stamp=1101659366&file=log&as=raw

The change in GMP was simply to NOT run the test suite when
cross-compiling. For the ia64 build, obviously, there was
no change.

The only toolchain difference between the two was binutils:
binutils_2.15-4 in October but binutils_2.15-5 in November. This
change corresponds to fixing 278836, which had something to do
with "unwind". Gmp failed to find symbol _Unwind_Resume. I figure
the patch must be buggy.

When this bug is fixed, would the ia64-powers-that-be please
schedule a build of gmp.

Thanks,
-Steve

Adrian Bunk <email address hidden> writes:

> Package: gmp
> Version: 4.1.4-5
> Severity: serious
>
>
> buildd.debian.org lists the following build error on ia64:

This kind of bug report exemplifies why buildd maintainers should be
the ones to file bugs. This was a temporary toolchain issue (not in
binutils, BTW) that has been resolved. gmp has been now been rebuilt
successfully.

--
James

Debian Bug Importer (debzilla) wrote :

Message-ID: <email address hidden>
Date: Sat, 11 Dec 2004 23:29:33 +0100
From: James Troup <email address hidden>
To: <email address hidden>
Subject: Re: Bug#285006: gmp doesn't build on ia64

Adrian Bunk <email address hidden> writes:

> Package: gmp
> Version: 4.1.4-5
> Severity: serious
>
>
> buildd.debian.org lists the following build error on ia64:

This kind of bug report exemplifies why buildd maintainers should be
the ones to file bugs. This was a temporary toolchain issue (not in
binutils, BTW) that has been resolved. gmp has been now been rebuilt
successfully.

--
James

Colin Watson (cjwatson) wrote :

Invalid report in Debian, and verified not a problem for us:

       gmp | 4.1.4-5 | hoary/main | source
   libgmp3 | 4.1.4-5 | hoary/main | amd64, i386, ia64, powerpc
libgmp3-dev | 4.1.4-5 | hoary/main | amd64, i386, ia64, powerpc
libgmp3-doc | 4.1.4-5 | hoary/main | all

Changed in gmp:
status: Unknown → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.