gm-notify has high cpu usage

Bug #616781 reported by Taylor "Ripps" LeMasurier-Wren on 2010-08-12
84
This bug affects 16 people
Affects Status Importance Assigned to Milestone
GMail Notifier
High
Alexander Hungenberg
gm-notify (Ubuntu)
High
Andrew Starr-Bochicchio
Maverick
High
Andrew Starr-Bochicchio

Bug Description

Binary package hint: gm-notify

Recently in Maverick, gm-notify has started having worringly high cpu usage, around 70-85%. This is unacceptably high. I've been using this version for around a month and it's never behaved like this. Something must have changed recently in the large number of updates in Maverick recently.

ProblemType: Bug
DistroRelease: Ubuntu 10.10
Package: gm-notify 0.10.2-0ubuntu1
ProcVersionSignature: Ubuntu 2.6.35-14.20-generic 2.6.35
Uname: Linux 2.6.35-14-generic i686
Architecture: i386
Date: Thu Aug 12 07:44:52 2010
PackageArchitecture: all
ProcEnviron:
 PATH=(custom, user)
 LANG=en_US.utf8
 SHELL=/bin/bash
SourcePackage: gm-notify

Related branches

Martijn vdS (martijn) wrote :

This happens as soon as you click on it when there's new mail (for me at least).

Greg Ryman (ryman-greg) wrote :

This isn't limited to i386 either, I have the same problem on X86_64.

Simon Baconnais (smon) wrote :

Same problem here !

100% CPU when i click on gm-notify.

Anders (andersja+launchpad-net) wrote :

Setting this to confirmed as it is impacting a large number of users (3 duplicates reported and counting). I haven't got access to change the "Importance" level, but I would call out that for gm-notify it's pretty high as it is impacting a lot of people who are testing it. For Ubuntu overall, of course, much lower.

Changed in gm-notify:
status: New → Confirmed
Changed in gm-notify (Ubuntu):
status: New → Confirmed
Extender (msveshnikov) wrote :

Please assign High importance to that bug!

well... you're right - but the problem is, that this is not directly gm-notify's fault.

The problem lies in the line with
subprocess.call() which seems to have problems with PyGTK

I'm investigating this and trying to find alternatives ;)

Changed in gm-notify:
importance: Undecided → High
status: Confirmed → Triaged
Changed in gm-notify (Ubuntu):
status: Confirmed → Triaged

thanks god I finally found a solution ;-)

standby :-)

Changed in gm-notify:
assignee: nobody → Alexander Hungenberg (alexander-hungenberg-gmail)
status: Triaged → In Progress

:-)

Changed in gm-notify:
status: In Progress → Fix Committed
Changed in gm-notify:
milestone: none → 0.10.3
status: Fix Committed → Fix Released

Great! I'll push this to Ubuntu today.

Changed in gm-notify (Ubuntu):
importance: Undecided → High
Changed in gm-notify (Ubuntu Maverick):
status: Triaged → In Progress
assignee: nobody → Andrew Starr-Bochicchio (andrewsomething)
Changed in gm-notify (Ubuntu Maverick):
milestone: none → ubuntu-10.10
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gm-notify - 0.10.3-0ubuntu1

---------------
gm-notify (0.10.3-0ubuntu1) maverick; urgency=low

  * New upstream bug fix release.
   - Fix CPU usage issue with subprocess.call. (LP: #616781)
  * debian/patches/scripts-with-extensions-in-PATH:
   - Drop, included upstream.
  * debian/control: Bump Standards-Version to 3.9.1.
 -- Andrew Starr-Bochicchio <email address hidden> Sat, 18 Sep 2010 15:41:02 -0400

Changed in gm-notify (Ubuntu Maverick):
status: Fix Committed → Fix Released
Extender (msveshnikov) wrote :

Thanks guys, bug fixed :)

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers