Ubuntu

Please remove and blacklist glx-alternatives

Reported by W. Scott Lockwood III on 2013-01-15
84
This bug affects 20 people
Affects Status Importance Assigned to Milestone
glx-alternatives (Ubuntu)
Undecided
Unassigned

Bug Description

Please remove glx-alternatives from the archive and blacklist it. The binaries provided by it depend on the way graphics drivers are installed in Debian and this is done completely differently in Ubuntu.

Original bug description:
This bug affects both glx-alternative-mesa and glx-diversions. Both packages require nvidia-installer-cleanup, however, nvidia-installer-cleanup is not installable.

slockwood@tincek:~$ sudo apt-get -f -u -m install glx-alternative-mesa glx-diversions
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 glx-diversions : PreDepends: nvidia-installer-cleanup but it is not installable
E: Unable to correct problems, you have held broken packages.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in glx-alternatives (Ubuntu):
status: New → Confirmed
BW~Merlin (bwmerlin) wrote :

I have the same issue but I get mine when I try to install glx-alternative-nvidia and trying to install the dependencies fails.

user@hostname:~$ sudo apt-get install glx-alternative-nvidia
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 glx-alternative-nvidia : Depends: glx-diversions (= 0.2.2)
                          Depends: glx-alternative-mesa
E: Unable to correct problems, you have held broken packages.

Colin Peart (cgapeart) wrote :

I had GL and everything working last weekend (Feb 24 or so). On monday Feb 25, I did apt-get upgrade on my system, and the display driver was broken. I had been using fglrx based on downloading that directly from AMD, but I also had the same problem with the in-stream fglrx and fglrx-updates versions. I had assumed a kernel update in that update set was part of the problem, and I have tried installing fglrx, fglrx-updates, and the latest version from AMD directly with no success so far.

I don't mind working with the radeon driver at this point, but I am still having troubles.

I have no idea if the problems are related to the GL or not, but I would like to get GL running properly using the radeon driver.

It appears that the nvida-installer-cleanup package is missing, and that is why the glx-diversions wont install. I am hoping to find a debian or ubuntu PPA source to install that package as a short term solution.

hardboot (hardwareguy) wrote :

Tried on 12.10 and 13.04, as mentioned the deps are broken.

This is a simple useful tool that package allows you to do "update-alternatives --config glx".
Without it (glx-alternative-fglrx) in my case, I have to manuallly send glx to the AMD driver using pkg-config to compile opengl stuff.

Graham Inggs (ginggs) on 2013-06-03
description: updated
summary: - glx-alternative-mesa and glx-diversions cannot be installed.
+ Please remove and blacklist glx-alternatives
Daniel Holbach (dholbach) wrote :

ACKed.

Stéphane Graber (stgraber) wrote :

Removed from saucy.

Changed in glx-alternatives (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers