Upgrade glusterfs to 3.0.4

Bug #577216 reported by agent 8131
28
This bug affects 5 people
Affects Status Importance Assigned to Milestone
glusterfs (Ubuntu)
Fix Released
Wishlist
Unassigned
Declined for Lucid by Sebastien Bacher
Declined for Maverick by Sebastien Bacher

Bug Description

changes:
http://ftp.gluster.com/pub/gluster/glusterfs/3.0/3.0.3/GlusterFS_3.0.3_Release_Notes.pdf
http://ftp.gluster.com/pub/gluster/glusterfs/3.0/3.0.4/GlusterFS_3.0.4_Release_Notes.pdf

I've found 3.0.2 to be very buggy. I'm using 3.0.4 from Debian Squeeze but it's too early to tell if it's any better. Still the reported bugs fixed in 3.0.3 and 3.0.4 seem important.

aXe1 (axe1)
Changed in glusterfs (Ubuntu):
status: New → Confirmed
Revision history for this message
Gionn (giovanni.toraldo) wrote :

Please upgrade or make a backport, glusterfs 3.0.2 is almost useless on lucid!

Revision history for this message
Gionn (giovanni.toraldo) wrote :

I've backported it on my PPA ppa:giovanni.toraldo/ppa https://launchpad.net/~giovanni.toraldo/+archive/ppa

Revision history for this message
Sebastien Bacher (seb128) wrote :

it's fixed now

Changed in glusterfs (Ubuntu):
importance: Undecided → Wishlist
status: Confirmed → Fix Released
Revision history for this message
Deadpan110 (deadpan110) wrote :

Is this still not available for Lucid (LTS)?

I have a 3 node cluster using glusterfs and badly need to fix the following bug:

[2010-10-09 09:07:05] W [posix.c:246:posix_lstat_with_gen] posix2: Access to /mn
t/data/mirror//.. (on dev 51712) is crossing device (51744)
[2010-10-09 09:07:15] W [posix.c:246:posix_lstat_with_gen] posix1: Access to /mn
t/data/stripe//.. (on dev 51712) is crossing device (51728)

This is a known issue with version 3.0.2 and an upgrade to 3.0.4 should be reconsidered for an LTS release.

Start of one (of a few) threads discussing the problem and a fix dated May 2010 here:

http://<email address hidden>/msg06840.html

The problem no longer occurs with version 3.0.4.

Revision history for this message
SaltwaterC (saltwaterc) wrote :

Is this going to be backported or we still need to rely on PPAs for a "fix"? Maybe I am missing the point, but doesn't LTS stand for Long Term *Support*? This one of the reasons to pick Lucid in the first place, but the reasons go thinner and thinner with every: "there's a PPA for that issue". I am not asking for the latest and greatest features to be included into a LTS since that is supposedly a stable release that takes a more conservative approach. But at least some maintenance releases of certain software that proves to be buggy should be considered.

Revision history for this message
Deadpan110 (deadpan110) wrote :

Now 2 days old - the latest glusterfs version 3.1 is out, it addresses many more old issues and has better performance than previous versions and a nice CLI to boot.

They provide Ubuntu amd64.debs for 64 bit platforms:
http://ftp.gluster.com/pub/gluster/glusterfs/3.1/LATEST/Ubuntu/

I have spoken with the friendly people on the mailing list and can confirm that building from source on 32bit is working for me.

After my last posting here, I was using Giovanni's PPA but the curiosity of the latest version got the better of me.
https://launchpad.net/~giovanni.toraldo/+archive/ppa

Agreed about the whole LTS situation, bumping to 3.0.4/5 should be reconsidered otherwise there is no point in keeping glusterfs 3.0.2 within the Ubuntu repositories - it would be safer for end users if it was simply removed.

As for version 3.1 on 32bit, I will link to a howto shorty if anyone is interested.

Revision history for this message
SaltwaterC (saltwaterc) wrote :

The GlusterFS team doesn't recommend 32-bit builds due to lack of QA. But of course, people can try. I'd still not use 32-bit builds on production machines.

Anyway, thanks for the info. Since 3.0.2 broke pretty ugly on our production cluster, working around this LTS thing is the only alternative for the moment.

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers