Glom should depend on postgresql-8.3

Bug #188939 reported by Murray Cumming
6
Affects Status Importance Assigned to Milestone
glom (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: glom

Ubuntu Hardy Heron is using postgresql-8.3 instead of 8.2, but Glom in Hardy Heron still depends on postgresql-8.2.

It should depend on 8.3, though you will need to use the --with_postgres_utils=thepath configure option to do so.

Related branches

Changed in glom:
assignee: nobody → protonchris
status: New → In Progress
Revision history for this message
Murray Cumming (murrayc) wrote :

By the way, I have just released Glom 1.6.8, which you probably want to package at the same time. I thought I had released it a few days ago, but I forgot a step.

Revision history for this message
Chris Brotherton (protonchris) wrote :

Unfortunately, the latest versions of glom rely on versions of libgdamm and libgda that are newer than the versions available in hardy.

Revision history for this message
Murray Cumming (murrayc) wrote :

So what do you want me to do? File bugs for those too?

Revision history for this message
Chris Brotherton (protonchris) wrote :

I filed a bug for upgrading the libgdamm package:

https://bugs.launchpad.net/ubuntu/+source/libgdamm3.0/+bug/190744

I plan on fixing that bug in the near future.

libgda3 is in main and is synced from Debian. So a bug will probably need to be submitted to Debian. After the Debian package gets updated, a sync request can be submitted to Ubuntu.

Revision history for this message
Chris Brotherton (protonchris) wrote :
Revision history for this message
Chris Brotherton (protonchris) wrote :

Updated debdiff with a new changelog (typo fixed).

Package builds and installs without issue on hardy.

Thanks.

Changed in glom:
assignee: protonchris → nobody
status: In Progress → Confirmed
Revision history for this message
Daniel Holbach (dholbach) wrote :

Regarding comment 4: we can as well update gda ourselves if there are good reasons - no need to block on Debian, although it's nice to be in sync.

Revision history for this message
Daniel Holbach (dholbach) wrote :

I just tried the patch and it seems that the new gda/gdamm/glom versions are necessary to properly work with postgres8.3 - did anybody get it working with just the versions in the archive?

Revision history for this message
Murray Cumming (murrayc) wrote :

The libgda update is useful - it allows passwords to contain whitespace, for instance.

I am not aware of a problem with postgres 8.3 - I haven't actually tried it with postgres 8.3 yet.

Revision history for this message
Chris Brotherton (protonchris) wrote :

I was able to use glom (updated package) with postgresql 8.3. Attached is the console log that occurred while I was using it. It looks like there was some XML issues. Murray, what do you think of those errors.

I also tried to use glom (current package) with postgresql 8.2, but it had trouble connecting to the server.

Daniel, does this answer your question?

Thanks.

Revision history for this message
Daniel Holbach (dholbach) wrote :

Looks like this is an unrelated problem. Uploading.

Still it might be worth though getting the new libgda, libgdamm and glom into Ubuntu.

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package glom - 1.6.6-0ubuntu2

---------------
glom (1.6.6-0ubuntu2) hardy; urgency=low

  * Fixed package so that it depends on the hardy version of postgresql (8.3)
    (LP: #188939)

 -- Christopher Brotherton <email address hidden> Sun, 10 Feb 2008 16:44:56 -0700

Changed in glom:
status: Confirmed → Fix Released
Revision history for this message
Murray Cumming (murrayc) wrote :

Thanks

> It looks like there was some XML issues. Murray, what do you think of those errors.

I guess you mean this:

STATEMENT: SELECT "glom_system_autoincrements"."next_value" FROM "glom_system_autoincrements" WHERE "table_name" = '83test' AND "field_name" = '83test_id'

(glom:6174): glibmm-CRITICAL **:
unhandled exception (type Glib::Error) in signal handler:
domain: gda_connection_error
code : 6
what : ERROR: operator does not exist: xml = unknown
LINE 1: ...M "glom_system_autoincrements" WHERE "table_name" = '83test'...
                                                             ^
HINT: No operator matches the given name and argument type(s). You might need to add explicit type casts.

I haven't seen that before and I don't understand it yet, but I will switch to Postgres 8.3 and investigate. Did this only happen with glom 1.6.8? Or was there another reason that you only packaged 1.6.6 again?

 If you could get the latest libgda 3.0.x and libgdamm versions in Ubuntu then that would make the picture clearer.

Revision history for this message
Murray Cumming (murrayc) wrote :

By the way, I already packaged the latest versions for Gutsy in our PPA
https://launchpad.net/~openismus-team/+archive
(using PostgreSQL 8.2)
and there are no problems.

Revision history for this message
Murray Cumming (murrayc) wrote :

glom 1.6.10 (just released) fixes that "xml" error. It only happened with postgres 8.3.

I notice that glom 1.6.9 in Ubuntu Hardy already depends on postgres 8.3, so this really needs to be updated.

Revision history for this message
StefanPotyra (sistpoty) wrote :

Yes, ACK #1 from me.

Revision history for this message
Chris Brotherton (protonchris) wrote :

A new bug has been opened for updating glom from 1.6.9 -> 1.6.10.

https://bugs.launchpad.net/bugs/204039

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions