Candidate revision glipper_2.1-0ubuntu1 (adds app indicator support, old version does not work with Unity)

Bug #754632 reported by Laszlo Pandy on 2011-04-08
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
glipper (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: glipper

A new upstream version of glipper is available:
http://launchpad.net/glipper/+download

The debian/ directory, updated from the current universe package, is available in upstream bzr:
https://code.launchpad.net/~glipper-drivers/glipper/trunk

A package for testing is available in the PPA:
https://launchpad.net/~glipper-drivers/+archive/ppa

Glipper 1.0 (the current version in universe) is a GNOME panel applet and thus does not work at all in Unity.
Glipper 2.0 uses an app indicator and has been tested with Unity.

Related branches

Laszlo Pandy (laszlok) on 2011-04-09
Changed in glipper (Ubuntu):
status: New → Confirmed
Laszlo Pandy (laszlok) on 2011-04-21
summary: - Candidate revision glipper_2.0-1ubuntu1
+ Candidate revision glipper_2.0-1ubuntu1 (adds app indicator support, old
+ version does not work with Unity)
description: updated

From a sponsoring point of view, I'd just change a few small things:
 - 'maverick' → 'natty'
 - re-add natty changelog entry
 - change 'Architecture' to 'all' - there's just architecture-independent files in the package

Laszlo Pandy (laszlok) wrote :

The patch has been applied in upstream bzr. But I don't think I can re-upload to the PPA without bumping the version number.

summary: - Candidate revision glipper_2.0-1ubuntu1 (adds app indicator support, old
+ Candidate revision glipper_2.1-0ubuntu1 (adds app indicator support, old
version does not work with Unity)
Martin Pitt (pitti) wrote :

Approved FFE-wise, as this doesn't work with the default desktop environment now. (*Grumble* about deliberately breaking compatibility here..)

Daniel Holbach (dholbach) wrote :

Uploaded. Sitting in the queue.

Changed in glipper (Ubuntu):
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package glipper - 2.1-0ubuntu1

---------------
glipper (2.1-0ubuntu1) natty; urgency=low

  * New upstream release. (LP: #754632)
  * Add python-xdg dependency.
  * Add python-appindicator dependency missing from the 2.0 package.

glipper (2.0-1ubuntu1) maverick; urgency=low

  * New upstream release.
  * debian/control:
    + Change homepage to new launchpad.net project.
    + Update standards version to 3.9.1.
    + Update long description to reflect that a GNOME applet is no longer used.
    + Update dependencies for new release (remove gnomeapplet, add appindicator).
    + Update build dependencies for new upstream build system (python-distutils).
  * debian/copyright:
    + Add new upstream author.
    + Change download location to new launchpad.net project.
  * debian/compat:
    + Update to debhelper 7.
  * debian/rules:
    + Remove all rules and replace with debhelper template because upstream build system has changed.
  * debian/watch:
    + Update to new download location on launchpad.net.
  * debian/docs:
    + Remove TODO and NEWS; they no longer exist upstream.
  * debian/glipper.NEWS:
    + Add new upstream version description.
 -- Laszlo Pandy <email address hidden> Wed, 13 Apr 2011 12:19:50 +0200

Changed in glipper (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Patches