Comment 1 for bug 1841793

Good morning Sebastien,

can you please describe why is it a problem to upgrade Glibmm?

We are affected by an issue in the current version (2.58). After some changes in GTK+ theme mechanisms in order to be able to configure the CSS class names properly it is important to be able to call gtk_widget_class_set_css_name() in the object instance init function.

However, this was not possible until Glibmm team add the support to this in version 2.60. Without these change there is no way to solve the problem. The discussion about this can be found in GNOME issue tracking:

https://gitlab.gnome.org/GNOME/glibmm/issues/33
https://gitlab.gnome.org/GNOME/gtkmm/issues/17