Don't update to 2.65.3

Bug #1841793 reported by Sebastien Bacher on 2019-08-28
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
glibmm2.4 (Ubuntu)
Wishlist
Unassigned

Bug Description

The .news entry starts with

'2.63.1: (unstable):
Distro packagers should probably not package this yet.'

Let's follow upstream's advice there

Changed in glibmm2.4 (Ubuntu):
status: New → Triaged
Alejandro Claro (aclaro) wrote :

Good morning Sebastien,

can you please describe why is it a problem to upgrade Glibmm?

We are affected by an issue in the current version (2.58). After some changes in GTK+ theme mechanisms in order to be able to configure the CSS class names properly it is important to be able to call gtk_widget_class_set_css_name() in the object instance init function.

However, this was not possible until Glibmm team add the support to this in version 2.60. Without these change there is no way to solve the problem. The discussion about this can be found in GNOME issue tracking:

https://gitlab.gnome.org/GNOME/glibmm/issues/33
https://gitlab.gnome.org/GNOME/gtkmm/issues/17

Alejandro, this bug is simply a note about early development releases like 2.61.1 and 2.63.1. The bug is to help the Ubuntu Desktop Team track out-of-date packages more effectively.

This bug does not have anything to do with updating stable versions of glibmm which are found in even numbers like 2.58, 2.60, etc.

Ubuntu 19.10 will be released in 2 weeks with glibmm 2.60 available.

summary: - Don't update to 2.61.1
+ Don't update to 2.631
description: updated
tags: added: version-skip-2.63.1
removed: version-skip-2.61.1
Alejandro Claro (aclaro) wrote :

Thank you for your answer Jeremy. Now it's clear to me.

summary: - Don't update to 2.631
+ Don't update to 2.63
summary: - Don't update to 2.63
+ Don't update to 2.63.1
Jeremy Bicha (jbicha) on 2020-03-29
tags: added: version-skip-2.65.3
removed: version-skip-2.63.1
summary: - Don't update to 2.63.1
+ Don't update to 2.65.3
Alejandro Claro (aclaro) wrote :

Please can somebody indicate whether this is still an issue or not?

We have some products that cannot be upgraded to Ubuntu 20.04 yet, and the version of Glibmm in Ubuntu 1804 (Glibmm 2.56) has some important compatibility issues after some design changes in glib. The mechanisms to solve this issue were introduced in Glibmm 2.60:

https://developer.gnome.org/glibmm/2.60/classGlib_1_1ExtraClassInit.html

I would like to ask to please increase the version in Ubuntu 18.04, to at least Glibmm 2.60 or to include a patch to introduce the solution. The patch is included in this issue report:

https://bugs.launchpad.net/ubuntu/+source/glibmm2.4/+bug/1846699

Sebastien Bacher (seb128) wrote :

@Alejandro, the issue you are having hasn't to do with the report you are commiting on, recent series of Ubuntu have > 2.60 version, the report here is specifically to document to ignore a currently unstable serie

Alejandro Claro (aclaro) wrote :

Thanks @sebastien!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.