ipv6 link local address lookup broken

Bug #374674 reported by AndrewD on 2009-05-11
34
This bug affects 5 people
Affects Status Importance Assigned to Milestone
glibc (Ubuntu)
Undecided
Unassigned

Bug Description

glibc 2.9 correctly handles lookup of IPV4 and IPV6 addresses in a mixed IPV4/IPV6 environment, see comments in the debian bug report: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=435646.

However Ubuntu still applies a hack glibc-2.9/debian/patches/any/local-ipv6-lookup.diff that completely disables IPV6 lookup if there are no routable IPV6 interfaces.

This causes problems. For example we use a mixture of link local IPV6 for local devices, while only using IPV4 for our network gateway.

With the above hack applied nc6, for example, can not communicate with link local IPV6 devices. (See also http://www.honeynet.org/node/251)

It appears that the correct fix is to just remove the local-ipv6-lookup.diff patch.

Related branches

Thierry Carrez (ttx) wrote :

For those interested, for testing purposes on Jaunty, I've a glibc update in my PPA that just has that patch removed:
https://launchpad.net/~ttx/+archive/ppa

This was done as part of investigating if this patch over 2.9 would not explain multiple reports of _nss_*_gethostbyname2_r() SIGSEGVs in Jaunty/Karmic.

AndrewD (andrewd-lists) wrote :

Excellent - "works for me".

nc6 and a local build of tftp-hpa-5.0 (for IPV6 support) now correctly resolve names to link local ipv6 devices advertised with dns-sd.

Patrick (oc3an) wrote :

Works for me too.

This also fixes #239701 https://bugs.launchpad.net/bugs/239701

-Patrick

Matthias Klose (doko) wrote :

eglibc (2.10.1-0ubuntu2) karmic; urgency=low

  * Merge with Debian (r3733, eglibc-2.10 branch).
  * Update to r8758 from the eglibc-2.10 branch.
  * Remove testcases from expected results, which don't fail anymore (ia64).
  * Mark test-memchr.out as failing on sparc.
  * patches/any/local-ipv6-lookup.diff: Don't apply. LP: #239701, #374674.
  * Work around Ubuntu buildd limitation: allow just 2.6.15 for libc6
    installation, although 2.6.18 is required for some patches (requested by
    soyuz maintainers).

 -- Matthias Klose < <email address hidden>> Tue, 04 Aug 2009 00:36:31 +0200

Changed in glibc (Ubuntu):
status: New → Fix Released
Laurent Bigonville (bigon) wrote :

Reopening as the patch has been reverted to fix bug #417757

Changed in glibc (Ubuntu):
status: Fix Released → New
Emmet Hikory (persia) on 2010-03-10
tags: added: ipv6
Ewout van der Linden (ewout-xt) wrote :

This also causes Samba not to bind to ipv6 on startup. Im using IPv6 stateless autoconfiguration, at bootup there is a moment when there is no ipv6 address configured yet, making getaddrinfo() fail with "Address family for hostname not supported".

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in glibc (Ubuntu):
status: New → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers