package akonadi-server 1.1.1-0ubuntu2~intrepid2 failed to install/upgrade: /usr/sbin/nscd: relocation error: /usr/sbin/nscd: symbol __nss_services_lookup, version GLIBC_PRIVATE not defined in file libc.so.6 with link time reference

Bug #338431 reported by fejes on 2009-03-05
2
Affects Status Importance Assigned to Milestone
glibc (Debian)
Fix Released
Unknown
glibc (Ubuntu)
Undecided
Unassigned

Bug Description

Simple upgrade (update-manager -d) from Hardy to Intrepid on an un-remarkable box. Not sure what else to add.

ProblemType: Package
Architecture: i386
DistroRelease: Ubuntu 8.10
ErrorMessage: dependency problems - leaving unconfigured
NonfreeKernelModules: nvidia
Package: akonadi-server 1.1.1-0ubuntu2~intrepid2
SourcePackage: akonadi
Title: package akonadi-server 1.1.1-0ubuntu2~intrepid2 failed to install/upgrade: dependency problems - leaving unconfigured
Uname: Linux 2.6.24-23-generic i686

fejes (anthony-fejes) wrote :
Jonathan Thomas (echidnaman) wrote :

It looks like this was caused by MySQL failing to upgrade:

Selecting previously deselected package mysql-server-5.0.
(Reading database ... 345024 files and directories currently installed.)
Unpacking mysql-server-5.0 (from .../mysql-server-5.0_5.0.67-0ubuntu6_i386.deb) ...
/usr/sbin/nscd: relocation error: /usr/sbin/nscd: symbol __nss_services_lookup, version GLIBC_PRIVATE not defined in file libc.so.6 with link time reference
/usr/sbin/nscd: relocation error: /usr/sbin/nscd: symbol __nss_services_lookup, version GLIBC_PRIVATE not defined in file libc.so.6 with link time reference
/usr/sbin/nscd: relocation error: /usr/sbin/nscd: symbol __nss_services_lookup, version GLIBC_PRIVATE not defined in file libc.so.6 with link time reference
/usr/sbin/nscd: relocation error: /usr/sbin/nscd: symbol __nss_services_lookup, version GLIBC_PRIVATE not defined in file libc.so.6 with link time reference
/usr/sbin/nscd: relocation error: /usr/sbin/nscd: symbol __nss_services_lookup, version GLIBC_PRIVATE not defined in file libc.so.6 with link time reference
adduser: The group `mysql' does not exist.
dpkg: error processing /var/cache/apt/archives/mysql-server-5.0_5.0.67-0ubuntu6_i386.deb (--unpack):
 subprocess pre-installation script returned error exit status 1

Mathias Gug (mathiaz) wrote :

This is an issue related to nscd and libc6.

Changed in glibc (Debian):
status: Unknown → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.