debconf fails to upgrade to 1.5.21

Bug #235581 reported by Michael Legart on 2008-05-28
2
Affects Status Importance Assigned to Milestone
glibc (Ubuntu)
High
Unassigned

Bug Description

Binary package hint: debconf

during upgrade of intrepid:

Preparing to replace debconf 1.5.20 (using .../debconf_1.5.21_all.deb) ...
xargs: xargs.c:443: main: Assertion `bc_ctl.arg_max <= (131072-2048)' failed.
Aborted
dpkg: warning - old pre-removal script returned error exit status 134
dpkg - trying script from the new package instead ...
xargs: xargs.c:443: main: Assertion `bc_ctl.arg_max <= (131072-2048)' failed.
Aborted
dpkg: error processing /var/cache/apt/archives/debconf_1.5.21_all.deb (--unpack):
 subprocess new pre-removal script returned error exit status 134
Errors were encountered while processing:
 /var/cache/apt/archives/debconf_1.5.21_all.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

Colin Watson (cjwatson) wrote :

We established on IRC this morning that libc6 needs to Breaks: findutils (<< 4.4.0-2ubuntu2). In the meantime, forcing an upgrade of findutils first ought to do it.

Changed in debconf:
importance: Undecided → High
status: New → Confirmed
Michael Legart (michael-legart) wrote :

That worked for me. Thanks for the prompt response!

Michael

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers