cannot install libc6-dev, requires old libc6 version

Bug #1926918 reported by Jim Salter on 2021-05-02
This bug affects 3 people
Affects Status Importance Assigned to Milestone
glibc (Ubuntu)

Bug Description

Current version of libc6:amd64 in Focal is 2.31-0ubuntu9.3. libc6-dev requires 2.31-0ubuntu9.2 **only**. This prevents installation of libc6-dev (as originally discovered while trying to install build-essential, which also requires libc6-dev).

root@nel-lg-gram:/home/nel# apt -f install libc6-dev
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 libc6-dev : Depends: libc6 (= 2.31-0ubuntu9.2) but 2.31-0ubuntu9.3 is to be installed
E: Unable to correct problems, you have held broken packages.
root@nel-lg-gram:/home/nel# dpkg --get-selections | grep libc6
libc6:amd64 install
libc6-dbg:amd64 install
root@nel-lg-gram:/home/nel# apt policy libc6
  Installed: 2.31-0ubuntu9.3
  Candidate: 2.31-0ubuntu9.3
  Version table:
 *** 2.31-0ubuntu9.3 100
        100 /var/lib/dpkg/status
     2.31-0ubuntu9.2 500
        500 focal-updates/main amd64 Packages
     2.31-0ubuntu9 500
        500 focal/main amd64 Packages

ProblemType: Bug
DistroRelease: Ubuntu 20.04
Package: libc6-dev (not installed)
ProcVersionSignature: Ubuntu 5.8.0-50.56~20.04.1-generic 5.8.18
Uname: Linux 5.8.0-50-generic x86_64
ApportVersion: 2.20.11-0ubuntu27.16
Architecture: amd64
CasperMD5CheckResult: skip
Date: Sun May 2 17:58:02 2021
InstallationDate: Installed on 2020-10-31 (183 days ago)
InstallationMedia: Ubuntu 20.04.1 LTS "Focal Fossa" - Release amd64 (20200731)
 PATH=(custom, no user)
SourcePackage: glibc
UpgradeStatus: No upgrade log present (probably fresh install)

Jim Salter (jrssnet) wrote :
Balint Reczey (rbalint) wrote :

Please downgrade libc6 to the version in focal-updates. The one installed has been removed from -updates because it caused regressions and the new version superseding 2.31-0ubuntu9.3 is not yet released.

Balint Reczey (rbalint) on 2021-05-03
Changed in glibc (Ubuntu):
status: New → In Progress
Jim Salter (jrssnet) wrote :

Balint, what is the accepted method to downgrade an installed package to a prior version? I can think of three or four ways to accomplish it, but I can think of ways it could bite me in the butt having done so just as easily. :)

This is especially a problem for this particular package, because simply removing libc6 would break enormous swathes of the system...

Gunnar Hjalmarsson (gunnarhj) wrote :

Try this:

sudo apt install libc6=2.31-0ubuntu9.2

Martin Ritter (martin-ritter) wrote :

I have to ask: Why wasn't the update reverted and not just withdrawn?

Especially if it causes regressions I would have assumed that there is something like `2.31-0ubuntu9.3+really9.2` to be pushed into updates to allow for smooth transitions out of the broken version.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers