Netboot Loading libc6-udeb failed for unknown reasons (focal) 2020-04-21

Bug #1926223 reported by papamoose
102
This bug affects 31 people
Affects Status Importance Assigned to Milestone
debian-installer
New
Undecided
Unassigned
debian-installer (Ubuntu)
Undecided
Unassigned
glibc (Ubuntu)
Undecided
Unassigned

Bug Description

With the netboot image from 2020-04-21 (http://archive.ubuntu.com/ubuntu/dists/focal/main/installer-amd64/current/legacy-images/netboot/) it shows me following error at partition disk space step

          ???????????????????? [!!] Detect disks ?????????????????????
          ? ?
          ? Failed to load installer component ?
          ? Loading libc6-udeb failed for unknown reasons. Aborting. ?
          ? ?
          ? <Go Back> <Continue> ?
          ? ?
          ????????????????????????????????????????????????????????????

I am unable to preseed install via PXE because of this.

This bug seems to be identical to previous reports which got fixed in the past.
https://bugs.launchpad.net/ubuntu/+source/debian-installer/+bug/1867502

Revision history for this message
papamoose (papam0ose) wrote :

While the bug seems to be identical to 1867502, because it was fixed (2020-03-17) and working for a whole year and now (2021-04-21) broke with the release of a new netboot image I would consider this a new bug. The fix may be the same.

Revision history for this message
Chris Guiver (guiverc) wrote :

A known & trusted user reported the other bug fixed on 2020-03-18, but the bug did not reach CONFIRMED status until 2020-03-20 (two days after the 'fixed' report).

The other bug is still OPEN & has a CONFIRMED status.

This bug report has yet to be confirmed, so I'll treat it as unique.

Thank you for taking the time to report this bug and helping to make Ubuntu better. Please execute the following command only once, as it will automatically gather debugging information, in a terminal:

apport-collect 1926223

When reporting bugs in the future please use apport by using 'ubuntu-bug' and the name of the package affected. You can learn more about this functionality at https://wiki.ubuntu.com/ReportingBugs.

Revision history for this message
Marcel (mkcionix) wrote :

I can confirm this bug. It bricked yesterday, right after the changes to the libc6-udeb package
https://launchpad.net/ubuntu/focal/amd64/libc6-udeb.

Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in debian-installer (Ubuntu):
status: New → Confirmed
Revision history for this message
Steven Clarkson (sclarkson) wrote :

This is caused by the libc update done in LP: #1914044

My workaround is to put this line in my early_command

sed -i -e '/Package: libc6-udeb/{N;N;s/Version: 2.31-0ubuntu9.*/Version: 2.31-0ubuntu9.3/}' /var/lib/dpkg/status

Revision history for this message
papamoose (papam0ose) wrote :

@sclarkson: I can confirm that your early command does work around the problem:

`d-i preseed/early_command string \
  sed -i -e '/Package: libc6-udeb/{N;N;s/Version: 2.31-0ubuntu9.*/Version: 2.31-0ubuntu9.3/}' /var/lib/dpkg/status`

@guiverc: Unfortunately tty 2 and 3 won't load to run the command.
'-/bin/sh: error while loading shared libraries: __vdso_gettimeofday: invalid mode for dlopen(): Invalid argument'

Steven Clarkson wrote verified this outside the debian-installer as well: https://bugs.launchpad.net/ubuntu/+source/glibc/+bug/1914044/comments/16

Revision history for this message
Jakuro (jakuro) wrote :

@sclarkson: Can you explain how this fix works? As it doesn't work for me. For me there is error in retrieving version 2.31-0ubuntu9.3 and your sed is changing 9>* to 9.3.

Revision history for this message
Brandon Wade (brandonwade) wrote :

I can also confirm this bug. I can also confirm that the workaround proposed by @sclarkson is not working for our environment either. This bug is preventing our organization from installing unattended via PXE. A more bulletproof workaround or fix is most desired.

Revision history for this message
Brandon Wade (brandonwade) wrote :

EDIT: After further troubleshooting, and finding a typo in the preseed file, I can also confirm that the workaround proposed by @sclarkson is working successfully by allowing the installation to complete without error.

Revision history for this message
Steven Clarkson (stvnclarkson) wrote :

@Jakuro: This just tricks udpkg in the install environment into thinking that it is already at 2.31-0ubuntu9.3 so it doesn't try to update, and therefore doesn't fail. It's is 9.* to catch 9 in the focal installer and 9.2 in the focal-updates installer.

A simpler sed is probably sufficient, and less prone to typos. This one is untested, though.

sed -i -e 's/Version: 2.31-0ubuntu9.*/Version: 2.31-0ubuntu9.3/' /var/lib/dpkg/status

Revision history for this message
papamoose (papam0ose) wrote :

Not sure if this is correct for this case but it looks like in the past an updated netboot image was provided which listed the updated version of libc6-udeb.

diff ubuntu/dists/focal/main/installer-amd64/current/legacy-images/udeb.list ubuntu/dists/focal-updates/main/installer-amd64/current/legacy-images/udeb.list |grep libc6-udeb
< libc6-udeb 2.31-0ubuntu9 amd64
> libc6-udeb 2.31-0ubuntu9.2 amd64

Revision history for this message
Balint Reczey (rbalint) wrote :

Thanks for the bug report. The glibc update has been moved back to focal-proposed thus the netboot image should work again.

Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in glibc (Ubuntu):
status: New → Confirmed
Revision history for this message
papamoose (papam0ose) wrote :

I can confirm that preseeding works now without @sclarkson's workaround.

Balint Reczey (rbalint)
Changed in glibc (Ubuntu):
assignee: nobody → Balint Reczey (rbalint)
status: Confirmed → In Progress
Balint Reczey (rbalint)
tags: added: regression-update
Balint Reczey (rbalint)
Changed in glibc (Ubuntu):
assignee: Balint Reczey (rbalint) → nobody
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers