glibc: backport "Add x86_64 to x86-64 HWCAP" for 17.10

Bug #1718928 reported by Marc Di Luzio on 2017-09-22
14
This bug affects 3 people
Affects Status Importance Assigned to Milestone
glibc (Ubuntu)
Undecided
Adam Conrad

Bug Description

glibc 2.26 regressed in terms of which subdirectories ld searched in for shared libraries.

The commit to fix this can be found here:

https://sourceware.org/git/gitweb.cgi?p=glibc.git;a=log;h=45ff34638f034877b6a490c217d6a0632ce263f4

This could cause issues in rare cases of apps using x86_86 subdirectories for multi-lib applications. In our case it breaks loading of Feral games without the above fix.

See https://github.com/FeralInteractive/ferallinuxscripts/issues/3#issuecomment-331426359 for reports more details.

Based on https://launchpad.net/ubuntu/artful/+source/glibc/+changelog it looks like this change hasn't been backported to 17.10's 2.26 version yet.

Julian Taylor (jtaylor) on 2017-09-22
Changed in glibc (Ubuntu):
status: New → Confirmed
Marc Di Luzio (mdiluzio-feral) wrote :

Since this is a fix for a breaking change, do we know if this well be fixed before 17.10 gets a final release?

Jeremy Bicha (jbicha) wrote :
Changed in glibc (Ubuntu):
status: Confirmed → Fix Committed
Adam Conrad (adconrad) on 2017-10-12
Changed in glibc (Ubuntu):
assignee: nobody → Adam Conrad (adconrad)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package glibc - 2.26-0ubuntu2

---------------
glibc (2.26-0ubuntu2) artful; urgency=medium

  * Cherry-pick some changes from Debian git for a few pending Ubuntu bugfixes:
    - Update to master and drop redundant submitted-tst-tlsopt-powerpc.diff.
    - debian/patches/any/local-cudacc-float128.diff: Local patch to prevent
      defining __HAVE_FLOAT128 on NVIDIA's CUDA compilers (LP: #1717257)
    - debian/patches/arm/git-arm64-memcmp.diff: Backport optimized memcmp
      for AArch64, improving performance from 25% to 500% (LP: #1720832)
    - debian/patches/amd64/git-x86_64-search.diff: Backport upstream commit
      to put x86_64 back in the search path, like in 2.25 (LP: #1718928)
    - debian/rules.d/debhelper.mk: Filter python hooks in stage1 (LP: #1715366)

 -- Adam Conrad <email address hidden> Wed, 11 Oct 2017 14:21:40 -0600

Changed in glibc (Ubuntu):
status: Fix Committed → Fix Released
Marc Di Luzio (mdiluzio-feral) wrote :

Great news, thank you

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers