package libc-bin 2.23-0ubuntu3 [modified: sbin/ldconfig.real usr/bin/catchsegv usr/bin/getconf usr/bin/getent usr/bin/iconv usr/bin/ldd usr/bin/locale usr/bin/localedef usr/bin/pldd usr/bin/tzselect usr/bin/zdump usr/sbin/iconvconfig usr/sbin/zic] failed to install/upgrade: package libc-bin is not ready for configuration cannot configure (current status 'half-installed')

Bug #1694944 reported by Akarsh Sinha on 2017-06-01
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
glibc (Ubuntu)
Undecided
Unassigned

Bug Description

Upon doing : sudo apt-get install git

I received the following :

Reading package lists... Done
Building dependency tree
Reading state information... Done
The following additional packages will be installed:
  git-man liberror-perl
Suggested packages:
  git-daemon-run | git-daemon-sysvinit git-doc git-el git-email git-gui gitk gitweb git-arch
  git-cvs git-mediawiki git-svn
The following NEW packages will be installed:
  git git-man liberror-perl
0 upgraded, 3 newly installed, 0 to remove and 390 not upgraded.
2 not fully installed or removed.
Need to get 4451 kB of archives.
After this operation, 25,6 MB of additional disk space will be used.

Do you want to continue? [Y/n] y

Get:1 http://nl.archive.ubuntu.com/ubuntu xenial/main amd64 libc-bin amd64 2.23-0ubuntu3 [627 kB]
Get:2 http://nl.archive.ubuntu.com/ubuntu xenial/main amd64 liberror-perl all 0.17-1.2 [19,6 kB]
Get:3 http://nl.archive.ubuntu.com/ubuntu xenial-updates/main amd64 git-man all 1:2.7.4-0ubuntu1.1 [735 kB]
Get:4 http://nl.archive.ubuntu.com/ubuntu xenial-updates/main amd64 git amd64 1:2.7.4-0ubuntu1.1 [3068 kB]
Fetched 4451 kB in 1s (2985 kB/s)
dpkg: error processing package libc-bin (--configure):
 package libc-bin is not ready for configuration
 cannot configure (current status 'half-installed')
E: Sub-process /usr/bin/dpkg returned an error code (1)

ProblemType: Package
DistroRelease: Ubuntu 16.04
Package: libc-bin 2.23-0ubuntu3 [modified: sbin/ldconfig.real usr/bin/catchsegv usr/bin/getconf usr/bin/getent usr/bin/iconv usr/bin/ldd usr/bin/locale usr/bin/localedef usr/bin/pldd usr/bin/tzselect usr/bin/zdump usr/sbin/iconvconfig usr/sbin/zic]
ProcVersionSignature: Ubuntu 4.4.0-31.50-generic 4.4.13
Uname: Linux 4.4.0-31-generic x86_64
ApportVersion: 2.20.1-0ubuntu2.1
Architecture: amd64
Date: Thu Jun 1 11:45:46 2017
Dependencies:
 gcc-6-base 6.0.1-0ubuntu1
 libc6 2.23-0ubuntu7
 libgcc1 1:6.0.1-0ubuntu1
DpkgTerminalLog:
 dpkg: error processing package libc-bin (--configure):
  package libc-bin is not ready for configuration
  cannot configure (current status 'half-installed')
ErrorMessage: package libc-bin is not ready for configuration cannot configure (current status 'half-installed')
InstallationDate: Installed on 2017-05-31 (0 days ago)
InstallationMedia: Ubuntu 16.04.1 LTS "Xenial Xerus" - Release amd64 (20160719)
RelatedPackageVersions:
 dpkg 1.18.4ubuntu1.1
 apt 1.2.12~ubuntu16.04.1
SourcePackage: glibc
Title: package libc-bin 2.23-0ubuntu3 [modified: sbin/ldconfig.real usr/bin/catchsegv usr/bin/getconf usr/bin/getent usr/bin/iconv usr/bin/ldd usr/bin/locale usr/bin/localedef usr/bin/pldd usr/bin/tzselect usr/bin/zdump usr/sbin/iconvconfig usr/sbin/zic] failed to install/upgrade: package libc-bin is not ready for configuration cannot configure (current status 'half-installed')
UpgradeStatus: No upgrade log present (probably fresh install)

Akarsh Sinha (akarshsinha) wrote :
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers