libc6:i386 failed to install/upgrade (related to epson-inkjet-printer-escpr)

Bug #1639818 reported by doylep on 2016-11-07
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
glibc (Ubuntu)
Undecided
Unassigned

Bug Description

Installing epson-inkjet-printer-escpr caused a failed installation of libc6:i386 (and libgcc1:i386). epson-inkjet-printer-escpr itself failed to install (due to the dependency on libc6 and libgcc1), and dpkg was left in a bad state.

The problem was resolved (I believe) by forcing installation of all three packages (atp-get -f install epson-inkjet-printer-escpr libc6:i386 libgcc1:i386) and then removing all three packages.

ProblemType: Package
DistroRelease: Ubuntu 16.04
Package: libc6:i386 (not installed)
ProcVersionSignature: Ubuntu 4.4.0-45.66-generic 4.4.21
Uname: Linux 4.4.0-45-generic x86_64
ApportVersion: 2.20.1-0ubuntu2.1
AptOrdering:
 libc6: Remove
 libgcc1: Remove
 NULL: ConfigurePending
Architecture: amd64
Date: Sun Nov 6 10:14:18 2016
DpkgTerminalLog:
 Removing libgcc1:i386 (1:6.0.1-0ubuntu1) ...
 dpkg: error processing package libc6:i386 (--remove):
  package is in a very bad inconsistent state; you should
  reinstall it before attempting a removal
DuplicateSignature:
 package:libc6:i386:(not installed)
 Removing libgcc1:i386 (1:6.0.1-0ubuntu1) ...
 dpkg: error processing package libc6:i386 (--remove):
  package is in a very bad inconsistent state; you should
ErrorMessage: package is in a very bad inconsistent state; you should reinstall it before attempting a removal
InstallationDate: Installed on 2016-06-06 (153 days ago)
InstallationMedia: Ubuntu-GNOME 16.04 LTS "Xenial Xerus" - Release amd64 (20160421)
RelatedPackageVersions:
 dpkg 1.18.4ubuntu1.1
 apt 1.2.12~ubuntu16.04.1
SourcePackage: glibc
Title: package libc6:i386 (not installed) failed to install/upgrade: package is in a very bad inconsistent state; you should reinstall it before attempting a removal
UpgradeStatus: Manual upgrade (complete replacement of system files, /home and /home configuration files unchanged)

doylep (doylep) wrote :
summary: - libc6:i386 failed to install/upgrade (related to printer-driver-escpr)
+ libc6:i386 failed to install/upgrade (related to epson-inkjet-printer-
+ escpr)
doylep (doylep) on 2016-11-07
description: updated
tags: removed: need-duplicate-check
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers