gnome-terminal fails to start

Bug #161772 reported by Ferenc Sipos on 2007-11-09
2
Affects Status Importance Assigned to Milestone
glibc (Ubuntu)
Undecided
Unassigned

Bug Description

After upgrading libc-6 to 2.6.1-1ubuntu10 (Gutsy) gnome-terminal did not start up anymore. All I could gather from strace's output is that receives a SIGBUS signal and exits with "Bus error" message. Downgrading to -ubuntu9 solved my problem.

jonathan (new-jonathan) wrote :

same thing happened to me... only worst. Firefox & Epiphany won't as well start after applying libc-6 2.6.1-1ubuntu10 (Gutsy). I am using AMD64.

I also tried fresh gutsy installation. The same problem occurred the moment libc6 is updated

Gergo Lippai (lipilee) wrote :

Fresh Gutsy install, libc6 2.6.1-1ubuntu10, no problem here. Reading Jonatahan's comment it seems irrelevant whether your system is upgraded or not.

jonathan (new-jonathan) wrote :

after numerous fresh installation, each time gnome-terminal core dumping after libc6 update, i decided to try a slightly different way of installation and it works fine now. Detail process as follows:

1) connected to internet and allow apt-get to refresh *during* installation (in my previous installations, i always disconnect during installation)
2) perform full update *before* trying to run any application (in prev installation, i always use terminal, firefox etc while updating)
3) restart
4) gnome-terminal core dumped again
5) apt-get --reinstall install libc6
6) restart
7) gnome-terminal works again :)
8) now firefox core dumped :(
9) reinstall firefox
10) restart
11) everything works :)
12) installed chinese language support (in previous installation, i installed language support immediately after update)

now everything works fine and i'm happy :) frankly i almost gave up gutsy and turn to fedora 8....
i don't know what went wrong with my previous installations, but all these failed attempts definitely leaves a bad taste

Matthias Klose (doko) wrote :

Updated sucessfully from a CD installation to current gutsy-updates, without seeing any of these problems (AMD64).

Changed in glibc:
status: New → Invalid

I got this error too and "solved" it downgrading libc6 to 2.6.1-1ubuntu9.

I hope Ubuntu fix this problem soon. I don't will update my system for next few days or will try pinning libc6.

Alan

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers