gresource is broken on powerpc

Bug #961512 reported by ojordan on 2012-03-21
22
This bug affects 3 people
Affects Status Importance Assigned to Milestone
GLib
Fix Released
Medium
glib2.0 (Ubuntu)
Low
Unassigned

Bug Description

I don't have a global menu when running gedit. I can get a normal menu to display when I right-click inside the gedit window (Undo, redo, cut, copy, etc) , but that doesn't have crucial menu items like save, save as, open etc .

It is simlar to a problem I have with nautilus https://bugs.launchpad.net/ubuntu/+source/nautilus/+bug/945097 .

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: gedit 3.3.8-0ubuntu1
ProcVersionSignature: Ubuntu 3.2.0-19.30-powerpc-smp 3.2.11
Uname: Linux 3.2.0-19-powerpc-smp ppc
ApportVersion: 1.94.1-0ubuntu2
Architecture: powerpc
Date: Wed Mar 21 18:54:10 2012
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Alpha powerpc (20120321)
ProcEnviron:
 LANGUAGE=en_GB:en
 TERM=xterm
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
SourcePackage: gedit
UpgradeStatus: No upgrade log present (probably fresh install)

Related branches

ojordan (ojordan12345) wrote :
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/961512

tags: added: iso-testing
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gedit (Ubuntu):
status: New → Confirmed
ojordan (ojordan12345) wrote :

This is the xsession error when I run gedit in xubuntu (where I also don't have a menu):

Gtk-WARNING **: Theme parsing error: misc.css:13:17: Not using units is deprecated. Assuming 'px'.

Gtk-WARNING **: Theme parsing error: misc.css:15:16: Not using units is deprecated. Assuming 'px'.

Gtk-WARNING **: Theme parsing error: misc.css:16:11: Not using units is deprecated. Assuming 'px'.

** WARNING **: Could not add ui definition: Error on line 1 char 1: Document must begin with an element (e.g. <book>)

** WARNING **: Could not add ui definition: Error on line 1 char 1: Document must begin with an element (e.g. <book>)

Gtk-CRITICAL **: gtk_action_group_set_sensitive: assertion `GTK_IS_ACTION_GROUP (action_group)' failed

Gtk-CRITICAL **: gtk_action_group_set_sensitive: assertion `GTK_IS_ACTION_GROUP (action_group)' failed

Gtk-CRITICAL **: gtk_action_group_get_action: assertion `GTK_IS_ACTION_GROUP (action_group)' failed

Gtk-CRITICAL **: gtk_toggle_action_set_active: assertion `GTK_IS_TOGGLE_ACTION (action)' failed

Gtk-CRITICAL **: gtk_action_group_set_sensitive: assertion `GTK_IS_ACTION_GROUP (action_group)' failed

Gtk-CRITICAL **: gtk_action_group_set_sensitive: assertion `GTK_IS_ACTION_GROUP (action_group)' failed

Gtk-CRITICAL **: gtk_action_group_set_sensitive: assertion `GTK_IS_ACTION_GROUP (action_group)' failed

Gtk-CRITICAL **: gtk_action_group_set_sensitive: assertion `GTK_IS_ACTION_GROUP (action_group)' failed

Gtk-CRITICAL **: gtk_action_group_set_sensitive: assertion `GTK_IS_ACTION_GROUP (action_group)' failed

Gtk-CRITICAL **: gtk_action_group_set_sensitive: assertion `GTK_IS_ACTION_GROUP (action_group)' failed

Gtk-CRITICAL **: gtk_action_group_set_sensitive: assertion `GTK_IS_ACTION_GROUP (action_group)' failed

Gtk-CRITICAL **: gtk_action_group_set_sensitive: assertion `GTK_IS_ACTION_GROUP (action_group)' failed

Gtk-CRITICAL **: gtk_action_group_get_action: assertion `GTK_IS_ACTION_GROUP (action_group)' failed

Gtk-CRITICAL **: gtk_toggle_action_get_active: assertion `GTK_IS_TOGGLE_ACTION (action)' failed

Gtk-CRITICAL **: gtk_action_group_get_action: assertion `GTK_IS_ACTION_GROUP (action_group)' failed

Gtk-CRITICAL **: gtk_toggle_action_get_active: assertion `GTK_IS_TOGGLE_ACTION (action)' failed

Gtk-CRITICAL **: gtk_action_group_get_action: assertion `GTK_IS_ACTION_GROUP (action_group)' failed

Gtk-CRITICAL **: gtk_action_group_list_actions: assertion `GTK_IS_ACTION_GROUP (action_group)' failed

Gtk-CRITICAL **: gtk_action_group_get_action: assertion `GTK_IS_ACTION_GROUP (action_group)' failed

Gtk-CRITICAL **: gtk_toggle_action_set_active: assertion `GTK_IS_TOGGLE_ACTION (action)' failed

** CRITICAL **: update_documents_list_menu_idle: assertion `p->documents_list_action_group != NULL' failed

Vadim Rutkovsky (roignac) wrote :

As this is reproducible for nautilus, then it is not a gedit's fault. Closing this as a duplicate of bug #945097

ojordan (ojordan12345) wrote :

How can it be a duplicate of that bug? The xsession error is different and none of the 62 people affected by that bug describe any symptoms of lacking menus.

ojordan (ojordan12345) wrote :

I should clarify the above comment, I was talking about bug 870742 which I don't think this is a duplicate of.

The xsession errors for bug 945097 are different to this bug too.

Sebastien Bacher (seb128) wrote :

Thank you for your bug report, what desktop environment do you use? Could you take a screenshot showing the issue?

Changed in gedit (Ubuntu):
status: Confirmed → Incomplete
importance: Undecided → Low
ojordan (ojordan12345) wrote :

Still exists on the latest Ubuntu ISO. I think I automatically boot into Unity-2d.

In the screenshot you can see the mouse is where the menu should be.

Changed in gedit (Ubuntu):
status: Incomplete → Confirmed
ojordan (ojordan12345) wrote :

Just to clarify:

In unity-2d I don't have a global menu.
In xubuntu/lubuntu I don't have a normal application menu at the top of the gedit window.

Changed in gtk+3.0 (Ubuntu):
status: New → Invalid
importance: Undecided → Low
Sebastien Bacher (seb128) wrote :

Since only you get the issue I guess it's somewhat powerpc specific...

Is gnome-settings-daemon running in your session? Is that happening every time with gedit? Could you change the theme and try to get a stacktrace of one of those gtk_action_get_group_action errors?

Changed in gtk+3.0 (Ubuntu):
status: Invalid → New
Changed in gedit (Ubuntu):
status: Confirmed → New
ojordan (ojordan12345) wrote :

As far as I can tell, the last working version of gedit was 3.3.4-0ubuntu1. Whatever changes happened in 3.3.5-0ubuntu1 is what is going wrong.

ojordan (ojordan12345) wrote :
Download full text (3.2 KiB)

This is the stacktrace of 3.3.4-0ubuntu1 (working fine):

gdb gedit
GNU gdb (Ubuntu/Linaro 7.4-2012.02-0ubuntu1) 7.4-2012.02
Copyright (C) 2012 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law. Type "show copying"
and "show warranty" for details.
This GDB was configured as "powerpc-linux-gnu".
For bug reporting instructions, please see:
<http://bugs.launchpad.net/gdb-linaro/>...
Reading symbols from /usr/bin/gedit...(no debugging symbols found)...done.
(gdb) run
Starting program: /usr/bin/gedit
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/lib/powerpc-linux-gnu/libthread_db.so.1".
[New Thread 0x48a462e0 (LWP 4895)]
[New Thread 0x493ff2e0 (LWP 4896)]

Gtk-WARNING **: Theme parsing error: misc.css:13:17: Not using units is deprecated. Assuming 'px'.

Gtk-WARNING **: Theme parsing error: misc.css:15:16: Not using units is deprecated. Assuming 'px'.

Gtk-WARNING **: Theme parsing error: misc.css:16:11: Not using units is deprecated. Assuming 'px'.
[New Thread 0x49cff2e0 (LWP 4897)]
[Thread 0x48a462e0 (LWP 4895) exited]
^C
Program received signal SIGINT, Interrupt.
0x0f01df7c in poll () from /lib/powerpc-linux-gnu/libc.so.6
(gdb) thread apply all bt

Thread 4 (Thread 0x49cff2e0 (LWP 4897)):
#0 0x0f01df7c in poll () from /lib/powerpc-linux-gnu/libc.so.6
#1 0x0f227a6c in g_poll () from /lib/powerpc-linux-gnu/libglib-2.0.so.0
#2 0x0f215dec in ?? () from /lib/powerpc-linux-gnu/libglib-2.0.so.0
#3 0x0f2163b0 in g_main_loop_run ()
   from /lib/powerpc-linux-gnu/libglib-2.0.so.0
#4 0x0e4a1788 in ?? ()
   from /usr/lib/powerpc-linux-gnu/gio/modules/libdconfsettings.so
#5 0x0f241f38 in ?? () from /lib/powerpc-linux-gnu/libglib-2.0.so.0
#6 0x0f0c5864 in start_thread () from /lib/powerpc-linux-gnu/libpthread.so.0
#7 0x0f02cc04 in clone () from /lib/powerpc-linux-gnu/libc.so.6

Thread 3 (Thread 0x493ff2e0 (LWP 4896)):
#0 0x0f01df7c in poll () from /lib/powerpc-linux-gnu/libc.so.6
#1 0x0f227a6c in g_poll () from /lib/powerpc-linux-gnu/libglib-2.0.so.0
#2 0x0f215dec in ?? () from /lib/powerpc-linux-gnu/libglib-2.0.so.0
#3 0x0f2163b0 in g_main_loop_run ()
   from /lib/powerpc-linux-gnu/libglib-2.0.so.0
#4 0x0f5100e8 in ?? () from /usr/lib/powerpc-linux-gnu/libgio-2.0.so.0
#5 0x0f241f38 in ?? () from /lib/powerpc-linux-gnu/libglib-2.0.so.0
#6 0x0f0c5864 in start_thread () from /lib/powerpc-linux-gnu/libpthread.so.0
#7 0x0f02cc04 in clone () from /lib/powerpc-linux-gnu/libc.so.6
---Type <return> to continue, or q <return> to quit---

Thread 1 (Thread 0x48042590 (LWP 4892)):
#0 0x0f01df7c in poll () from /lib/powerpc-linux-gnu/libc.so.6
#1 0x0f227a6c in g_poll () from /lib/powerpc-linux-gnu/libglib-2.0.so.0
#2 0x0f215dec in ?? () from /lib/powerpc-linux-gnu/libglib-2.0.so.0
#3 0x0f2163b0 in g_main_loop_run ()
   from /lib/powerpc-linux-gnu/libglib-2.0.so.0
#4 0x0fb5b2f0 in gtk_main () from /usr/lib/powerpc-linux-gnu/libgtk-3.so.0
#5 0x1001b24c in main ()
(gdb) quit
A debugging session is active.

 Inferior 1 [process 4892] will be ...

Read more...

ojordan (ojordan12345) wrote :
Download full text (6.1 KiB)

This is the stacktrace of 3.3.5-0ubuntu1 (menu missing):

gdb gedit
GNU gdb (Ubuntu/Linaro 7.4-2012.02-0ubuntu1) 7.4-2012.02
Copyright (C) 2012 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law. Type "show copying"
and "show warranty" for details.
This GDB was configured as "powerpc-linux-gnu".
For bug reporting instructions, please see:
<http://bugs.launchpad.net/gdb-linaro/>...
Reading symbols from /usr/bin/gedit...(no debugging symbols found)...done.
(gdb) run
Starting program: /usr/bin/gedit
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/lib/powerpc-linux-gnu/libthread_db.so.1".
[New Thread 0x48a462e0 (LWP 5250)]
[New Thread 0x493ff2e0 (LWP 5251)]

Gtk-WARNING **: Theme parsing error: misc.css:13:17: Not using units is deprecated. Assuming 'px'.

Gtk-WARNING **: Theme parsing error: misc.css:15:16: Not using units is deprecated. Assuming 'px'.

Gtk-WARNING **: Theme parsing error: misc.css:16:11: Not using units is deprecated. Assuming 'px'.
[New Thread 0x49cff2e0 (LWP 5252)]

** WARNING **: Could not add ui definition: Error on line 1 char 1: Document must begin with an element (e.g. <book>)

** WARNING **: Could not add ui definition: Error on line 1 char 1: Document must begin with an element (e.g. <book>)

Gtk-CRITICAL **: gtk_action_group_set_sensitive: assertion `GTK_IS_ACTION_GROUP (action_group)' failed

Gtk-CRITICAL **: gtk_action_group_set_sensitive: assertion `GTK_IS_ACTION_GROUP (action_group)' failed

Gtk-CRITICAL **: gtk_action_group_get_action: assertion `GTK_IS_ACTION_GROUP (action_group)' failed

Gtk-CRITICAL **: gtk_toggle_action_set_active: assertion `GTK_IS_TOGGLE_ACTION (action)' failed

Gtk-CRITICAL **: gtk_action_group_set_sensitive: assertion `GTK_IS_ACTION_GROUP (action_group)' failed

Gtk-CRITICAL **: gtk_action_group_set_sensitive: assertion `GTK_IS_ACTION_GROUP (action_group)' failed

Gtk-CRITICAL **: gtk_action_group_set_sensitive: assertion `GTK_IS_ACTION_GROUP (action_group)' failed

Gtk-CRITICAL **: gtk_action_group_set_sensitive: assertion `GTK_IS_ACTION_GROUP (action_group)' failed

Gtk-CRITICAL **: gtk_action_group_set_sensitive: assertion `GTK_IS_ACTION_GROUP (action_group)' failed

Gtk-CRITICAL **: gtk_action_group_set_sensitive: assertion `GTK_IS_ACTION_GROUP (action_group)' failed

Gtk-CRITICAL **: gtk_action_group_set_sensitive: assertion `GTK_IS_ACTION_GROUP (action_group)' failed

Gtk-CRITICAL **: gtk_action_group_set_sensitive: assertion `GTK_IS_ACTION_GROUP (action_group)' failed

Gtk-CRITICAL **: gtk_action_group_get_action: assertion `GTK_IS_ACTION_GROUP (action_group)' failed

Gtk-CRITICAL **: gtk_toggle_action_get_active: assertion `GTK_IS_TOGGLE_ACTION (action)' failed

Gtk-CRITICAL **: gtk_action_group_get_action: assertion `GTK_IS_ACTION_GROUP (action_group)' failed

Gtk-CRITICAL **: gtk_toggle_action_get_active: assertion `GTK_IS_TOGGLE_ACTION (action)' failed

Gtk-CRITICAL **: gtk_action_group_get_action: assertion `GTK_IS_ACTION_GROUP (action_group)' failed

Gtk-CRITICAL **: ...

Read more...

Sebastien Bacher (seb128) wrote :

Thanks, do you know how to rebuild a source? It would be interesting to know what commit created the bug, could you try to do a build of the current version without http://git.gnome.org/browse/gedit/commit/?id=065a5ee30d36d24fa38c465ed70be746e1912224 ?

ojordan (ojordan12345) wrote :

Forgot to say gnome-settings-daemon is not running.

The above stacktraces were done using a xubuntu session.

Not sure what you wanted with the changing themes request, but changing the Window Manager theme doesn't make a difference.

The lack of menus happens everytime gedit is run.

ojordan (ojordan12345) wrote :

Hi Sebastien, sorry I somehow missed your comment earlier. Yes I can build from source although I have never applied or even reversed a commit/patch before. I can probably do it manually or figure it out myself, but if you have some fancy command to hand that will do it then I am keen to learn! Anyway, it is a job for tomorrow now as it it late here. Thanks.

ojordan (ojordan12345) wrote :

I've reversed the commit by reversing the patch. I'll compile tomorrow and let you know.

ojordan (ojordan12345) wrote :

Initial results are that removing that commit does not solve the problem.

I've compiled this morning and still have no menu. I'll check if I've done something wrong tonight, but have you any more suggestions?

summary: - No global menu with gedit
+ gresource is broken on powper
summary: - gresource is broken on powper
+ gresource is broken on powerpc
no longer affects: gedit (Ubuntu)
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gtk+3.0 (Ubuntu):
status: New → Confirmed
Sebastien Bacher (seb128) wrote :

Ok, thanks for your work it's indeed a big endian specific issue with gresource, it's being discussed on https://bugzilla.gnome.org/show_bug.cgi?id=673409

Changed in gtk+3.0 (Ubuntu):
status: Confirmed → Triaged
affects: gtk+3.0 (Ubuntu) → ubuntu
affects: ubuntu → glib2.0 (Ubuntu)
Changed in glib:
importance: Unknown → Medium
status: Unknown → New
ojordan (ojordan12345) wrote :

Thanks Sebastien, I think you've found the problem!!!!

I've compiled a version a version of glib2.0 using Michel Dänzer's patch. The most recent versions of gedit and nautilus now work as expected! Yes!

Now the big question: are we too late to get it into 12.04?

Sebastien Bacher (seb128) wrote :

No it's not too late for 12.04, we will keep fix bugs in stable updates after release and there will be a solid 12.04.1 as well including those rolled later in the year

Lars Noodén (larsnooden) wrote :

There's still no menus present at the top of the Gedit window for 3.4.0-0ubuntu1 for powerpc

ojordan (ojordan12345) wrote :

@Lars The patch hasn't made it into Ubuntu yet. You need to compile glib2.0 to fix this, but it takes several hours to do so on my machine.

@Sebastien The glib developers seem happy with their patch. Would it be possible to get it into Ubuntu before the ISO release date?

Changed in glib2.0 (Ubuntu):
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package glib2.0 - 2.32.0-1ubuntu3

---------------
glib2.0 (2.32.0-1ubuntu3) precise-proposed; urgency=low

  * debian/patches/git_gdbus_messages_decoding.patch,
    debian/patches/git_gdbus_messages_decoding_test.patch:
    - upstream patch to fix a gdbus message decoding issue, include the
      next commit which has the testcase for the issue
  * debian/patches/git_powerpc_gresources.patch:
    - upstream fix for gresource on big endian archs, i.e powerpc
      (lp: #961512)
 -- Sebastien Bacher <email address hidden> Wed, 11 Apr 2012 18:15:42 +0200

Changed in glib2.0 (Ubuntu):
status: Fix Committed → Fix Released
Changed in glib:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.