Saved search file opens in firefox instead of nautilus

Bug #901171 reported by Manuel J. Garrido on 2011-12-07
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
GLib
Fix Released
Medium
glib2.0 (Ubuntu)
Low
Unassigned
Precise
Low
Unassigned

Bug Description

Steps to reproduce

1.- Open nautilus and perform a search

2.- Save that search. A file named "whatever.savedSearch" is created.

3.- In nautilus, double click to open "whatever.savedSearch"

What happens: Firefox is invoked to open the saved search

What should happen: the saved search is open in nautilus

Found in ubuntu 11.10

desktop-file-utils:
     Installed: 0.18-0ubuntu9

Sebastien Bacher (seb128) wrote :

Thank you for your bug report, I can't confirm the issue, what mimetype is listed when opening the nautilus properties dialog on it?
Could you add an example file to the bug?

Changed in desktop-file-utils (Ubuntu):
importance: Undecided → Low
status: New → Incomplete
Sebastien Bacher (seb128) wrote :

does running "gvfs-mime --query" on the file gives any output?

Manuel J. Garrido (mgarrido) wrote :

The mimetype listed in the nautilus properties is "application/x-gnome-saved-search"

The output of "gvfs-mime --query vidal.savedSearch" is "No default applications for 'vidal.savedSearch'".

I'm adding an example file.

Sebastien Bacher (seb128) wrote :

ok, I can't confirm there but maybe we should add nautilus as default handler for the mimetype in case, it's weird that firefox is started if it's not listed as an handler though

Changed in desktop-file-utils (Ubuntu):
status: Incomplete → New
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in desktop-file-utils (Ubuntu):
status: New → Confirmed
Sebastien Bacher (seb128) wrote :

There seems to be a bug in glib there, I've opened https://bugzilla.gnome.org/show_bug.cgi?id=678944

Changed in glib:
importance: Unknown → Medium
status: Unknown → New
Sebastien Bacher (seb128) wrote :

The issue has been fixed in upstream git

affects: desktop-file-utils (Ubuntu) → glib2.0 (Ubuntu)
Changed in glib2.0 (Ubuntu):
status: Confirmed → Fix Committed
Changed in glib2.0 (Ubuntu Precise):
importance: Undecided → Low
status: New → Triaged
Changed in glib:
status: New → Fix Released

Hello Manuel, or anyone else affected,

Accepted glib2.0 into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/glib2.0/2.32.4-0ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in glib2.0 (Ubuntu Precise):
status: Triaged → Fix Committed
tags: added: verification-needed

The fix for this bug has been awaiting testing feedback in the -proposed repository for precise for more than 90 days. Please test this fix and update the bug appropriately with the results. In the event that the fix for this bug is still not verified 15 days from now, the package will be removed from the -proposed repository.

tags: added: removal-candidate
tags: added: verification-failed
removed: verification-needed
Manuel J. Garrido (mgarrido) wrote :

I think It's not fixed, the saved searches still launches firefox. But if, after saving the search, in the same nautilus window, I double click on the saved search it works fine. If I open another nautilus window and double click on the saved search, firefox is launched.

Sebastien Bacher (seb128) wrote :

we should probably not fail verification just because the fix is not perfect, the update includes other fixes and if it doesn't break anything it's still a good update to get

Manuel J. Garrido (mgarrido) wrote :

Ok, I just focused in this particular bug. Then, how should this bug be tagged, "verification-done"?

Sebastien Bacher (seb128) wrote :

verification-failed is fine, I'm mostly letting the comment for the SRU team as a "please don't block the SRU on that"

Iain Lane (laney) wrote :

I think this update is being ignored because of that; let's change to v-done.

tags: added: verification-done
removed: verification-failed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package glib2.0 - 2.32.4-0ubuntu1

---------------
glib2.0 (2.32.4-0ubuntu1) precise; urgency=low

  * New upstream release (LP: #1154657)
    + GSettings: Don't crash due to incorrect handling of "/" (LP: #1154370)
    + gio: Stop ignoring defaults.list wrongly (LP: #901171)
  * Update watch file to track 2.32 series for Precise
  * debian/control{,.in}: Require libelf-dev >= 0.8.12, per configure.ac
  * gnetworkmonitor_dont_leak_networks.patch: Drop, included in this release.
  * Install bash completion files into /etc/bash_completion.d; overriding an
    upstream change (not appropriate for Precise) to install into
    /usr/share/bash-completion/completions. This change also names the
    completion files correctly (after the commands they are completing for),
    so they will start working now.
 -- Iain Lane <email address hidden> Wed, 13 Mar 2013 10:45:56 +0000

Changed in glib2.0 (Ubuntu Precise):
status: Fix Committed → Fix Released

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Mathew Hodson (mathew-hodson) wrote :

This is fixed in current releases.

Changed in glib2.0 (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.