Ubuntu

libglib-2.0 dependencies problem

Reported by Marvin Lee on 2011-11-14
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
glib2.0 (Ubuntu)
Undecided
Unassigned

Bug Description

 Hello, the following message occurred frequently when i try to install packages:

A package failed to install. Trying to recover:
Setting up ubuntuone-client (1.2.1-0ubuntu1) ...
Setting up nvidia-173 (173.14.22-0ubuntu11) ...
Removing old nvidia-173-173.14.22 DKMS files...

------------------------------
Deleting module version: 173.14.22
completely from the DKMS tree.
------------------------------
Done.
Loading new nvidia-173-173.14.22 DKMS files...
First Installation: checking all kernels...
Building only for 2.6.35-22-generic
Building for architecture i686
Building initial module for 2.6.35-22-generic

Error! Bad return status for module build on kernel: 2.6.35-22-generic (i686)
Consult the make.log in the build directory
/var/lib/dkms/nvidia-173/173.14.22/build/ for more information.
Traceback (most recent call last):
  File "/usr/share/apport/package-hooks/dkms.py", line 22, in <module>
    import apport
ImportError: No module named apport
dpkg: error processing nvidia-173 (--configure):
 subprocess installed post-installation script returned error exit status 10
Setting up libglib2.0-0 (2.26.0-0ubuntu1) ...
/var/lib/dpkg/info/libglib2.0-0.postinst: 39: /usr/lib/glib-2.0/gio-querymodules: not found
dpkg: error processing libglib2.0-0 (--configure):
 subprocess installed post-installation script returned error exit status 127
dpkg: dependency problems prevent configuration of gnome-session-bin:
 gnome-session-bin depends on libglib2.0-0 (>= 2.23.5); however:
  Package libglib2.0-0 is not configured yet.
dpkg: error processing gnome-session-bin (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of abiword-plugin-grammar:
 abiword-plugin-grammar depends on libglib2.0-0 (>= 2.12.0); however:
  Package libglib2.0-0 is not configured yet.
dpkg: error processing abiword-plugin-grammar (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of xfce4-appfinder:
 xfce4-appfinder depends on libglib2.0-0 (>= 2.18.0); however:
  Package libglib2.0-0 is not configured yet.
dpkg: error processing xfce4-appfinder (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of gnotski:
 gnotski depends on libglib2.0-0 (>= 2.23.5); however:
  Package libglib2.0-0 is not configured yet.
dpkg: error processing gnotski (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libgnome-media0:
 libgnome-media0 depends on libglib2.0-0 (>= 2.18.2); however:
  Package libglib2.0-0 is not configured yet.
dpkg: error processing libgnome-media0 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of xfdesktop4:
 xfdesktop4 depends on libglib2.0-0 (>= 2.18.0); however:
  Package libglib2.0-0 is not configured yet.
dpkg: error processing xfdesktop4 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libffado2:
 libffado2 depends on libglib2.0-0 (>= 2.12.0); however:
  Package libglib2.0-0 is not configured yet.
dpkg: error processing libffado2 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of gimp:
 gimp depends on libglib2.0-0 (>= 2.23.5); however:
  Package libglib2.0-0 is not configured yet.
dpkg: error processing gimp (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libots0:
 libots0 depends on libglib2.0-0 (>= 2.12.0); however:
  Package libglib2.0-0 is not configured yet.
dpkg: error processing libots0 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libgnome-speech7:
 libgnome-speech7 depends on libglib2.0-0 (>= 2.16.0); however:
  Package libglib2.0-0 is not configured yet.
dpkg: error processing libgnome-speech7 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of seahorse-plugins:
 seahorse-plugins depends on libglib2.0-0 (>= 2.23.5); however:
  Package libglib2.0-0 is not configured yet.
dpkg: error processing seahorse-plugins (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of gvfs-bin:
 gvfs-bin depends on libglib2.0-0 (>= 2.23.4); however:
  Package libglib2.0-0 is not configured yet.
dpkg: error processing gvfs-bin (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of xfce4-cpugraph-plugin:
 xfce4-cpugraph-plugin depends on libglib2.0-0 (>= 2.18.0); however:
  Package libglib2.0-0 is not configured yet.
dpkg: error processing xfce4-cpugraph-plugin (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of xfprint4:
 xfprint4 depends on libglib2.0-0 (>= 2.18.0); however:
  Package libglib2.0-0 is not configured yet.
dpkg: error processing xfprint4 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of glines:
 glines depends on libglib2.0-0 (>= 2.23.5); however:
  Package libglib2.0-0 is not configured yet.
dpkg: error processing glines (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libpango-perl:
 libpango-perl depends on libglib2.0-0 (>= 2.16.0); however:
  Package libglib2.0-0 is not configured yet.
dpkg: error processing libpango-perl (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libgegl-0.0-0:
 libgegl-0.0-0 depends on libglib2.0-0 (>= 2.18.0); however:
  Package libglib2.0-0 is not configured yet.
dpkg: error processing libgegl-0.0-0 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of gnome-settings-daemon:
 gnome-settings-daemon depends on libglib2.0-0 (>= 2.23.5); however:
  Package libglib2.0-0 is not configured yet.
dpkg: error processing gnome-settings-daemon (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of gtali:
 gtali depends on libglib2.0-0 (>= 2.23.5); however:
  Package libglib2.0-0 is not configured yet.
dpkg: error processing gtali (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libqtgui4:
 libqtgui4 depends on libglib2.0-0 (>= 2.12.0); however:
  Package libglib2.0-0 is not configured yet.
dpkg: error processing libqtgui4 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of xfswitch-plugin:
 xfswitch-plugin depends on libglib2.0-0 (>= 2.18.0); however:
  Package libglib2.0-0 is not configured yet.
dpkg: error processing xfswitch-plugin (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of python-mediaprofiles:
 python-mediaprofiles depends on libglib2.0-0 (>= 2.16.0); however:
  Package libglib2.0-0 is not configured yet.
 python-mediaprofiles depends on libgnome-media0; however:
  Package libgnome-media0 is not configured yet.
dpkg: error processing python-mediaprofiles (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of gnome-core:
 gnome-core depends on gnome-settings-daemon (>= 2.28); however:
  Package gnome-settings-daemon is not configured yet.
dpkg: error processing gnome-core (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libgdome2-cpp-smart0c2a:
 libgdome2-cpp-smart0c2a depends on libglib2.0-0 (>= 2.12.0); however:
  Package libglib2.0-0 is not configured yet.
dpkg: error processing libgdome2-cpp-smart0c2a (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of xfce4-verve-plugin:
 xfce4-verve-plugin depends on libglib2.0-0 (>= 2.18.0); however:
  Package libglib2.0-0 is not configured yet.
dpkg: error processing xfce4-verve-plugin (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of gnect:
 gnect depends on libglib2.0-0 (>= 2.23.5); however:
  Package libglib2.0-0 is not configured yet.
dpkg: error processing gnect (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of gigolo:
 gigolo depends on libglib2.0-0 (>= 2.22.0); however:
  Package libglib2.0-0 is not configured yet.
dpkg: error processing gigolo (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of xfce4-weather-plugin:
 xfce4-weather-plugin depends on libglib2.0-0 (>= 2.18.0); however:
  Package libglib2.0-0 is not configured yet.
dpkg: error processing xfce4-weather-plugin (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libloudmouth1-0:
 libloudmouth1-0 depends on libglib2.0-0 (>= 2.16.0); however:
  Package libglib2.0-0 is not configured yet.
dpkg: error processing libloudmouth1-0 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of xfce4-panel:
 xfce4-panel depends on libglib2.0-0 (>= 2.18.0); however:
  Package libglib2.0-0 is not configured yet.
dpkg: error processing xfce4-panel (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libgnome2-canvas-perl:
 libgnome2-canvas-perl depends on libglib2.0-0 (>= 2.16.0); however:
  Package libglib2.0-0 is not configured yet.
dpkg: error processing libgnome2-canvas-perl (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libthunar-vfs-1-2:
 libthunar-vfs-1-2 depends on libglib2.0-0 (>= 2.18.0); however:
  Package libglib2.0-0 is not configured yet.
dpkg: error processing libthunar-vfs-1-2 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of brasero:
 brasero depends on libglib2.0-0 (>= 2.23.5); however:
  Package libglib2.0-0 is not configured yet.
dpkg: error processing brasero (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of python-mmkeys:
 python-mmkeys depends on libglib2.0-0 (>= 2.16.0); however:
  Package libglib2.0-0 is not configured yet.
dpkg: error processing python-mmkeys (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libgnomeprint2.2-0:
 libgnomeprint2.2-0 depends on libglib2.0-0 (>= 2.16.0); however:
  Package libglib2.0-0 is not configured yet.
dpkg: error processing libgnomeprint2.2-0 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of gnome-panel:
 gnome-panel depends on libglib2.0-0 (>= 2.23.5); however:
  Package libglib2.0-0 is not configured yet.
dpkg: error processing gnome-panel (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of xfce4-clipman-plugin:
 xfce4-clipman-plugin depends on libglib2.0-0 (>= 2.18.0); however:
  Package libglib2.0-0 is not configured yet.
 xfce4-clipman-plugin depends on xfce4-panel (>= 4.6.0); however:
  Package xfce4-panel is not configured yet.
dpkg: error processing xfce4-clipman-plugin (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of sound-juicer:
 sound-juicer depends on libglib2.0-0 (>= 2.18.0); however:
  Package libglib2.0-0 is not configured yet.
 sound-juicer depends on libgnome-media0; however:
  Package libgnome-media0 is not configured yet.
dpkg: error processing sound-juicer (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of xfce4-power-manager:
 xfce4-power-manager depends on libglib2.0-0 (>= 2.18.0); however:
  Package libglib2.0-0 is not configured yet.
dpkg: error processing xfce4-power-manager (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of thunar:
 thunar depends on libglib2.0-0 (>= 2.18.0); however:
  Package libglib2.0-0 is not configured yet.
 thunar depends on libthunar-vfs-1-2 (>= 1.0.0); however:
  Package libthunar-vfs-1-2 is not configured yet.
dpkg: error processing thunar (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libpulse-mainloop-glib0:
 libpulse-mainloop-glib0 depends on libglib2.0-0 (>= 2.16.0); however:
  Package libglib2.0-0 is not configured yet.
dpkg: error processing libpulse-mainloop-glib0 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libgtk2-gladexml-perl:
 libgtk2-gladexml-perl depends on libglib2.0-0 (>= 2.16.0); however:
  Package libglib2.0-0 is not configured yet.
dpkg: error processing libgtk2-gladexml-perl (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of gettext:
 gettext depends on libglib2.0-0 (>= 2.12.0); however:
  Package libglib2.0-0 is not configured yet.
dpkg: error processing gettext (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libgnome-window-settings1:
 libgnome-window-settings1 depends on libglib2.0-0 (>= 2.17.4); however:
  Package libglib2.0-0 is not configured yet.
dpkg: error processing libgnome-window-settings1 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of gvfs-backends:
 gvfs-backends depends on libglib2.0-0 (>= 2.23.5); however:
  Package libglib2.0-0 is not configured yet.
dpkg: error processing gvfs-backends (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libgnome2-perl:
 libgnome2-perl depends on libglib2.0-0 (>= 2.16.0); however:
  Package libglib2.0-0 is not configured yet.
 libgnome2-perl depends on libgnome2-canvas-perl (>= 1.00); however:
  Package libgnome2-canvas-perl is not configured yet.
dpkg: error processing libgnome2-perl (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of xulrunner-1.9.2:
 xulrunner-1.9.2 depends on libglib2.0-0 (>= 2.23.5); however:
  Package libglib2.0-0 is not configured yet.
dpkg: error processing xulrunner-1.9.2 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of gnome-desktop-environment:
 gnome-desktop-environment depends on gnome-core (= 1:2.28+1ubuntu3); however:
  Package gnome-core is not configured yet.
 gnome-desktop-environment depends on brasero (>= 2.28); however:
  Package brasero is not configured yet.
 gnome-desktop-environment depends on gvfs-backends (>= 1.4); however:
  Package gvfs-backends is not configured yet.
 gnome-desktop-environment depends on gvfs-bin (>= 1.4); however:
  Package gvfs-bin is not configured yet.
 gnome-desktop-environment depends on seahorse-plugins (>= 2.28); however:
  Package seahorse-plugins is not configured yet.
 gnome-desktop-environment depends on sound-juicer (>= 2.28); however:
  Package sound-juicer is not configured yet.
 gnome-desktop-environment depends on libgnome2-perl (>= 1.042); however:
  Package libgnome2-perl is not configured yet.
dpkg: error processing gnome-desktop-environment (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libgimp2.0:
 libgimp2.0 depends on libglib2.0-0 (>= 2.23.5); however:
  Package libglib2.0-0 is not configured yet.
dpkg: error processing libgimp2.0 (--configure):
 dependency problems - leaving unconfigured
dpkg: too many errors, stopping
Processing triggers for python-gmenu ...
Rebuilding /usr/share/applications/desktop.en_US.utf8.cache...
Processing triggers for libc-bin ...
ldconfig deferred processing now taking place
Processing triggers for python-support ...
Errors were encountered while processing:
 nvidia-173
 libglib2.0-0
 gnome-session-bin
 abiword-plugin-grammar
 xfce4-appfinder
 gnotski
 libgnome-media0
 xfdesktop4
 libffado2
 gimp
 libots0
 libgnome-speech7
 seahorse-plugins
 gvfs-bin
 xfce4-cpugraph-plugin
 xfprint4
 glines
 libpango-perl
 libgegl-0.0-0
 gnome-settings-daemon
 gtali
 libqtgui4
 xfswitch-plugin
 python-mediaprofiles
 gnome-core
 libgdome2-cpp-smart0c2a
 xfce4-verve-plugin
 gnect
 gigolo
 xfce4-weather-plugin
 libloudmouth1-0
 xfce4-panel
 libgnome2-canvas-perl
 libthunar-vfs-1-2
 brasero
 python-mmkeys
 libgnomeprint2.2-0
 gnome-panel
 xfce4-clipman-plugin
 sound-juicer
 xfce4-power-manager
 thunar
 libpulse-mainloop-glib0
 libgtk2-gladexml-perl
 gettext
 libgnome-window-settings1
 gvfs-backends
 libgnome2-perl
 xulrunner-1.9.2
 gnome-desktop-environment
 libgimp2.0
Processing was halted because there were too many errors.
Press return to continue.

 There's a viable solution?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions