nautilus crashed with SIGSEGV in ffi_call()

Bug #805783 reported by cariboo on 2011-07-05
168
This bug affects 32 people
Affects Status Importance Assigned to Milestone
glib2.0 (Ubuntu)
High
Canonical Desktop Team
Oneiric
High
Canonical Desktop Team

Bug Description

While trying to re-name a file, nautilus crashes.

TEST CASE
1. right click file and select rename
2. click in file name
3. press delete key (nothing happens).

Result:
nautilus closes.

ProblemType: Crash
DistroRelease: Ubuntu 11.10
Package: nautilus 1:3.1.3-0ubuntu1
ProcVersionSignature: Ubuntu 3.0-3.4-generic 3.0.0-rc5
Uname: Linux 3.0-3-generic x86_64
NonfreeKernelModules: nvidia
Architecture: amd64
CrashCounter: 1
Date: Mon Jul 4 20:33:41 2011
ExecutablePath: /usr/bin/nautilus
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Alpha amd64 (20110701)
ProcCmdline: nautilus
ProcEnviron:
 LANGUAGE=en_CA:en
 PATH=(custom, no user)
 LANG=en_CA.UTF-8
 SHELL=/bin/bash
SegvAnalysis:
 Segfault happened at: 0x7f06f396ca76: mov (%rsi),%rcx
 PC (0x7f06f396ca76) ok
 source "(%rsi)" (0x00000000) not located in a known VMA region (needed readable region)!
 destination "%rcx" ok
SegvReason: reading NULL VMA
Signal: 11
SourcePackage: nautilus
StacktraceTop:
 ?? () from /lib/x86_64-linux-gnu/libc.so.6
 ffi_call () from /usr/lib/x86_64-linux-gnu/libffi.so.6
 g_cclosure_marshal_generic () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
 g_closure_invoke () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
 ?? () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
Title: nautilus crashed with SIGSEGV in ffi_call()
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

cariboo (cariboo) wrote :
cariboo (cariboo) wrote :

Changed to public

visibility: private → public

StacktraceTop:
 __memcpy_sse2 () at ../sysdeps/x86_64/multiarch/../memcpy.S:102
 ffi_call (cif=0x7fff70699730, fn=0x4eac60 <eel_editable_label_delete_from_cursor>, rvalue=<value optimized out>, avalue=<value optimized out>) at /usr/include/bits/string3.h:52
 g_cclosure_marshal_generic (closure=0x2d30ee0, return_gvalue=0x0, n_param_values=3, param_values=<value optimized out>, invocation_hint=<value optimized out>, marshal_data=0x4eac60) at /build/buildd/glib2.0-2.29.8/./gobject/gclosure.c:1129
 g_closure_invoke (closure=0x2d30ee0, return_value=0x0, n_param_values=3, param_values=0x2d3e300, invocation_hint=<value optimized out>) at /build/buildd/glib2.0-2.29.8/./gobject/gclosure.c:771
 signal_emit_unlocked_R (node=<value optimized out>, detail=0, instance=0x2a0a610, emission_return=0x0, instance_and_params=0x2d3e300) at /build/buildd/glib2.0-2.29.8/./gobject/gsignal.c:3294

Changed in nautilus (Ubuntu):
importance: Undecided → Medium
tags: removed: need-amd64-retrace
Jean-Baptiste Lallement (jibel) wrote :

Thanks for your report. I can reproduce with the steps in the description, but I get a slightly different trace (see bug 805797)

description: updated
Changed in nautilus (Ubuntu):
importance: Medium → High
status: New → Confirmed
Changed in nautilus (Ubuntu Oneiric):
assignee: nobody → Canonical Desktop Team (canonical-desktop-team)
fjgaude (tanzen) wrote :

Nautilus crashed when trying to copying one file to another mounted drive.

dino99 (9d9) wrote :

on Oneiric i386 updated, i have to kill the nautilus process because it was using 2.3 Gio of ram (silently growing)

Harry (harry33) wrote :

I notice Nautilus (also with gksu nautilus) crashes immediately if, when renaming a file, I press an arrow key.
But if I rename a file only by typing the new file name, it works OK.

Pedro Villavicencio (pedro) wrote :

reassigning to glib, according to upstream the issue is coming from there, please do not forward it upstream for now since a new package is going to be uploaded to test if the issue is still reproducible with that newer version , thanks all!.

affects: nautilus (Ubuntu Oneiric) → glib2.0 (Ubuntu Oneiric)

Happens when pressing any arrow key, delete or backspace

Jairo Serrano (jairo-serrano) wrote :

happens with a remote file transfer in sftp

tags: added: iso-testing
Martin Pitt (pitti) wrote :

For folks on i386, can you please test with today's oneiric? We got a new glib version 2.29.10. Thank you!

Hi pitti,

Yep, did update and the problem is gone.

Thanks!

---
Ubuntu Bug Squad volunteer triager
http://wiki.ubuntu.com/BugSquad

dino99 (9d9) wrote :

its fixed on my end too (i386)

Martin Pitt (pitti) wrote :

Thanks for confirming. If someone still gets this, please yell here, but after two confirmations I'll close it. I also don't get the crashes any more.

Changed in glib2.0 (Ubuntu Oneiric):
status: Confirmed → Fix Released
Quackers (quackers) wrote :

Still happening here in 64 bit

Quackers (quackers) wrote :

oops please disregard my previous ramblings!
I had some updates to run. It's fixed now.
My apoligies!

Alessandro Losavio (alo21) wrote :

I have the same problem when i opne UbuntuOne's folder.

Pedro Villavicencio (pedro) wrote :

if you still face the issue please open a new bug report with apport, thanks all.

tags: added: testcase
Amila (amilauduwerella) wrote :

for 64bit, try removing the side bar. it fixed my problem, but without sidebar.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers