Ubuntu

glib-compile-schemas fails if override files refer to non-installed schemas

Reported by Natanael on 2010-08-21
266
This bug affects 55 people
Affects Status Importance Assigned to Milestone
GLib
Fix Released
Medium
glib2.0 (Ubuntu)
High
Robert Ancell
Maverick
Medium
Unassigned

Bug Description

Binary package hint: evince

Ubuntu maverick 10.10
When I try evince for PDF Files appear the crash

ProblemType: Crash
DistroRelease: Ubuntu 10.10
Package: evince 2.31.90-0ubuntu1
ProcVersionSignature: Ubuntu 2.6.35-14.19-generic 2.6.35
Uname: Linux 2.6.35-14-generic i686
Architecture: i386
Date: Fri Aug 20 18:43:57 2010
ExecutablePath: /usr/bin/evince
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Alpha i386 (20100803.1)
ProcCmdline: BOOT_IMAGE=/boot/vmlinuz-2.6.35-14-generic root=UUID=1249671c-b52e-48f0-bd1b-d91cf4420dae ro quiet splash
ProcEnviron:
 LANG=en_US.utf8
 SHELL=/bin/bash
Signal: 5
SourcePackage: evince
StacktraceTop:
 ?? () from /usr/lib/libgio-2.0.so.0
 ?? () from /usr/lib/libgio-2.0.so.0
 g_object_newv () from /usr/lib/libgobject-2.0.so.0
 g_object_new_valist () from /usr/lib/libgobject-2.0.so.0
 g_object_new () from /usr/lib/libgobject-2.0.so.0
Title: evince crashed with signal 5 in g_object_newv()
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

Timmy Shih Jun Yee (shijun) wrote :

Please attach one of the PDF files that crashes Evince to this bug report. Thanks!

Changed in evince (Ubuntu):
status: New → Incomplete
Changed in evince (Ubuntu):
importance: Undecided → Low
Felix Zweig (f.zweig) wrote :

When running evince from terminal, I get the following message:

$ evince

GLib-GIO-ERROR **: Settings schema 'org.gnome.Evince.Default' is not installed

aborting...
Trace/breakpoint trap (core dumped)

tags: added: apport-collected

Architecture: i386
DistroRelease: Ubuntu 10.10
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Beta i386 (20100901.1)
Package: evince 2.31.90-0ubuntu1
PackageArchitecture: i386
ProcCmdline: BOOT_IMAGE=/vmlinuz-2.6.35-19-generic root=UUID=386b980b-adc2-4268-803f-c53a0386290c ro quiet splash profile
ProcEnviron:
 LANG=en_US.utf8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.35-19.28-generic 2.6.35.3
Tags: maverick
Uname: Linux 2.6.35-19-generic i686
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

apport information

apport information

apport information

I forgot to mention that it's not restricted to a single PDF file, but the crash happens with whatever document I'm trying to open.

Changed in evince (Ubuntu):
status: Incomplete → New

Evince won't open at all.

evince

GLib-GIO-ERROR **: Settings schema 'org.gnome.Evince.Default' is not installed

aborting...
Trace/breakpoint trap (core dumped)

See Attachment for full Backtrace with libgl2.0-0-dbg installed.

libglib2.0-0-dbg was what i meant...

Jonathan Davies (jpds) on 2010-09-05
Changed in evince (Ubuntu):
status: New → Confirmed
Lars Kumbier (derlars) wrote :

why is the importance of this bug set to "low"? If I can't read PDFs, I basically can stop working... Sure, it's not a kernel OOPS, but could you put the importance higher please?

Lars Kumbier (derlars) wrote :

okay, the problem is based in not having Empathy installed, as there is a dependency in /usr/share/glib-2.0/schemas/ubuntu-artwork.gschema.override. This prevents the schemas from being built correctly, if Empathy is not installed (like on my system):

root@host:~# glib-compile-schemas /usr/share/glib-2.0/schemas/
No such schema `org.gnome.Empathy.conversation' specified in override file `/usr/share/glib-2.0/schemas/ubuntu-artwork.gschema.override'

Installing Empathy again or deleting the ubuntu-artwork.gschema.override, Evince works normally after recompiling the schemas. As does gcacltool, which as the same problems: https://bugs.launchpad.net/ubuntu/+source/gcalctool/+bug/630460

This seems directly related to this bug: https://bugs.launchpad.net/ubuntu/+source/glib2.0/+bug/602175

Natim (site-remy) wrote :

I can confirm that installing empathy fixed the bug for me.

Thanks , is O.K. after reinstalled Emphaty !!!

2010/9/6 Natim <email address hidden>

> I can confirm that installing empathy fixed the bug for me.
>
> --
> evince crashed with signal 5 in g_object_newv()
> https://bugs.launchpad.net/bugs/621507
> You received this bug notification because you are a direct subscriber
> of the bug.
>

affects: evince (Ubuntu) → ubuntu-artwork (Ubuntu)
Changed in ubuntu-artwork (Ubuntu):
assignee: nobody → Robert Ancell (robert-ancell)
importance: Low → High
summary: - evince crashed with signal 5 in g_object_newv()
+ gsettings override created a depends on empathy
summary: - gsettings override created a depends on empathy
+ glib-compile-schemas fails if override files refer to non-installed
+ schemas
affects: ubuntu-artwork (Ubuntu) → glib2.0 (Ubuntu)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package glib2.0 - 2.25.15-0ubuntu2

---------------
glib2.0 (2.25.15-0ubuntu2) maverick; urgency=low

  * debian/patches/06_glib_compile_schemas.patch:
    - Ignore broken schemas and overrides entries referring to schemas not
      installed (LP: #621507)
 -- Robert Ancell <email address hidden> Tue, 07 Sep 2010 15:49:00 +1000

Changed in glib2.0 (Ubuntu):
status: Confirmed → Fix Released
Changed in glib:
status: Unknown → New

I experienced this crash when pasting some text into OpenOffice 3.2 spreadsheet. I was not using evince at the time.

Frans van Berckel (fberckel) wrote :

If bug the fix in bug #621507 got to solve this Evince issue, it does NOT after installing glib2.0 2.25.15-0ubuntu2.

Robert Ancell (robert-ancell) wrote :

Frans, what steps do you take to reproduce the issue?

I can confirm the bug is fixed for me:
1. ubuntu-artwork is installed
2. empathy is not installed
3. evince and gcalctool both work - they did not before

Frans van Berckel (fberckel) wrote :

I can confirm the bug is NOT fixed for me:
1. ubuntu-artwork is installed
2. empathy is or is not installed
3. evince and gcalctool both NOT work

Changed in glib:
importance: Unknown → Medium
Changed in glib:
status: New → Confirmed
Changed in glib:
status: Confirmed → Fix Released

With glib 2.26.0-0ubuntu1 evince still crashes with GLib-GIO-ERROR

From strace:

open("/usr/share/glib-2.0/schemas/gschemas.compiled", O_RDONLY|O_LARGEFILE) = 14
fstat64(14, {st_mode=S_IFREG|0644, st_size=12972, ...}) = 0
mmap2(NULL, 12972, PROT_READ, MAP_PRIVATE, 14, 0) = 0xf5fff000
close(14) = 0
write(2, "\nGLib-GIO-ERROR **: Settings sch"..., 93
GLib-GIO-ERROR **: Settings schema 'org.gnome.Evince.Default' is not installed

aborting...
) = 93

A directory with single schema compiled. I suspect the issue is related to the big-endianness (should separate bug be open?). Opened a bug upstream: https://bugzilla.gnome.org/show_bug.cgi?id=630968 - since the scenario is reproducable from git

The upstream bug got fixed. Could we have those patches in ubuntu? Anything using gsettings is unusable ATM

Luke Yelavich (themuso) wrote :

We can get the relevant patches pushed through as an SRU.

Andrew Engelbrecht (sudoman) wrote :

I'm still having this issue in 10.10 on a PPC machine. Has the patched version been released?

GLib-GIO-ERROR **: Settings schema 'org.gnome.Evince.Default' is not installed

Jonathan Hudson (jh+lpd) wrote :

It would appear not and the problem is likely more than that. Building Glib from git and installing it with LD_LIBRARY_PATH or /etc/ld.so.conf.d/ trickery will allow applications like empathy and evince to run, but the settings are corrupt and (now I'm way out of my depth) probably require a new GConf as well, then you have to repair the damage done by the broken gsettings conversion processes (including things like

$ gsettings-data-convert --verbose
(gsettings-data-convert:12168): GLib-GObject-CRITICAL **: gtype.c:2710: You forgot to call g_type_init()
(gsettings-data-convert:12168): GLib-GObject-CRITICAL **: g_object_new: assertion `G_TYPE_IS_OBJECT (object_type)' failed
(gsettings-data-convert:12168): GLib-GObject-CRITICAL **: g_object_ref: assertion `G_IS_OBJECT (object)' failed
Segmentation fault

Just rebuilding Glib allows the affected applications to run with:
GLib-GIO-Message: Using the 'memory' GSettings backend. Your settings will not be saved or shared with other applications.

which is better than nothing.

-jh

Drew: it is fixed upstream for PPC, waiting for Ubuntu to package

rquint (richard-quint) wrote :

I've just done an upgrade of a powerpc iMac G3 from lucid to meerkat with all additional updates as of 18.10.10. I also have this problem with evince. Just to confirm that there is nothing in the pdf files that is causing the problem I checked they are readable on the machine with ghostview. Can I send any info that would be of use. Synaptic reports the installed version of libglib2.0-0 is 2.26.0-0ubuntu1.

I can confirm the issue on my Powermac G4/800 "Silver", with the latest 10.10 updates installed a few minutes ago. It is not bound to any pdf document; just running evince from a terminal triggers the crash.

$ gsettings-data-convert --verbose
All uptodate, nothing to do

$ evince
GLib-GIO-ERROR **: Settings schema 'org.gnome.Evince.Default' is not installed
aborting...
Trace/breakpoint trap

$ evince --version
GNOME dokumentvisning 2.32.0

1. ubuntu-artwork is installed
2. empathy is not installed
3. evince or gcalctool do not work

On C2D E8500 amd64 linux 2.6.36 (natty).
I tried reinstalling the evince packages to no avail.

Robert Ancell (robert-ancell) wrote :

Re-opening as the patch that fixed this was dropped in 2.26.0-0ubuntu1. Confirming this problem does occur in Maverick.

Changed in glib2.0 (Ubuntu):
status: Fix Released → Triaged
Changed in glib2.0 (Ubuntu Maverick):
importance: Undecided → Medium
status: New → Triaged
Changed in glib2.0 (Ubuntu Maverick):
status: Triaged → Invalid
Changed in glib2.0 (Ubuntu):
status: Triaged → Fix Released
Robert Ancell (robert-ancell) wrote :

On further investigation, the bug appears to be in natty, not maverick. The changes were not present in 2.27.0 so this bug is occurring again. However the changes are in git master so it will be fixed again in 2.27.1.

rquint (richard-quint) wrote :

How does an end user fix their system? I deleted libglib2* from my cache and then used synaptic to download and reinstall them, but that did not fix the problem with evince--starting evince in a terminal still yields

rquint@old-iMac:~$ evince

GLib-GIO-ERROR **: Settings schema 'org.gnome.Evince.Default' is not installed

aborting...
Aborted

Robert Ancell (robert-ancell) wrote :

rquint, Albrecht, I think you are getting bug 663384. Could you please add any information to that bug that you think may help.

Robert Roth (evfool) wrote :

Is bug #666312 a duplicate of this?
 It's about a gcalctool crash with GLib-GIO-ERROR **: Settings schema 'org.gnome.gcalctool' is not installed, but it's reported after this fix has been released.

Updated to all latest packages. The bug is still there.

$ evince

GLib-GIO-ERROR **: Settings schema 'org.gnome.Evince.Default' is not installed

aborting...

robbie (roberto-tomas-cuentas) wrote :

I get this error as well. installed the dbg because I am getting many errors like this and particularly not having evince is driving me nuts :D Log appears equally lacking:

GNU gdb (GDB) 7.2-ubuntu
Copyright (C) 2010 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law. Type "show copying"
and "show warranty" for details.
This GDB was configured as "powerpc-linux-gnu".
For bug reporting instructions, please see:
<http://www.gnu.org/software/gdb/bugs/>...
Reading symbols from /usr/bin/evince...(no debugging symbols found)...done.
(gdb) run
Starting program: /usr/bin/evince
[Thread debugging using libthread_db enabled]
[New Thread 0xf7c32310 (LWP 26435)]
[New Thread 0xf72ff310 (LWP 26436)]

GLib-GIO-ERROR **: Settings schema 'org.gnome.Evince.Default' is not installed

aborting...

Program received signal SIGABRT, Aborted.
0x1f0f1b8c in raise () from /lib/libc.so.6
(gdb)

robbie (roberto-tomas-cuentas) wrote :

its been more than a month with the current release version of the OS housing this bug .. any head up on how long before ubuntu supports reading pdfs again?

Andrew Engelbrecht (sudoman) wrote :

In the meantime, try installing xpdf-reader.

robbie (roberto-tomas-cuentas) wrote :

thank you Drew :) I can report that xpdf-reader does work.

Its worth pointing out that glib 2.26 was uploaded to maverick-proposed. Powerpc users, I suggest you enable maverick-proposed and test the glib package there to see if the issue is fixed.

Yes, 2.26 fixed the issue for me! I can run evince, hurray! Would you promote that package to the official updates?

Jonathan Hudson (jh+lpd) wrote :

Installed on ppc, thanks. empathy runs with the "Using the 'memory' GSettings backend." message.
Saving evince settings results in a crash " evince: symbol lookup error: /usr/lib/libgio-2.0.so.0: undefined symbol: g_main_context_invoke".

But at least the apps run, so it's an improvement, albeit far from the usability on ia32 or x86_64. Perhaps the endian issues remain?

-jh

Luke Yelavich (themuso) wrote :

No I can't, as I am not an archive admin. Its being tracked in ug #663384, as that bug is specific to the powerpc problem discussed here.

As for the symbol lookup issue, I'll try and reproduce here, and if so, I'll see if a rebuild somewhere fixes the issue. From now on, I will reply to the other bug.

Jonathan Hudson (jh+lpd) wrote :

The evince crash was due to (mea culpa, a more recent version of libgio begin around (from an earlier investigation of the problem). Removing it fixes the evince crash. Apologies for the noise.

-jh

alektrotsky (aleksanderesk) wrote :

I can verify that installing the pre-release updates for glib allows the schemas to compile correctly for PowerPC. I'm running Maverick Meerkat on a PowerBook G4.

Nowheretoseek (nowheretoseek) wrote :

no solutions so far?

Azmodeus (91balint) wrote :

azmodeus@ubi ~> gsettings-data-convert --verbose
File 'brasero.convert already converted, skipping
File 'gvfs-dns-sd.convert already converted, skipping
File 'gvfs-smb.convert already converted, skipping
File 'nautilus-sendto-convert already converted, skipping
File 'shotwell.convert already converted, skipping
File 'org.gnome.crypto.pgp.convert already converted, skipping
collecting settings for schema 'org.gnome.desktop.background'

GLib-GIO-ERROR **: Settings schema 'org.gnome.desktop.background' is not installed

aborting...
fish: Job 1, “gsettings-data-convert --verbose” terminated by signal SIGABRT (Abort)

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.