g_set_prgname() called multiple times

Bug #501670 reported by arky on 2009-12-30
134
This bug affects 27 people
Affects Status Importance Assigned to Milestone
glib2.0 (Debian)
Fix Released
Unknown
glib2.0 (Ubuntu)
Low
Ubuntu Desktop Bugs

Bug Description

Binary package hint: emacs-snapshot

emacs warns on starting..

(emacs:4846): GLib-WARNING **: g_set_prgname() called multiple times

ProblemType: Bug
Architecture: i386
Date: Wed Dec 30 21:21:38 2009
DistroRelease: Ubuntu 10.04
Package: emacs-snapshot 1:20090909-1
ProcEnviron:
 PATH=(custom, user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.32-6.8-generic
SourcePackage: emacs-snapshot
Tags: lucid
Uname: Linux 2.6.32-6-generic i686

arky (arky) wrote :
dino99 (9d9) wrote :

same warning, but with: (firefox:3476): GLib-WARNING **: g_set_prgname() called multiple times

pmitros (pmtemp79) wrote :

This also effects emacs23 (with x) in Ubuntu 9.10:

(emacs:22241): GLib-WARNING **: g_set_prgname() called multiple times

Isaac Golding (isaac-golding) wrote :

After updating today I received this error, removing the .firefox directory had no effect on the error

$ firefox

(firefox:16157): GLib-WARNING **: g_set_prgname() called multiple times

(firefox:16157): GLib-WARNING **: g_set_prgname() called multiple times

(firefox:16157): GLib-WARNING **: g_set_prgname() called multiple times
Segmentation fault

affects: emacs-snapshot (Ubuntu) → glib2.0 (Ubuntu)
Chris Coulson (chrisccoulson) wrote :

The commit which caused this has been reverted now

Changed in glib2.0 (Ubuntu):
assignee: nobody → Ubuntu Desktop Bugs (desktop-bugs)
importance: Undecided → Low
status: New → Fix Committed
Sebastien Bacher (seb128) wrote :

The issue is fixed in lucid

Changed in glib2.0 (Ubuntu):
status: Fix Committed → Fix Released
Bashar (kuwaitnet) wrote :

how to apply this fix? because its giving me problem with my thunderbird too
bashar@bashar-laptop:~$ thunderbird

(thunderbird-bin:2702): GLib-WARNING **: g_set_prgname() called multiple times

Segmentation fault
bashar@bashar-laptop:~$

Bashar (kuwaitnet) wrote :

im on 9.10 btw

Sebastien Bacher (seb128) wrote :

the crash issue is a different one, the warning doesn't lead to other issues

Ray Chidley (rchidley) on 2010-01-16
Changed in glib2.0 (Ubuntu):
status: Fix Released → Fix Committed
status: Fix Committed → Fix Released
status: Fix Released → Confirmed
status: Confirmed → Invalid
MonkeyMorph (robert-bogie) wrote :

Sebastien Bacher wrote on 2010-01-11: #7
The issue is fixed in lucid
Changed in glib2.0 (Ubuntu):
status: Fix Committed → Fix Released

How do we implement this fix if we are still getting the error message?

Many thanks.

Jingyu Zou (jingyu-zou) wrote :

Can someone please provide a fix or at least a workaround for 9.10? Or are we all supposed to upgrade to lucid right away because it has been fixed there? And to Mr. Ray Chidley, no offense, bu twhy did you mark this bug as invalid when it is still bothering me everyday as well as lots of other 9.10 users I believe?

Sebastien Bacher (seb128) wrote :

why do people care so much about a warning printed on the command line there? the issue is only a warning one, not a crasher or something breaking any software

I found it was stopping thunderbird running, or at least obscuring the actual problem.

For those that want to fix it I found this after much searching yesterday:

Go to the Synaptics Package Manager in the System => Administration menu
Search for libglib
Select "libglib2.0-0" (should be version 2.22.3)
Press Ctrl+E or go to Packages => Force Version...
Force the version to 2.22.2
Apply the changes

This worked for me, but if it doesn't work for you try looking for any of the other libglib packages that are still on version 2.22.3 and changing them.

Hope that helps
-Scut

Chris Coulson (chrisccoulson) wrote :

This doesn't stop applications from running - it's just a warning. If you're experiencing other behaviour, then you're probably experiencing a separate bug. Advising users to force glib to a specific version to hide a warning is not sensible advice, and might cause more real issues for users than it solves.

Please don't do this. It's completely unsupported, and you're on your own if you break other things

Okay, just a couple of things.

First I said It was either stopping it running *or* obscuring the actual problem. Once I'd managed to get rid of this error message I was able to see what was left over and fix that. I didn't know enough about this to know whether it was part of the problem.

Second I didn't actually advise them to do that, I just said what they could do if they wanted to. If someone who knew more than me had commented earlier saying specifically that any problems experienced at the same time as this had to be from another source entirely then I wouldn't have even gone looking for a way to stop it.

Now that I know this is unrelated I'll say that the other problem I had was solved by following the instructions here:
http://kb.mozillazine.org/Standard_diagnostic_-_Thunderbird

Once I'd backed up my profile, deleted the chrome and extensions folders, and created a new profile, it worked. I was able to copy all of the extension folders back with no problems, though I expect that won't be the case for many people.

Is there any way to edit my comment to remove those steps from it?

djjuhasz (david-artefactual) wrote :

I don't understand why this has been marked invalid. I realize that it's not breaking anything and that this makes it a low priority, but it's still an ugly error message every time I call gvim in 9.10.

Jingyu Zou (jingyu-zou) wrote :

Sebastien Bacher wrote 11 hours ago: #13

why do people care so much about a warning printed on the command line there? the issue is only a warning one, not a crasher or something breaking any software

--------------

I do find this warning very annoying for two reasons: first, seeing the warning itself everytime I run emacs is annoying enough to me as I do this a lot of times from command-line everyday; second, I am used to the way of launching emacs as "emacs some_file &" so that after emacs pops out I still have the command-line prompt but with this warning I have to hit an extra Enter to get back to the prompt.

Well okay, now I realized that I could have used alias emacs="emacs 2>/dev/null" to get around my problem but maybe a newbie to Ubuntu got so pissed off by this small thing for similar reasons that he ended up switching back to Windows.

My point is, (assuming this bug is now a very easy-to-fix one after fixes to lucid is done), why couldn't Ubuntu developers care a bit more about users' experience and make their Ubuntu journey smoother other than filled with little bumps which users are supposed to either put up with or be able smoothen by themselves?

Sebastien Bacher (seb128) wrote :

> why couldn't Ubuntu developers care a bit more about users' experience and make their Ubuntu journey smoother

because there is some thousand bugs open by active contributor and there is no way with this ressources we could both backport every warning fix to stable and fix new bugs for the next version, we decided on trying to fix crasher and real bugs in new code rather than focusing on backporting every change to stable

Allen Petersen (allen-suberic) wrote :

Another vote to fix this.

As paper cuts go, this one is like a really nasty one under your thumbnail. And Ubuntu has figured out that fixing paper cuts is actually worth doing, right?

Sebastien Bacher (seb128) wrote :

could people stop arguing there? that's not a papercut issue, it's a warning in a system log or on command lines

Loïc Minier (lool) wrote :

Upstream bug which triggered this change in behavior in glib: https://bugzilla.gnome.org/show_bug.cgi?id=563627

It may only be a warning to you, but it's an issue that effects my productivity. Here's an example: I'll run some command (for example, grep) that produces a list of files, then go to edit them with gvim.... oops, between this and 402188, my grep output has now scrolled off the top of the screen.

wind (pipilu8) wrote :

Please fix this as it makes me questioning the quality of Ubuntu. As a first time 9.10 user, I find myself going back to redhat due to crashed vncconfig (on 64bit), problematic eclipse ide, hundreds of errors on [sda] Sense Key : Recovered Error ...

Sebastien Bacher (seb128) wrote :

the previous comment has nothing to do with this bug

mikeize (mikequist) wrote :

Firefox will not run *at all* on my computer, currently. I don't know what happened. Yesterday, it worked fine---->no updates--->today it won't run. I tried running from terminal, and got the above error. I cannot get firefox to run. I had to install midori, just to search for this error.

Chris Coulson (chrisccoulson) wrote :

Firefox not running has nothing to do with this warning. As explained above, it is just a warning. There aren't any other consequences

Chris: Instead of just stating blankly what the problem isn't, why not offer some advise.

mikeize: Try the steps listed here, that will probably solve whatever the problem is.
http://kb.mozillazine.org/Standard_diagnostic_-_Firefox

Thanks for both your replies. I'll try the fix when I'm back at my computer.

On 2/9/10, scutterman <email address hidden> wrote:
> Chris: Instead of just stating blankly what the problem isn't, why not
> offer some advise.
>
> mikeize: Try the steps listed here, that will probably solve whatever the
> problem is.
> http://kb.mozillazine.org/Standard_diagnostic_-_Firefox
>
> --
> g_set_prgname() called multiple times
> https://bugs.launchpad.net/bugs/501670
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in “glib2.0” package in Ubuntu: Invalid
> Status in “glib2.0” package in Debian: Unknown
>
> Bug description:
> Binary package hint: emacs-snapshot
>
> emacs warns on starting..
>
> (emacs:4846): GLib-WARNING **: g_set_prgname() called multiple times
>
> ProblemType: Bug
> Architecture: i386
> Date: Wed Dec 30 21:21:38 2009
> DistroRelease: Ubuntu 10.04
> Package: emacs-snapshot 1:20090909-1
> ProcEnviron:
> PATH=(custom, user)
> LANG=en_US.UTF-8
> SHELL=/bin/bash
> ProcVersionSignature: Ubuntu 2.6.32-6.8-generic
> SourcePackage: emacs-snapshot
> Tags: lucid
> Uname: Linux 2.6.32-6-generic i686
>
> To unsubscribe from this bug, go to:
> https://bugs.launchpad.net/ubuntu/+source/glib2.0/+bug/501670/+subscribe
>

--
Sent from my mobile device

I am experiencing that this is not just a hidden error. My Gnome-Do Docky is badly affected. It seems that it starts up a double process which causes the dock to disappear at random times, and sometimes not at all at startup. (a random behaviour). This is worked around by opening the process manager and killing one of the processes.

When I run Gnome-Do from the command line, this is the message I get (after a fresh install of 9.10)

(/usr/lib/gnome-do/Do.exe:2819): GLib-WARNING **: g_set_prgname() called multiple times

(/usr/lib/gnome-do/Do.exe:2819): Wnck-CRITICAL **: wnck_set_client_type got called multiple times.

Could not locate Tomboy on D-Bus. Perhaps it's not running?
Firefox.PlacesItemSource "Firefox Places" encountered an error in UpdateItems: Object reference not set to an instance of an object.
Could not locate Tomboy on D-Bus. Perhaps it's not running?
Firefox.PlacesItemSource "Firefox Places" encountered an error in UpdateItems: Object reference not set to an instance of an object.
Could not locate Tomboy on D-Bus. Perhaps it's not running?
Firefox.PlacesItemSource "Firefox Places" encountered an error in UpdateItems: Object reference not set to an instance of an object.
Could not locate Tomboy on D-Bus. Perhaps it's not running?
Firefox.PlacesItemSource "Firefox Places" encountered an error in UpdateItems: Object reference not set to an instance of an object.
Could not locate Tomboy on D-Bus. Perhaps it's not running?
Firefox.PlacesItemSource "Firefox Places" encountered an error in UpdateItems: Object reference not set to an instance of an object.

Definitely a real problem for me.

Ahmed Osama (aosama) wrote :

Having the same issue within mozilla firefox. Downgrading libglibc from 2.22.3 to 2.22.2 was the appropriate workaround to get rid of this warning.

Thank you.

Carl Nobile (cnobile1) wrote :

This is also happening with virt-manager, but as it has been mention has no effect on the running of the application.

I usually start my day long editing session with "emacs file &" from there because it much faster than opening the main menu as I always have an open terminal. This warning is very annoying because it makes the terminal scroll.
Maybe it's not a high priority bug (I'd pay to fix some other issues... for instance I can't suspend anymore since 9.04) but I'd appreciate if somebody fixes it.

MarcoPau (marcopau) wrote :

Same here with emacs from command line...

odyseuss (cxc639) wrote :

>scutterman wrote on 2010-01-19: #14
>Go to the Synaptics Package Manager in the System => Administration menu
>Search for libglib
>Select "libglib2.0-0" (should be version 2.22.3)
>Press Ctrl+E or go to Packages => Force Version...
>Force the version to 2.22.2
>Apply the changes

Scut, I followed your instruction and it works for me.
Now I can say goodbye to those annoying "g_set_prgname() called..." warnings.
Many thanks.

jonesints (jone-u2) wrote :

Not that I intend forcing to version 2.22.2 since I'm soon planning on upgrading, but I thought I'd say, I got this error when trying to launch tomboy and now it won't even load at all. So, at least in my case its more than just a terminal message.
If people don't intend to upgrade, I can understand the importance of fixing it!

studio@studio-laptop:~$ tomboy

(/usr/lib/tomboy/Tomboy.exe:3420): GLib-WARNING **: g_set_prgname() called multiple times

(/usr/lib/tomboy/Tomboy.exe:3420): GLib-WARNING **: g_set_prgname() called multiple times
[INFO]: Initializing Mono.Addins

Unhandled Exception: System.IO.IOException: Invalid handle to path "/home/studio/.local/share/tomboy/0d6597e4-b650-495d-8118-10d8b5487dfa.note"
  at System.IO.FileStream..ctor (System.String path, FileMode mode, FileAccess access, FileShare share, Int32 bufferSize, Boolean anonymous, FileOptions options) [0x00000]
  at System.IO.FileStream..ctor (System.String path, FileMode mode, FileAccess access, FileShare share) [0x00000]
  at (wrapper remoting-invoke-with-check) System.IO.FileStream:.ctor (string,System.IO.FileMode,System.IO.FileAccess,System.IO.FileShare)
  at System.IO.File.OpenRead (System.String path) [0x00000]
  at System.IO.StreamReader..ctor (System.String path, System.Text.Encoding encoding, Boolean detectEncodingFromByteOrderMarks, Int32 bufferSize) [0x00000]
  at System.IO.StreamReader..ctor (System.String path, System.Text.Encoding encoding) [0x00000]
  at (wrapper remoting-invoke-with-check) System.IO.StreamReader:.ctor (string,System.Text.Encoding)
  at Tomboy.NoteArchiver.ReadFile (System.String read_file, System.String uri) [0x00000]
  at Tomboy.NoteArchiver.Read (System.String read_file, System.String uri) [0x00000]
  at Tomboy.Note.Load (System.String read_file, Tomboy.NoteManager manager) [0x00000]
  at Tomboy.NoteManager.LoadNotes () [0x00000]
  at Tomboy.NoteManager..ctor (System.String directory, System.String backup_directory) [0x00000]
  at Tomboy.NoteManager..ctor (System.String directory) [0x00000]
  at Tomboy.Tomboy.Main (System.String[] args) [0x00000]

neuromancer (neuromancer) wrote :

Just two tips for user who have this problem starting Thunderbird.
My friend is running Ubuntu karmic 9.10 and thunderbird 3.1.2.
Sometime thunderbird stop working, he double click the icon but the program doesn't start.
So i read this discussion, and, as said by scutterman in #16, the solution is in the mozilla Kb http://kb.mozillazine.org/Standard_diagnostic_-_Thunderbird

In my case I have opened a terminal, then typed thunderbird -safe-mode and thunderbird start.
After that I've disabled all extension, closed thunderbird and reopened in normal mode 2 or 3 times (just typing thunderbird or double click in the desktop icon).
Next step (to repeat for every extension do you have) is to enable one extension a time, close thunderbird and reopen.
After a while I have found the guilty, in my case Lightning 1.0b2.

g_set_prgname() called multiple times is only a warning and have nothing to do with the real problem ;)
by

Stil an issue on 10.10 (libglib2.0-0 2.26.0-0ubuntu1 and emacs23 23.1+1-4ubuntu7).

I it is really irritating, and although I understand there are so and so many more important issues, it does not make this issue invalid or go away.

Don't you have a "WONTFIX" state which you can use when priority and resources concerns results in valid issues being dropped?

Argh, forget that about still being here on 10.10, I was using emacs in the wrong terminal after upgrading. Good to see this gone :-D

But I still wonder why valid issues are marked invalid because of resource and/or priority concerns.

Changed in glib2.0 (Debian):
status: Unknown → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.