Everything whick is linked against libgio-2.0 core dump

Bug #402693 reported by Raine on 2009-07-21
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
GLib
Fix Released
Critical
glib2.0 (Ubuntu)
Medium
Unassigned

Bug Description

Hi! I'll post same info posted on Ubuntu Forums: http://ubuntuforums.org/showthread.php?t=1219305

Recently I've updated to latest kernel 2.6.28-14-generic i686 in my Jaunty Jackalope 9.04 32-bit system.

I use kde4 4.3 RC and in the latest days I've been suffering of massive core dumping due to 'segmentation fault' my applications that depend on Gnome libs.

My thunderbird can't even save an attachment, it just cores dump

I've tried gedit from console, it cores dump even before starting!

Here is the backtrace of gdb on gedit behavior:

[CODE]
(gdb) bt
#0 0x00000000 in ?? ()
#1 0xb790cd9d in ?? () from /usr/lib/libgio-2.0.so.0
#2 0xb78e58b2 in ?? () from /usr/lib/libgio-2.0.so.0
#3 0xb78f92f9 in ?? () from /usr/lib/libgio-2.0.so.0
#4 0xb78f2204 in ?? () from /usr/lib/libgio-2.0.so.0
#5 0xb7738e26 in ?? () from /usr/lib/libglib-2.0.so.0
#6 0xb77377bf in ?? () from /usr/lib/libglib-2.0.so.0
#7 0xb76b04ff in start_thread () from /lib/tls/i686/cmov/libpthread.so.0
[/CODE]

From my thunderbird launched on console:
$ /usr/lib/thunderbird/thunderbird

[CODE]
#0 0xb808e430 in __kernel_vsyscall ()
#1 0xb7ec74b0 in raise () from /lib/tls/i686/cmov/libpthread.so.0
#2 0x08057c3e in ?? ()
#3 <signal handler called>
#4 0xb4132a52 in ?? ()
#5 0xb79ebd9d in ?? () from /usr/lib/libgio-2.0.so.0
#6 0xb79c48b2 in ?? () from /usr/lib/libgio-2.0.so.0
#7 0xb79d82f9 in ?? () from /usr/lib/libgio-2.0.so.0
#8 0xb79d1204 in ?? () from /usr/lib/libgio-2.0.so.0
#9 0xb77a5e26 in ?? () from /usr/lib/libglib-2.0.so.0
#10 0xb77a47bf in ?? () from /usr/lib/libglib-2.0.so.0
#11 0xb7ebf4ff in start_thread () from /lib/tls/i686/cmov/libpthread.so.0
#12 0xb74a749e in clone () from /lib/tls/i686/cmov/libc.so.6
[/CODE]

As you can see something in libgio-2.0.so is wrong. Maybe some new bug due to latest kernel patch (that nasty bug on NULL pointers stuff).

Interesting part:
if open gedit with gksudo it just works witout any core dump!

$ gksudo gedit

Any help?

Thanks and regards!
Raine

Raine (rainefan) on 2009-07-21
description: updated
Raine (rainefan) wrote :

More information:

Using Firefox when downloading a file (lucky me) opened the file-browser window effectively (no core dump here). The difference is is last path Firefox saved was /usr/share/icons, then I've changed to <home dir> and, here we go, crash and core dump!

Tried again but now trying to save on /tmp. Again, crash and core dump.

Here is my directory rights:

/usr/share/icons:
drwxr-xr-x 22 root root 4096 2009-07-17 12:38 icons

/tmp:
drwxrwxrwt 23 root root 20480 2009-07-21 19:51 tmp

<home-dir>:
drwxr--r-- 74 raine raine 4096 2009-07-21 18:54 raine

Raine (rainefan) wrote :

Tried also reinstalling libglib. But same behavior...

sudo aptitude reinstall libglib2.0-0

Any help? I'm really stuck on common operations with my desktop :(

Raine (rainefan) wrote :

Installed libglib2.0-0-dbg package to backtrace the crash.

Here is the full backtrace of the crash:

#0 0x00100007 in ?? ()
No symbol table info available.
#1 0xb7a44d9d in g_local_file_enumerator_next_file (enumerator=0x8e70650, cancellable=0x900f180, error=0xb6c1b248) at /build/buildd/glib2.0-2.20.1/gio/glocalfileenumerator.c:343
        filename = 0x9087d20 "\230Q�\b\002"
        info = <value optimized out>
        my_error = (GError *) 0x0
#2 0xb7a1d8b2 in next_files_thread (res=0x9078b80, object=0x8e70650, cancellable=0x900f180) at /build/buildd/glib2.0-2.20.1/gio/gfileenumerator.c:641
        op = (NextAsyncOp *) 0x8f346f0
        class = (GFileEnumeratorClass *) 0xb63014c8
        error = (GError *) 0x0
        info = <value optimized out>
        i = 72
#3 0xb7a312f9 in run_in_thread (job=0x9047808, c=0x900f180, _data=0x904e700) at /build/buildd/glib2.0-2.20.1/gio/gsimpleasyncresult.c:656
        simple = (GSimpleAsyncResult *) 0x9078b80
        source = <value optimized out>
#4 0xb7a2a204 in io_job_thread (data=0x9047808, user_data=0x0) at /build/buildd/glib2.0-2.20.1/gio/gioscheduler.c:179
        job = (GIOSchedulerJob *) 0x9047808
        result = <value optimized out>
#5 0xb7870e26 in g_thread_pool_thread_proxy (data=0x8e80680) at /build/buildd/glib2.0-2.20.1/glib/gthreadpool.c:265
        task = (gpointer) 0x9047808
        pool = (GRealThreadPool *) 0x8e80680
#6 0xb786f7bf in g_thread_create_proxy (data=0x8f71680) at /build/buildd/glib2.0-2.20.1/glib/gthread.c:635
        __PRETTY_FUNCTION__ = "g_thread_create_proxy"
#7 0xb77e84ff in start_thread () from /lib/tls/i686/cmov/libpthread.so.0
No symbol table info available.
#8 0xb776349e in clone () from /lib/tls/i686/cmov/libc.so.6
No symbol table info available.

Take a look at this: "\230Q�\b\002"

I also updated my system to latest KDE 4.2.98 (KDE 4.3 RC3)

Any help?

Regards,
Raine

Raine (rainefan) wrote :

This issue still exists and it's really anoying. Can't work with firefox, thunderbird, nothing that depends on the gnome file browser.

Raine (rainefan) wrote :

My last chance: reported this issue/bug on gnome's bugzilla site at http://bugzilla.gnome.org/show_bug.cgi?id=591606

Raine

Raine (rainefan) wrote :

Workaround here: http://bugzilla.gnome.org/show_bug.cgi?id=591606

I'll describe how to reproduce it on my Ubuntu 9.04 32-bit (fully updated to
latest version).

The problem is in the file '$HOME/.local/share/mime/mime.cache' (I think it's
corrupted. I've attached above this post a strace dump file and a corrupted
mime.cache file as a tar.gz directory).

Steps to reproduce it:

1) Backup your '.local/' dir

$ mv $HOME/.local/ $HOME/.local_bkp/

2) Create a NEW '.local/' dir
$ mkdir $HOME/.local/; mkdir $HOME/.local/share; mkdir $HOME/.local/share/mime/

3) Copy corrupted 'mime.cache' attached in this post to the NEW dir.
$ cp bug_591606/mime.cache $HOME/.local/share/mime/

4) Launch program linked against libgio (i.e. nautilus)
$ nautilus

5) Enjoy your Segmentation Fault ;)

Steps to workaround:

1) Move '$HOME/.local/share/mime/mime.cache' file to a temporary dir just to
backup it
$ mv $HOME/.local/share/mime/mime.cache $HOME/<temporary_dir>

2) Launch nautilus to test it
$ nautilus

That's all folks!

PD: Anyway, can anybody confirm this bug? Please!

Raine

affects: ubuntu → glib2.0 (Ubuntu)
Changed in glib2.0 (Ubuntu):
status: New → Triaged
importance: Undecided → Medium
Raine (rainefan) wrote :

Guys, I'm having (again) the same issue... ;_(

All my apps core's dump whenever a file explorer windows opens-up or I have to navigate to $HOME folder.

******************************************************* Package information: ******************************
Package: libglib2.0-0
State: installed
Automatically installed: no
Version: 2.20.1-0ubuntu2
Priority: optional
Section: libs
Maintainer: Ubuntu Core Developers <email address hidden>
Uncompressed Size: 1839k
Depends: libc6 (>= 2.8), libpcre3 (>= 7.7), libselinux1 (>= 2.0.59)
Recommends: libglib2.0-data, shared-mime-info
Conflicts: libpango1.0-0 (< 1.11)
*********************************************************************************

Here is attached the mime.cache file which is causing this behavior. The older one (also attached in previous post was deleted once).

The only way to workaround this bug is, in fact, deleting the mime.cache file.

Raine

Raine (rainefan) wrote :

Again... :(

This is really annoying me....have to delete each day $HOME/.local/share/mime/mime.cache

Is there any way you help me in finding which app is corrupting '$HOME/.local/share/mime/mime.cache' file?

Thanks ;_(

peterius (necedemalis) wrote :

Thanks, I was getting this on gentoo under kde4. I had added an icon to a mimetype and then deleted the icon to change it and that's when it started crashing. But libgio shouldn't crash like that, regardless.

Changed in glib:
importance: Unknown → Critical
status: Unknown → Fix Released
Miguel J (mjulier) wrote :

I got the same problem, with the same workaround, today just after upgrading Mozilla Firefox to v18.0. I had a hard time solving the problem.

Symptoms:
  * Anything linked to libgio-2.0 do segfault.
  * cannot login using xfce4-session or gnome-session
  * dbus not working either
  * using xinit and then opera, I could still use internet!

Workaround:
  rm ~/.local/share/mime/mime.cache

Log:
$ cat /var/log/kern.log | tail -1
Jan 11 22:58:42 asuslinux kernel: [ 868.425016] xfce4-session[4187]: segfault at 5bb51138 ip b69af4d1 sp bfe035b0 error 4 in libgio-2.0.so.0.3400.1[b68b8000+15b000]

Versions:
$ dpkg -l |grep glib
ii libglib2.0-0:i386 2.34.1-1ubuntu1 i386 GLib library of C routines
$ uname -a
Linux asuslinux 3.5.0-22-generic #33-Ubuntu SMP Wed Jan 2 21:45:40 UTC 2013 i686 i686 i686 GNU/Linux

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.