unable to play audio CDs on SATA dvd/cd player

Bug #397350 reported by encmonkey on 2009-07-09
60
This bug affects 11 people
Affects Status Importance Assigned to Milestone
glib2.0 (Ubuntu)
Undecided
Unassigned

Bug Description

Howdy!

I can't get 9.04 64 bit (Desktop or Server) to play a regular audio cd to save my life. Depending on your tastes in music, you might think this is a good thing :) This is true for my laptop (Lenovo X301), my server (has 2 sata dvd drives), and a workstation (also has a sata drive). Data disks work completely as expected, I'm able to burn dvds and cds. But if I put a regular audio disk in, I get the following (for example) on my laptop:

[22925.310117] end_request: I/O error, dev sr0, sector 0
[22925.310128] Buffer I/O error on device sr0, logical block 0
[22925.310135] Buffer I/O error on device sr0, logical block 1
[22925.310144] Buffer I/O error on device sr0, logical block 2
[22925.310149] Buffer I/O error on device sr0, logical block 3
[22925.310155] Buffer I/O error on device sr0, logical block 4
[22925.310160] Buffer I/O error on device sr0, logical block 5
[22925.310166] Buffer I/O error on device sr0, logical block 6
[22925.310171] Buffer I/O error on device sr0, logical block 7
[22925.341786] end_request: I/O error, dev sr0, sector 0
[22925.341799] Buffer I/O error on device sr0, logical block 0
[22925.341808] Buffer I/O error on device sr0, logical block 1
[22925.435344] ata2.00: exception Emask 0x12 SAct 0x0 SErr 0x400 action 0x6 frozen
[22925.435353] ata2.00: irq_stat 0x08000000, interface fatal error
[22925.435360] ata2: SError: { Proto }
[22925.435373] ata2.00: cmd a0/00:00:00:02:00/00:00:00:00:00/a0 tag 0 pio 16388 in
[22925.435375] cdb 43 02 05 00 00 00 00 00 02 00 00 00 00 00 00 00
[22925.435377] res 50/00:03:00:04:00/00:00:00:00:00/a0 Emask 0x12 (ATA bus error)
[22925.435383] ata2.00: status: { DRDY }
[22925.435393] ata2: hard resetting link
[22926.032590] ata2: SATA link up 3.0 Gbps (SStatus 123 SControl 300)
[22926.037352] ata2.00: ACPI cmd e3/00:79:00:00:00:a0 succeeded
[22926.038485] ata2.00: ACPI cmd e3/00:01:00:00:00:a0 succeeded
[22926.049889] ata2.00: ACPI cmd e3/00:79:00:00:00:a0 succeeded
[22926.050910] ata2.00: ACPI cmd e3/00:01:00:00:00:a0 succeeded
[22926.053451] ata2.00: configured for UDMA/33
[22926.058956] ata2: EH complete

The disk will spin up, crank, and then spin down all the while popping up a window with "Unable to mount Audio Disk - DBus error org.freedesktop.DBus.Error.NoReply: Message did not receive a reply (timeout by message bus). These windows stack up until I eject the disk from the console (the eject button is locked out at this point).

On my server, I get a bunch of buffer io errors when the cd is inserted and when I try to read the disk via abcde I get this:

[ 2484.561361] Buffer I/O error on device sr1, logical block 0
[ 2484.564566] sr 3:0:0:0: [sr1] Result: hostbyte=DID_OK driverbyte=DRIVER_SENSE
[ 2484.564569] sr 3:0:0:0: [sr1] Sense Key : Illegal Request [current]
[ 2484.564572] sr 3:0:0:0: [sr1] Add. Sense: Illegal mode for this track
[ 2484.564577] end_request: I/O error, dev sr1, sector 0
[ 2484.564608] Buffer I/O error on device sr1, logical block 0

At boot, I get this:
[ 1.102701] Driver 'sr' needs updating - please use bus_type methods
[ 1.438870] sr0: scsi3-mmc drive: 40x/40x writer dvd-ram cd/rw xa/form2 cdda
tray
[ 1.438938] sr 2:0:1:0: Attached scsi CD-ROM sr0
[ 1.438988] sr 2:0:1:0: Attached scsi generic sg0 type 5
[ 1.620293] sr1: scsi3-mmc drive: 40x/40x writer dvd-ram cd/rw xa/form2 cdda
tray
[ 1.620387] sr 3:0:0:0: Attached scsi CD-ROM sr1
[ 1.620432] sr 3:0:0:0: Attached scsi generic sg1 type 5
[ 2.266354] arcmsr 0000:0b:0e.0: PCI INT A -> GSI 18 (level, low) -> IRQ 18
[ 9.013553] sr 3:0:0:0: [sr1] Result: hostbyte=DID_OK driverbyte=DRIVER_SENSE
[ 9.013559] sr 3:0:0:0: [sr1] Sense Key : Illegal Request [current]
[ 9.013563] sr 3:0:0:0: [sr1] Add. Sense: Illegal mode for this track
[ 9.013573] end_request: I/O error, dev sr1, sector 0
[ 9.013626] Buffer I/O error on device sr1, logical block 0
[ 9.013680] Buffer I/O error on device sr1, logical block 1
[ 9.013727] Buffer I/O error on device sr1, logical block 2
[ 9.013774] Buffer I/O error on device sr1, logical block 3
[ 9.015665] sr 3:0:0:0: [sr1] Result: hostbyte=DID_OK driverbyte=DRIVER_SENSE
[ 9.015668] sr 3:0:0:0: [sr1] Sense Key : Illegal Request [current]
[ 9.015672] sr 3:0:0:0: [sr1] Add. Sense: Illegal mode for this track
[ 9.015676] end_request: I/O error, dev sr1, sector 0
[ 9.015723] Buffer I/O error on device sr1, logical block 0

What I expected to happen - put in an audio cd and be able to either play or rip it in some fashion.

What happened instead - errors above.

I can't believe I'm the only person seeing this kind of behavior. The closest thing I was able to find was a bug posted against fedora 11. I'm using very generic clean installs on both systems. Any ideas? Is this a known issue and my google-fu is just sad?

Sam Reynolds (cloudboi) wrote :

I have this same issue. Please let me know if I can provide any additional information that will aid in solving this.

encmonkey (ian-gonesailing) wrote :

I found the posted fedora bug - they're describing the problem exactly there as well.

https://bugzilla.redhat.com/show_bug.cgi?id=485551

encmonkey (ian-gonesailing) wrote :

Ok, after much playing around, I found if I put the Lenovo's SATA ports into "compatibility mode" in the bios, I can at least audio cds. The price of this joy is now eject is extremely flaky at best and typically no longer ejects cds which breaks a good number of my scripts so now they need tender monitoring care..

Gah..

BTW - YMMV on this trick. It didn't work at all on my big server or desktop machine.

caolan (caolan) wrote :

Setting the SATA ports into "compatibility mode" in the bios seems to have fixed this issue for me on the Lenovo x301, many thanks!

caolan (caolan) wrote :

It may be a coincidence but after making this change I had some problems with corrupted data on my SSD, ending up with the machine being unbootable with GRUB Error 2 (not much actual data loss though).

I'm still figuring it out, but since this was a recent change and related to the SSD I'm suspicious that this was the cause.

PROCEED WITH CAUTION! - make a full backup first

encmonkey (ian-gonesailing) wrote :

Yikes. I haven't experienced any issues with the SSD since making that change. Good luck!

Ron Wills (ron-rwsoft) wrote :

I've been having this problem with Ubuntu 9.04 and hoped with an upgrade to 9.10 would fix it, but this bug is still persisting. This is also across multiple kernels including the current one for 9.10, 2.6.31-19-generic.

1. I have 2 Toshiba Laptops A100 and an A200 with the exact same symptoms.
2. On both laptops the DVD drives work perfectly in Windows Vista.
3. On the A200 still has Ubuntu 9.04 and the A100 with Ubuntu 9.10 recently upgraded to see if this problem has
    been fixed, which it has not.
4. I have attempted just about every kernel option available to fix the problem, but nothing has worked :(
5. Neither laptop has BIOS options to adjust the settings for the DVD drives.
6. The problems has persisted for several months.

I have been googling this problem and it seems to affect several distros; Ubuntu, Redhat/Fedora, Gentoo, Suse. I am finding that most responses to the problem is it must be bad hardware or CDs/DVDs or due to in activity of the bugs just assuming it has been fixed :(

The Continual Symptoms:
  [sr0] Result: hostbyte=DID_OK driverbyte=DRIVER_SENSE
  sr 1:0:0:0: [sr0] Sense Key : Illegal Request [current]
  Info fld=0x0
  [sr0] Add. Sense: Illegal mode for this track

  Buffer I/O error on device sr0, logical block XXX

  ata2: lost interrupt (Status 0x50)
  ata2.00: exception Emask 0x0 SAct 0x0 SErr 0x0 action 0x6 frozen
  ata2.00: cmd a0/01:00:00:00:08/00:00:00:00:00/a0 tag 0 dma 2048 in
                cdb be 00 00 04 d4 52 00 00 01 10 00 00 00 00 00 00
                res 40/00:02:00:0c:00/00:00:00:00:00/a0 Emask 0x4 (timeout)
  ata2.00: status: { DRDY }
  ata2: soft resetting link
  ata2.00: configured for UDMA/33
  ata2: EH complete
  ata2.00: limiting speed to UDMA/25:PIO4
  ata2.00: exception Emask 0x0 SAct 0x0 SErr 0x0 action 0x6 frozen
  ata2.00: cmd a0/01:00:00:00:08/00:00:00:00:00/a0 tag 0 dma 2048 in
                cdb be 00 00 04 d5 7e 00 00 01 10 00 00 00 00 00 00
                res 40/00:02:00:0c:00/00:00:00:00:00/a0 Emask 0x4 (timeout)
  ata2.00: status: { DRDY }
  ata2: soft resetting link
  ata2.00: configured for UDMA/25
  ata2: EH complete

I have also searched the kernel bugzilla, but it hasn't seemed to reach them. Is it possible to forward this bug to them or collaborating with other distributors to validate this bug? As far as I can tell it only seems to affect laptops, but this problem gets attributed to bad hardware so fast it's hard to tell.

As time permits I'm going to start further testing my hardware with other OS's, BSD, Minix, ReactOS to see if I get any similar symptoms. If there is anything I can do to help, please let me know ;)

Ron Wills (ron-rwsoft) wrote :

After testing this problem further, it seems this problem exists in gnome (possibly in the vfs subsystem?). If I login into an xterm session I can play and rip audio CD's as expected. To duplicate the errors as above in the xterm session all I have to do is try to mount the audio CD (# mount /dev/sr0 /media/cdrom).

I believe the problem comes from gnome or some part the freedesktop frame works (this problem seems to also exist for KDE users) continual attempts actually mount the audio CD. I believe the desktop session should only be creating/updating icons to indicate there is an audio CD present?

I can get some CD players (like GooBox) to work in Gnome if I turn off nautilus auto mounting, but anything that depends heavily on Gnome still doesn't work (like Rhythmbox).

I hope this can give some direction to a fix ;)

Fabio Marconi (fabiomarconi) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better.
Is this bug reproducible with the latest Lucid packages ?
Tanks in advance.

Changed in ubuntu:
status: New → Incomplete
Fabio Marconi (fabiomarconi) wrote :

We'd like to figure out what's causing this bug for you, but we haven't heard back from you in a while. Could you please provide the requested information? Thanks!

Fabio Marconi (fabiomarconi) wrote :

We are closing this bug report because it lacks the information we need to investigate the problem, as described in the previous comments. Please reopen it if you can give us the missing information, and don't hesitate to submit bug reports in the future. To reopen the bug report you can click on the current status, under the Status column, and change the Status back to "New". Thanks again!

Changed in ubuntu:
status: Incomplete → Invalid

I can confirm this issue is still valid for the Lenovo X301 and Ubuntu 10.10 (as well as 10.04).

Changed in ubuntu:
status: Invalid → New
tsg1zzn (tsg1zzn) wrote :

I assume this is in gio, since it only affects gnome apps.

affects: ubuntu → glib2.0 (Ubuntu)

Still not working on multiple machines. Sometimes it doesn't even open the CD in dolphin.

Linux Kubuntu 2.6.35-23-generic #41-Ubuntu SMP Wed Nov 24 10:18:49 UTC 2010 i686 GNU/Linux

[ 684.988592] ata2.00: exception Emask 0x0 SAct 0x0 SErr 0x0 action 0x6 frozen
[ 684.988605] sr 1:0:0:0: CDB: Unmap/Read sub-channel: 42 02 40 01 00 00 00 00 10 00
[ 684.988633] ata2.00: cmd a0/01:00:00:10:00/00:00:00:00:00/a0 tag 0 dma 16400 in
[ 684.988635] res 40/00:03:00:00:00/00:00:00:00:00/a0 Emask 0x4 (timeout)
[ 684.988642] ata2.00: status: { DRDY }
[ 684.988652] ata2: hard resetting link
[ 684.988656] ata2: nv: skipping hardreset on occupied port
[ 685.456582] ata2: SATA link up 1.5 Gbps (SStatus 113 SControl 300)
[ 685.512222] ata2.00: configured for UDMA/100
[ 685.513352] ata2: EH complete
[ 694.992077] ata2.00: exception Emask 0x0 SAct 0x0 SErr 0x0 action 0x6 frozen
[ 694.992090] sr 1:0:0:0: CDB: Unmap/Read sub-channel: 42 02 40 01 00 00 00 00 10 00
[ 694.992117] ata2.00: cmd a0/01:00:00:10:00/00:00:00:00:00/a0 tag 0 dma 16400 in
[ 694.992120] res 40/00:03:00:00:00/00:00:00:00:00/a0 Emask 0x4 (timeout)
[ 694.992127] ata2.00: status: { DRDY }
[ 694.992137] ata2: hard resetting link
[ 694.992141] ata2: nv: skipping hardreset on occupied port
[ 695.460058] ata2: SATA link up 1.5 Gbps (SStatus 113 SControl 300)
[ 695.516198] ata2.00: configured for UDMA/100
[ 695.516976] ata2: EH complete
[ 798.048554] ata2.00: exception Emask 0x0 SAct 0x0 SErr 0x0 action 0x6 frozen
[ 798.048566] sr 1:0:0:0: [sr0] CDB: Volume set (in), Read cd: be 00 00 00 20 ab 00 00 01 f8 00 00
[ 798.048594] ata2.00: cmd a0/01:00:00:30:09/00:00:00:00:00/a0 tag 0 dma 2352 in
[ 798.048597] res 40/00:02:00:0c:00/00:00:00:00:00/a0 Emask 0x4 (timeout)
[ 798.048604] ata2.00: status: { DRDY }
[ 798.048613] ata2: hard resetting link
[ 798.048618] ata2: nv: skipping hardreset on occupied port
[ 798.516057] ata2: SATA link up 1.5 Gbps (SStatus 113 SControl 300)
[ 798.572695] ata2.00: configured for UDMA/100
[ 798.573504] ata2: EH complete

Data CD/DVD's work fine

Changed in glib2.0 (Ubuntu):
status: New → Confirmed
Callum Macdonald (chmac) wrote :

Awesome, thanks for the info guys. I also have this issue on my Lenovo X301. If I open Nautilus then Edit > Preferences > Media > Never prompt or start programs on media insertion, it works! Finally I can actually play audio CDs! Wow, I'm glad I looked into this today and very glad I found this thread. I just discovered my CD collection from 5 years ago, so now I can rip the good stuff and forget about audio CDs once again. :-)

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.