Comment 38 for bug 369498

On Wed, Aug 26, 2009 at 08:08:41PM -0000, Tim Mann wrote:
> Just for people's information... #22 says:
>
> > The alternative would be to add into user's or environment profile:
> > export GTK_PATH=/usr/lib32/gtk-2.0:/usr/lib/gtk-2.0
>
> I tried the above in my environment (in Jaunty), and it made acroread
> work but broke firefox. The 64-bit firefox 3.0.13 gives up on loading
> several libraries after trying only the 32-bit version, and so printing
> doesn't work:
>
> Gtk-Message: Failed to load module "canberra-gtk-module": /usr/lib32/gtk-2.0/modules/libcanberra-gtk-module.so: wrong ELF class: ELFCLASS32
> (firefox:28933): Gtk-WARNING **: /usr/lib32/gtk-2.0/2.10.0/engines/libglide.so: wrong ELF class: ELFCLASS32
> Gtk-Message: Failed to load module "canberra-gtk-module": /usr/lib32/gtk-2.0/modules/libcanberra-gtk-module.so: wrong ELF class: ELFCLASS32
> (firefox:28933): Gtk-WARNING **: /usr/lib32/gtk-2.0/2.10.0/engines/libglide.so: wrong ELF class: ELFCLASS32
> (firefox:28933): Gtk-WARNING **: /usr/lib32/gtk-2.0/2.10.0/printbackends/libprintbackend-file.so: wrong ELF class: ELFCLASS32
> (firefox:28933): Gtk-WARNING **: /usr/lib32/gtk-2.0/2.10.0/printbackends/libprintbackend-file.so: wrong ELF class: ELFCLASS32
> (firefox:28933): Gtk-WARNING **: /usr/lib32/gtk-2.0/2.10.0/printbackends/libprintbackend-cups.so: wrong ELF class: ELFCLASS32
> (firefox:28933): Gtk-WARNING **: /usr/lib32/gtk-2.0/2.10.0/printbackends/libprintbackend-cups.so: wrong ELF class: ELFCLASS32

some modules are just not in the ia32libs package. in karmic we added
more and if you want more to be added file bugs against ia32libs with
a rational why to add those.

Also the i486-... link is currently created properly in karmic
afaik. If not, we should definitly add it. But remember to remove
atk-bridge at least which is known to break 32-bit adobe flash.

 - Alexander