gdmsetup crashed with SIGSEGV in g_unix_mount_guess_should_display()

Bug #252942 reported by Atanas Atanasov on 2008-07-29
8
Affects Status Importance Assigned to Milestone
GLib
Fix Released
Critical
glib2.0 (Ubuntu)
Medium
Ubuntu Desktop Bugs
Hardy
Undecided
Unassigned

Bug Description

Binary package hint: gdm

gdmsetup crashes on start.

I also encountered another problem with apport. It would report that firefox is not responding when firefox is open. I had to close firefox and then apport opened it anew.

ProblemType: Crash
Architecture: amd64
Date: Tue Jul 29 15:18:05 2008
DistroRelease: Ubuntu 8.10
ExecutablePath: /usr/sbin/gdmsetup
NonfreeKernelModules: fglrx
Package: gdm 2.20.7-0ubuntu2
PackageArchitecture: amd64
ProcCmdline: gdmsetup
ProcEnviron:
 PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/X11R6/bin
 LANG=en_US.UTF-8
 LANGUAGE=en_US.UTF-8:en
 SHELL=/bin/bash
Signal: 11
SourcePackage: gdm
StacktraceTop:
 g_unix_mount_guess_should_display ()
 ?? () from /usr/lib/libgio-2.0.so.0
 ?? () from /usr/lib/libgio-2.0.so.0
 ?? () from /usr/lib/libgio-2.0.so.0
 ?? () from /usr/lib/libgio-2.0.so.0
Title: gdmsetup crashed with SIGSEGV in g_unix_mount_guess_should_display()
Uname: Linux 2.6.26-4-generic x86_64
UserGroups:

Atanas Atanasov (thenasko) wrote :

StacktraceTop:_g_unix_mount_new (volume_monitor=0x0, mount_entry=0x0, volume=0x0) at /build/buildd/glib2.0-2.17.4/gio/gunixmount.c:114
get_mount_for_mount_path (mount_path=<value optimized out>, cancellable=<value optimized out>) at /build/buildd/glib2.0-2.17.4/gio/gunixvolumemonitor.c:155
_g_mount_get_for_mount_path (mount_path=0x1f44a70 "//", cancellable=0x0) at /build/buildd/glib2.0-2.17.4/gio/gunionvolumemonitor.c:585
g_local_file_find_enclosing_mount (file=<value optimized out>, cancellable=0x0, error=0x0) at /build/buildd/glib2.0-2.17.4/gio/glocalfile.c:1079
_gtk_file_system_get_volume_for_file (file_system=0x1fba040, file=0x2033a40) at /build/buildd/gtk+2.0-2.13.5/gtk/gtkfilesystem.c:1155

Changed in gdm:
importance: Undecided → Medium
Sebastien Bacher (seb128) wrote :

Thanks for your bug report. This bug has been reported to the developers of the software. You can track it and make comments here: http://bugzilla.gnome.org/show_bug.cgi?id=545457

Changed in gdm:
assignee: nobody → desktop-bugs
status: New → Triaged
Sebastien Bacher (seb128) wrote :

the crash has been fixed upstream now, they would be interest to get details on the mount triggering the bug though, do you get the crash every time or did you get it only once? what did you do to get the issue?

Changed in glib2.0:
status: Triaged → Fix Committed
Changed in glib:
status: Unknown → Fix Released
Atanas Atanasov (thenasko) wrote :

I upgraded to the most recent version but gdmsetup still crashes with the same message. This also happens every single time I run the program. Should I submit another bug using apport?

Sebastien Bacher (seb128) wrote :

the fixed version is not in ubuntu yet that's why you still get the issue, could you run "gvfs-mount -li" and attach the log to the bug? could you also attach /proc/mounts, it would be interesting to know which mount is creating the issue

Atanas Atanasov (thenasko) wrote :

Here are the mounts:

/proc/mounts
------------------------------------------------
rootfs / rootfs rw 0 0
none /sys sysfs rw,nosuid,nodev,noexec 0 0
none /proc proc rw,nosuid,nodev,noexec 0 0
udev /dev tmpfs rw,mode=755 0 0
fusectl /sys/fs/fuse/connections fusectl rw 0 0
/dev/disk/by-uuid/04f3cff6-f628-4a0a-ac8b-94959b6a5327 / ext3 rw,errors=remount-ro,data=ordered 0 0
/dev/disk/by-uuid/04f3cff6-f628-4a0a-ac8b-94959b6a5327 /dev/.static/dev ext3 ro,errors=remount-ro,data=ordered 0 0
tmpfs /lib/init/rw tmpfs rw,nosuid,mode=755 0 0
varrun /var/run tmpfs rw,nosuid,mode=755 0 0
varlock /var/lock tmpfs rw,nosuid,nodev,noexec 0 0
tmpfs /dev/shm tmpfs rw,nosuid,nodev 0 0
devpts /dev/pts devpts rw,nosuid,noexec,gid=5,mode=620 0 0
/dev/sda8 /home ext3 rw,errors=continue,data=ordered 0 0
securityfs /sys/kernel/security securityfs rw 0 0
binfmt_misc /proc/sys/fs/binfmt_misc binfmt_misc rw,nosuid,nodev,noexec 0 0
------------------------------------------------

gvfs-mount -li
------------------------------------------------
Drive(0): CD-RW/DVD±RW Drive
  ids:
   unix-device: '/dev/scd0'
   hal-udi: '/org/freedesktop/Hal/devices/storage_model_DVD__RW_TS_L632D'
  themed icons: [drive-optical] [drive]
  is_media_removable=1
  has_media=0
  is_media_check_automatic=0
  can_poll_for_media=1
  can_eject=1
Drive(1): SCSI Drive
  ids:
   unix-device: '/dev/sda'
   hal-udi: '/org/freedesktop/Hal/devices/storage_serial_1ATA_ST9160821AS_5MA3RQ3R'
  themed icons: [drive-removable-media-scsi] [drive-removable-media] [drive-removable] [drive]
  is_media_removable=0
  has_media=1
  is_media_check_automatic=0
  can_poll_for_media=0
  can_eject=0
  Volume(0): OS
    ids:
     unix-device: '/dev/sda3'
     hal-udi: '/org/freedesktop/Hal/devices/volume_uuid_9C10B74010B71FE6'
     uuid: '9C10B74010B71FE6'
     label: 'OS'
    uuid=9C10B74010B71FE6
    themed icons: [drive-removable-media-scsi] [drive-removable-media] [drive-removable] [drive]
    can_mount=1
    can_eject=0
  Volume(1): RECOVERY
    ids:
     unix-device: '/dev/sda2'
     hal-udi: '/org/freedesktop/Hal/devices/volume_uuid_C80CB23B0CB223FA'
     uuid: 'C80CB23B0CB223FA'
     label: 'RECOVERY'
    uuid=C80CB23B0CB223FA
    themed icons: [drive-removable-media-scsi] [drive-removable-media] [drive-removable] [drive]
    can_mount=1
    can_eject=0
  Volume(2): 10.0 GB Media
    ids:
     unix-device: '/dev/sda6'
     hal-udi: '/org/freedesktop/Hal/devices/volume_uuid_ff6f12db_e4f6_459d_99d2_176b2aa68374'
     uuid: 'ff6f12db-e4f6-459d-99d2-176b2aa68374'
    uuid=ff6f12db-e4f6-459d-99d2-176b2aa68374
    themed icons: [drive-removable-media-scsi] [drive-removable-media] [drive-removable] [drive]
    can_mount=1
    can_eject=0
------------------------------------------------

I hope this helps.

Sebastien Bacher (seb128) wrote :

thank you for your effort, there is nothing special in those logs, could you install libglib2.0-0-dbg, run those commands:
- sudo gdb gdmsetup
(gdb) run
... get the crash
(gdb) bt
(gdb) frame n (where "n" is the number for the g_local_file_find_enclosing_mount() in the "bt" list
(gdb) print *local
(gdb) print local->filename

and attach those informations to the bug

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package glib2.0 - 2.17.6-0ubuntu1

---------------
glib2.0 (2.17.6-0ubuntu1) intrepid; urgency=low

  * New upstream version:
    - Fix problems on 64-bit Windows
    - g_markup_context_get_user_data: New function to access the user_data
      outside of callbacks
    - GIO
    - g_mount_guess_content_type_sync: synchronous version of
      g_mount_guess_content_type
    - GEmblem: A GIcon implementation that adds emblem-related metadata to icons
    - GEmblemedIcon: A GIcon implementation that can add emblems to icons
    - Bugs fixed:
    544088 option_test_LDADD is left in tests/Makefile.am
    544465 gmarkup makes it hard to use pre-rolled parsers
    545485 Implicit declaration of utime
    545798 "Since: 2.18" mark is missing in g_set_error_literal...
    544140 fam-helper 64-bit issue
    529694 SELinux context setting support
    545157 wrong/no list of "open with" applications for .cc... (lp: #239692)
    545203 gfile.c: argument is different type
    545457 gdmsetup crashed with SIGSEGV in g_unix_mount_guess... (lp: #252942)
    544177 Fix trivial cut and paste error in documentation
    545395 Language tweak for g_value_set_string* docs
    541036 Gnumeric crashes when trying to open Desktop...
    546079 leak in xdgmime
    545395 Language tweak for g_value_set_string* docs
    546017 Don't copy attributes when copying a symlink
  * debian/libglib2.0-0.symbols:
    - new version update
  * debian/rules:
    - updated shlibs version

 -- Sebastien Bacher <email address hidden> Mon, 04 Aug 2008 21:23:02 +0200

Changed in glib2.0:
status: Fix Committed → Fix Released
Atanas Atanasov (thenasko) wrote :

I updated and cannot reproduce the crash anymore. Is there another way to send the information from gdb?

On another note, it takes a while to receive emails from launchpad, so I don't get notified for a while (last time it took about 2 days). Is this to be expected?

Martin Pitt (pitti) wrote :

Accepted into -proposed, please test and give feedback here. Please see https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in glib2.0:
status: New → Fix Committed
Atanas Atanasov (thenasko) wrote :

I am running Intrepid so I don't think I can test Hardy proposed. Is this correct?

Matt Neilson (ichthyoboy) wrote :

verification passed...no crash on i386.

Martin Pitt (pitti) wrote :

Copied to hardy-updates.

Changed in glib2.0:
status: Fix Committed → Fix Released
Changed in glib:
importance: Unknown → Critical
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.