Icon themes are broken

Bug #188542 reported by GPLed on 2008-02-03
68
Affects Status Importance Assigned to Milestone
Nautilus
Invalid
Medium
glib2.0 (Ubuntu)
High
Ubuntu Desktop Bugs

Bug Description

In all icon themes except Rodent common file types like tar, deb, pdf etc. don't show their right icons.

It used to work before.

Related branches

description: updated
Sebastien Bacher (seb128) wrote :

Thank you for your bug report. The description lacks basic detail to be useful though. What version of Ubuntu do you use? What dialog doesn't show icons? Could you describe steps to trigger the issue and take a screenshot?

Changed in gnome-themes:
assignee: nobody → desktop-bugs
importance: Undecided → Low
status: New → Incomplete
GPLed (sunnysachanandani) wrote :

Oh yes, I am running Hardy. What I meant to say was that icons for pdf files, tar files, etc. (many such file types) are broken in the icon themes. They used to work fine about a week back. I don't remember when they got broken.

Changed in gnome-themes:
status: Incomplete → New
GPLed (sunnysachanandani) wrote :

This the screenshot of my desktop. See the .tar.gz file in the centre. It does not have an icon.

GPLed (sunnysachanandani) wrote :

Also interestingly none of the file thumbnailers seem to work. No new files(escpecially pdfs) are being thumbnailed. However on logging out and then logging in again thumbnails of pictures appear.

Sebastien Bacher (seb128) wrote :
Changed in gnome-themes:
status: New → Triaged
Changed in nautilus:
status: Unknown → Confirmed
Changed in nautilus:
milestone: none → ubuntu-8.04
Mahdi (mahdi-hates-spam) wrote :

I am also using the latest hardy.
More than the problem described, the "Computer", "Home", "Network" and media icons on the desktop are broken: the right icon is not shown, and a default (ugly) png icon is shown. Is there any workaround for that? I tested the Dropline Nuovo, Neu, Spherecrystal, Gartoon, and others and they all have the same issue!

Mahdi (mahdi-hates-spam) wrote :

Forgot to mention: i am using hardy amd64 upgraded from a fully working up to date gutsy (update-manager -d).

Changed in nautilus:
importance: Low → High
Patrick (patrick-voegeli) wrote :

Still happening!

The problem seems to be the way nautilus assigns the icons, looking into the mime type. For example, deb file:

gnome-mime-application-x-deb.svg doesn't work anymore and displays that generic icon. There is a fix making a symlink from there to application-x-deb.svg, then it works again...

cheers

A. Walton (awalton) wrote :

This is an icon theme problem (whichever theme you happen to be using), not a Nautilus problem. Nautilus (actually GIO) is following the Icon Naming Specification from FreeDesktop.org (http://standards.freedesktop.org/icon-naming-spec/icon-naming-spec-latest.html ) for finding icons, and many old themes have yet to upgrade their icon names to be compliant with this standard. Fixing the themes can be done via symlinks if necessary. GIO also can look up old icon theme names now, but this functionality should probably go away in the future and themes SHOULD migrate as soon as possible (http://svn.gnome.org/viewvc/glib?view=revision&revision=6557 ).

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package glib2.0 - 2.15.6-0ubuntu1

---------------
glib2.0 (2.15.6-0ubuntu1) hardy; urgency=low

  * New upstream version:
    GIO:
    - New file attributes: trash::item-count, filesystem::use-preview
    - Rename g_file_contains_file to g_file_has_prefix
    - g_file_query_filesystem_info grew async variants
    - g_themed_icon_append_name: new convenience function
    - g_content_type_get_icon is implemented now (lp: #188542)
    - Only show mounts in /media and ~
    - g_file_contains_file has been renamed to g_file_has_prefix
    Other:
    - g_uri_get_scheme has been renamed go g_uri_parse_scheme
    Updated translations
  * debian/rules:
    - updated shlibs version

 -- Sebastien Bacher <email address hidden> Mon, 25 Feb 2008 22:00:21 +0100

Changed in glib2.0:
status: Triaged → Fix Released
Lechuan (lechuan) wrote :

It doesn't seem to have been thoroughly fixed. See the zip file in screenshot.

Robert Pickle (rpickle) wrote :

I just tested creating zips on the desktop and within Nautilus; works great for me.

Lechuan (lechuan) wrote :

That's funny. I've tried every icon set I have, but all display the zip file with an icon for text.

I'm using the latest Hardy from upgrade.

Anything wrong with the MIME type though? It is 'application/x-extension-zip' for me.

Lechuan (lechuan) wrote :

I just discovered something funny.

Lechuan (lechuan) wrote :

So this proves that it is not a icon naming bug. The icon is only wrong in Nautilus.

Sebastien Bacher (seb128) wrote :

Can you run "grep zip .local/share -R" and copy that to a comment?

Lechuan (lechuan) wrote :

lechuan@ubuntu:~$ grep zip .local/share -R
.local/share/mime/packages/user-extension-zip.xml: <mime-type type="application/x-extension-zip">
.local/share/mime/packages/user-extension-zip.xml: <comment>zip document</comment>
.local/share/mime/packages/user-extension-zip.xml: <glob pattern="*.zip"/>
.local/share/mime/globs:application/x-extension-zip:*.zip
二进制文件 .local/share/mime/mime.cache 匹配
.local/share/mime/application/x-extension-zip.xml:<mime-type xmlns="http://www.freedesktop.org/standards/shared-mime-info" type="application/x-extension-zip">
.local/share/mime/application/x-extension-zip.xml: <comment>zip document</comment>
.local/share/applications/defaults.list:application/zip=ooo-writer-usercustom.desktop
.local/share/applications/ooo-writer-usercustom.desktop:MimeType=application/zip;
.local/share/applications/mimeapps.list:application/x-extension-zip=file-roller.desktop;comix.desktop;
grep: .local/share/applications/wine: Permission denied
.local/share/applications/mimeinfo.cache:application/zip=webrunner-usercreated.desktop;ooo-writer-usercustom.desktop;
.local/share/applications/webrunner-usercreated.desktop:MimeType=application/zip;

Sebastien Bacher (seb128) wrote :

the issue comes from your user configuration which defines this broken mimetype, that's not an ubuntu bug

Lechuan (lechuan) wrote :

Thank you! I deleted the problematic files and the zip icon is back.

In retrospect this is almost certainly caused by this bug:
https://bugs.launchpad.net/ubuntu/+source/openoffice.org/+bug/138252

I was frustrated and associated docx with OpenOffice, only to find out that every compressed file was going to be opened by OpenOffice.

Changed in nautilus:
status: Confirmed → Invalid
Changed in nautilus:
importance: Unknown → Medium
status: Invalid → Unknown
Changed in nautilus:
status: Unknown → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.