Product crashes after upgrading to glib2.0 2.56.2 in Ubuntu 18.04 Bionic Beaver

Bug #1795230 reported by Amit Karmilkar on 2018-09-30
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
glib2.0 (Ubuntu)
High
Marco Trevisan (Treviño)
libappindicator (Ubuntu)
Undecided
Unassigned

Bug Description

Our product is using LibAppIndicator
Please find the dependency tree below for libappindicator, it is using libglib

    libappindicator.so.1 => /usr/lib/i386-linux-gnu/libappindicator.so.1
        libindicator.so.7 => /usr/lib/i386-linux-gnu/libindicator.so.7
            libgtk-x11-2.0.so.0 => /usr/lib/i386-linux-gnu/libgtk-x11-2.0.so.0
                libgdk-x11-2.0.so.0 => /usr/lib/i386-linux-gnu/libgdk-x11-2.0.so.0
                    libpangocairo-1.0.so.0 => /usr/lib/i386-linux-gnu/libpangocairo-1.0.so.0
                        libpango-1.0.so.0 => /usr/lib/i386-linux-gnu/libpango-1.0.so.0
                            libgobject-2.0.so.0 => /usr/lib/i386-linux-gnu/libgobject-2.0.so.0
                                libglib-2.0.so.0 => /lib/i386-linux-gnu/libglib-2.0.so.0

Our product is crashing after upgrading libglib to the latest version glib2.0 2.56.2 released on 19-Sep-2018.

https://launchpad.net/ubuntu/+source/glib2.0/2.56.2-0ubuntu0.18.04.2

description: updated
Sebastien Bacher (seb128) wrote :

Could you give details on the segfault, maybe a backtrace from gdb? Did you try downgrading the glib package to verify if that resolves the issue?

Leonidas S. Barbosa (leosilvab) wrote :

Hi Amit,

The last update/sec update touched glib2.0 regarding gMarkup and UTF structure.
Were them:
- Fix crash in error handling path for closing elements - fccef3cc822af74699cca84cd202719ae61ca3b9
- Fix unvalidated UTF-8 read in markup parsing error path - cec71705406f0b2790422f0c1aa0ff3b4b464b1b

That can give us a clue about that segfault. Could be possible to provide any way in how to reproduce this issue?

Thanks!

Vishnu (vishnupkb) wrote :

Here is the stack view of the time of crash happened ,

/usr/lib/x86_64-linux-gnu/libappindicator.so.1(app_indicator_set_icon_full+0x2d) [0x7f44fe09b4ed]
/usr/lib/x86_64-linux-gnu/libappindicator.so.1(app_indicator_set_icon_full+0x2d) [0x7f44fe09b4ed]
/usr/lib/x86_64-linux-gnu/libglib-2.0.so.0(g_main_context_dispatch+0x155) [0x7f4500fd80f5]
/usr/lib/x86_64-linux-gnu/libglib-2.0.so.0(+0x4c4c0) [0x7f4500fd84c0]
/usr/lib/x86_64-linux-gnu/libglib-2.0.so.0(g_main_loop_run+0xc2) [0x7f4500fd87d2]
/usr/lib/x86_64-linux-gnu/libgtk-x11-2.0.so.0(gtk_main+0xb7) [0x7f4500741a37]
/lib/x86_64-linux-gnu/libc.so.6(__libc_start_main+0xe7) [0x7f44fd927b97]

The product was working properly in 18.04 but it is not working on 18.04.1

Leonidas S. Barbosa (leosilvab) wrote :

Can you reproduce the issue in a previous version, such as 2.56.2-0ubuntu0.18.04.1?
Also, is there any POC/test in how to reproduce this?

Thanks!

Vishnu (vishnupkb) wrote :

When we tried to install glib 2.56.2-0ubuntu0.18.04.1 it was giving an error like this,
E: Version '2.56.2-0ubuntu0.18.04.1' for 'libglib2.0-0' was not found.

The error is reproducible only when we upgrade from glib 2.56.1 to glib 2.56.2 . We are not facing this issue on glib 2.56.1

Vishnu (vishnupkb) wrote :

Here is the back trace when running using GDB,

0x00007ff5784d94ed in app_indicator_set_icon_full () from /usr/lib/x86_64-linux-gnu/libappindicator.so.1
(gdb) bt
#0 0x00007ff5784d94ed in app_indicator_set_icon_full () at /usr/lib/x86_64-linux-gnu/libappindicator.so.1
#1 0x000000000041263f in ()
#2 0x00007ff57bddc0f5 in g_main_context_dispatch () at /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#3 0x00007ff57bddc4c0 in () at /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#4 0x00007ff57bddc7d2 in g_main_loop_run () at /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#5 0x00007ff57b545a37 in gtk_main () at /usr/lib/x86_64-linux-gnu/libgtk-x11-2.0.so.0
#6 0x000000000040f36f in main ()

Leonidas S. Barbosa (leosilvab) wrote :

By the changelog, glib2.0 was update to a new upstream release from 2.56.1-2 to 2.56.2 and so a security update was done over it.

In order to figure out if it's an issue in the security update or the original version glib 2.56.2-0ubuntu0.18.04.1. Could you please try this pkg version and check if the regression segfault persist:

AMD64 - https://launchpad.net/~ci-train-ppa-service/+archive/ubuntu/3389-deletedppa/+build/15310024

I386 - https://launchpad.net/~ci-train-ppa-service/+archive/ubuntu/3389-deletedppa/+build/15310027

Thanks!

Vishnu (vishnupkb) wrote :

We tried with the package which was given above (AMD64 - https://launchpad.net/~ci-train-ppa-service/+archive/ubuntu/3389-deletedppa/+build/15310024) , and still we facing the same issue and same gdb back trace as well.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in glib2.0 (Ubuntu):
status: New → Confirmed

Thanks a lot Vishnu!

Since it's not a security udpate issue I'll notice and add the desktop team to handle with this bug.

Sebastien Bacher (seb128) wrote :

The bug is not easy to work on without a reproducer or a debug backtrace. Can you share the binary you are using which is hitting the issue? If not could you at least get a debug backtrace (install the debug symbols for libappindicator and libglib2.0-0, see https://wiki.ubuntu.com/DebuggingProgramCrash for detailled instructions on how to do that)

Sebastien Bacher (seb128) wrote :

Marco, you did that SRU. Did you see/hear about other similar problems? Any idea what the issue could be?

Changed in glib2.0 (Ubuntu):
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
importance: Undecided → High

Mh, not that I'm aware of, but also not having a full stacktrace doesn't help.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers