package libglib2.0-dev 2.48.2-0ubuntu4 failed to install/upgrade: subprocess new pre-removal script returned error exit status 1

Bug #1793304 reported by Geokimbo on 2018-09-19
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
glib2.0 (Ubuntu)
Undecided
Unassigned

Bug Description

This is likely an issue to do with having both python2.7 and 3.5 on the machine. The work around is the same as that I gave for samba in Bug 1651660.

TL:DR Copy weakref.py from the 3.5 directory to the 2.7 directory and edit syntax until offender installs

Patched weakref.py uploaded to the above mentioned bug.

The root of the problem is likely either the QGIS 3.2 repo install or the Paraview 5.5 binary copy.

Cheers
Kim

ProblemType: Package
DistroRelease: Ubuntu 16.04
Package: libglib2.0-dev 2.48.2-0ubuntu4
ProcVersionSignature: Ubuntu 4.4.0-135.161-generic 4.4.140
Uname: Linux 4.4.0-135-generic x86_64
NonfreeKernelModules: nvidia_uvm nvidia_drm nvidia_modeset nvidia
ApportVersion: 2.20.1-0ubuntu2.18
Architecture: amd64
Date: Wed Sep 19 20:27:49 2018
ErrorMessage: subprocess new pre-removal script returned error exit status 1
InstallationDate: Installed on 2016-12-10 (648 days ago)
InstallationMedia: Ubuntu 16.04.1 LTS "Xenial Xerus" - Release amd64 (20160719)
RelatedPackageVersions:
 dpkg 1.18.4ubuntu1.4
 apt 1.2.27
SourcePackage: glib2.0
Title: package libglib2.0-dev 2.48.2-0ubuntu4 failed to install/upgrade: subprocess new pre-removal script returned error exit status 1
UpgradeStatus: No upgrade log present (probably fresh install)

Geokimbo (kfrankcombe) wrote :
tags: removed: need-duplicate-check
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers