upgrade from 14.04 to 16.04 fails due to `interest-await' in trigger

Bug #1784065 reported by Yan Birch on 2018-07-27
This bug affects 11 people
Affects Status Importance Assigned to Milestone
glib2.0 (Ubuntu)
Brian Murray
Brian Murray

Bug Description

[Test case]
Verify that a release-upgrade of an Ubuntu desktop works from trusty to xenial with -proposed enabled.

Package failed to install.

ProblemType: Package
DistroRelease: Ubuntu 16.04
Package: libglib2.0-0 2.48.2-0ubuntu3
ProcVersionSignature: Ubuntu 4.4.0-131.157-generic 4.4.134
Uname: Linux 4.4.0-131-generic x86_64
ApportVersion: 2.20.1-0ubuntu2.18
Architecture: amd64
Date: Fri Jul 27 18:31:08 2018
 Preparing to unpack .../libglib2.0-0_2.48.2-0ubuntu3_amd64.deb ...
 dpkg: error processing archive /var/cache/apt/archives/libglib2.0-0_2.48.2-0ubuntu3_amd64.deb (--unpack):
  triggers ci file contains unknown directive `interest-await'
ErrorMessage: triggers ci file contains unknown directive `interest-await'
InstallationDate: Installed on 2015-03-31 (1213 days ago)
InstallationMedia: Ubuntu 14.04 LTS "Trusty Tahr" - Release amd64 (20140417)
 dpkg 1.18.4ubuntu1.4
 apt 1.2.27
SourcePackage: glib2.0
Title: package libglib2.0-0 2.48.2-0ubuntu3 failed to install/upgrade: triggers ci file contains unknown directive `interest-await'
UpgradeStatus: Upgraded to xenial on 2018-07-27 (0 days ago)

Yan Birch (y-k-birch) wrote :
tags: removed: need-duplicate-check
Sebastien Bacher (seb128) wrote :

The issue seems a regression for the recent SRU?

Changed in glib2.0 (Ubuntu):
assignee: nobody → Julian Andres Klode (juliank)
Steve Langasek (vorlon) wrote :

Unreproducible here in a xenial chroot w/ same versions of dpkg and libglib2.0-0. The format of the triggers file looks correct. Yan, is this problem reproducible if you run 'sudo dpkg --configure -a && sudo apt -f install && sudo apt install libglib2.0-0' in a terminal? Otherwise, my guess is that this a rogue bitflip error rather than a bug in libglib2.0-0.

See also https://wiki.ubuntu.com/DebuggingInstallationIssues#triggers_ci_file_contains_unknown_directive_syntax which points to LP: #500042.

Changed in glib2.0 (Ubuntu):
status: New → Incomplete
Brian Murray (brian-murray) wrote :

This bug report is actually about an upgrade from Ubuntu 14.04 to Ubuntu 16.04 where dpkg is being upgraded from 1.17.5ubuntu5.8. That version of dpkg does not have support for the "-await" alias variants and dpkg was updated after libglib2.0-0 so that package upgrade failed. This is fallout of the changes in bug 1780996. The fix is to make the packages changed in bug 1780996 pre-depend on dpkg greater than or equal to 1.17.21.

It is also worth investigating the archive for other packages in Ubuntu 16.04 that use "-await" but do not pre-depend on dpkg.

summary: - package libglib2.0-0 2.48.2-0ubuntu3 failed to install/upgrade: triggers
- ci file contains unknown directive `interest-await'
+ upgrade from 14.04 to 16.04 fails due to `interest-await' in trigger
Changed in glib2.0 (Ubuntu):
status: Incomplete → Triaged
importance: Undecided → High

Same issue here after do-release-upgrade from 14.04 to 16.04:

Preparing to unpack .../libglib2.0-0_2.48.2-0ubuntu3_amd64.deb ...
dpkg: error processing archive /var/cache/apt/archives/libglib2.0-0_2.48.2-0ubuntu3_amd64.deb (--unpack):
 triggers ci file contains unknown directive `interest-await'
Errors were encountered while processing:
E: Sub-process /usr/bin/dpkg returned an error code (1)

Also, a similar one: https://bugs.launchpad.net/ubuntu/+source/glib2.0/+bug/1784028

It looks like I found a workaround:


wget https://launchpad.net/ubuntu/+source/glib2.0/2.48.2-0ubuntu3/+build/15131273/+files/libglib2.0-0_2.48.2-0ubuntu3_amd64.deb
wget http://mirrors.kernel.org/ubuntu/pool/main/d/dpkg/dpkg_1.18.4ubuntu1_amd64.deb
ar -x dpkg_1.18.4ubuntu1_amd64.deb
tar -xzf data.tar.gz
sudo ./usr/bin/dpkg -i libglib2.0-0_2.48.2-0ubuntu3_amd64.deb

After doing that I was able to run sudo apt-get -f install.

Dave Butcher (dbutcher) wrote :

This workaround doesn't work for me...
I have i386 architecture, so I changed the commands as follows:

wget https://launchpad.net/ubuntu/+source/glib2.0/2.48.2-0ubuntu3/+build/15131276/+files/libglib2.0-0_2.48.2-0ubuntu3_i386.deb
wget http://mirrors.kernel.org/ubuntu/pool/main/d/dpkg/dpkg_1.18.4ubuntu1_i386.deb
ar -x dpkg_1.18.4ubuntu1_i386.deb
tar -xzf data.tar.gz
sudo ./usr/bin/dpkg -i libglib2.0-0_2.48.2-0ubuntu3_i386.deb

everything appeared to process correctly, but when I run
sudo apt-get -f install
it fails with the same "interest-await" error as before.

Beat (beat-c) wrote :

Also affected me.

In addition of doing the steps in comment #6 above, I had to do:

sudo cp libglib2.0-0_2.48.0-1ubuntu4_amd64.deb /var/cache/apt/archives/.
sudo cp ./usr/bin/dpkg /usr/bin/.

Then I could run

sudo apt-get -f install

Beat (beat-c) wrote :

Update to my comment #8:
The upgrade from 14.04 to 16.04 failed later again on package gconf2

dpkg: error processing package gconf2 (--configure):
 dependency problems - leaving triggers unprocessed
dpkg: dependency problems prevent processing triggers for gconf2:
 gconf2 depends on python:any; however:
  Package python is not configured yet.

And many other packages.

This PC has been installed with Ubuntu 12.04, then upgraded to 14.04, and now upgrading to 16.04 fails with the bug described in this tracker item and leaves the system not upgraded and not upgradable. Reverting now to 14.04 from backup and postponing upgrade to 16.04.

Mark Krueger (the-integrator) wrote :

Had same issue with 14.04 to 16.04 upgrade, I had i386 and amd64 so this worked for me, just doing amd64 gave me an error:
wget http://mirrors.kernel.org/ubuntu/pool/main/d/dpkg/dpkg_1.18.4ubuntu1_amd64.deb
ar -x dpkg_1.18.4ubuntu1_amd64.deb
tar -xvf data.tar.gz
wget https://launchpad.net/ubuntu/+source/glib2.0/2.48.2-0ubuntu3/+build/15131273/+files/libglib2.0-0_2.48.2-0ubuntu3_amd64.deb
wget https://launchpad.net/ubuntu/+source/glib2.0/2.48.2-0ubuntu3/+build/15131276/+files/libglib2.0-0_2.48.2-0ubuntu3_i386.deb
sudo ./usr/bin/dpkg -i libglib2.0-0_2.48.2-0ubuntu3_amd64.deb libglib2.0-0_2.48.2-0ubuntu3_i386.deb

Changed in glib2.0 (Ubuntu):
assignee: Julian Andres Klode (juliank) → Brian Murray (brian-murray)
status: Triaged → In Progress
Changed in glib2.0 (Ubuntu Xenial):
importance: Undecided → High
status: New → In Progress
assignee: nobody → Brian Murray (brian-murray)

Hello Yan, or anyone else affected,

Accepted glib2.0 into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/glib2.0/2.48.2-0ubuntu4 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-xenial to verification-done-xenial. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-xenial. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

description: updated
Changed in glib2.0 (Ubuntu Xenial):
status: In Progress → Fix Committed
tags: added: verification-needed verification-needed-xenial
Brian Murray (brian-murray) wrote :

On an Ubuntu 14.04 system I installed the libglib2.0-0 package, then modified my /etc/apt/sources.list file from trusty to xenial, tried to install libglib2.0-0 and then experienced the crash in this bug report.

I performed the same steps but added xenial-proposed to my /etc/apt/sources.list file and then the upgrade wanted to also install dpkg among other things.

(trusty-amd64)root@impulse:/home/bdmurray# apt-get install libglib2.0-0
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages were automatically installed and are no longer required:
  libboost-date-time1.54.0 libboost-system1.54.0 libcdr-0.0-0 libcmis-0.4-4
  libelfg0 libevdev2 libgnome-desktop-3-12 libinput-bin libinput10
  libmspub-0.0-0 liborcus-0.6-0 librhythmbox-core8 libvisio-0.0-0 libwpd-0.9-9
  libwpg-0.2-2 libwps-0.2-2 overlay-scrollbar-gtk2 pidgin-data
  rhythmbox-mozilla xfonts-mathml
Use 'apt-get autoremove' to remove them.
The following extra packages will be installed:
  adwaita-icon-theme apt apt-utils console-setup console-setup-linux cups
  cups-bsd cups-client cups-common cups-core-drivers cups-daemon
  cups-server-common dbus dpkg fontconfig fontconfig-config fonts-stix
  gcc-5-base gir1.2-javascriptcoregtk-4.0 gir1.2-rb-3.0 gir1.2-webkit2-4.0

Then in /var/log/apt/term.log we can see:

Setting up dpkg (1.18.4ubuntu1.4) ...^M$
Installing new version of config file /etc/cron.daily/dpkg ...^M$
(Reading database ... ^M(Reading database ... 5%^M(Reading database ... 10%^M(Reading database ... 15%^M(Reading database ... 20%^M(Reading database ... 25%^M(Re
ading database ... 30%^M(Reading database ... 35%^M(Reading database ... 40%^M(Reading database ... 45%^M(Reading database ... 50%^M(Reading database ... 55%^M(R
eading database ... 60%^M(Reading database ... 65%^M(Reading database ... 70%^M(Reading database ... 75%^M(Reading database ... 80%^M(Reading database ... 85%^M(
Reading database ... 90%^M(Reading database ... 95%^M(Reading database ... 100%^M(Reading database ... 132743 files and directories currently installed.)^M$
Preparing to unpack .../libglib2.0-0_2.48.2-0ubuntu4_amd64.deb ...^M$
Unpacking libglib2.0-0:amd64 (2.48.2-0ubuntu4) over (2.40.2-0ubuntu1) ...^M$

tags: added: verification-done verification-done-xenial
removed: verification-needed verification-needed-xenial
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package glib2.0 - 2.48.2-0ubuntu4

glib2.0 (2.48.2-0ubuntu4) xenial; urgency=medium

  * Add a versioned Pre-Depends for dpkg because the libglib2.0-0 -await
    trigger requires a newer dpkg than the one in Ubuntu 14.04. (LP: #1784065)

 -- Brian Murray <email address hidden> Mon, 30 Jul 2018 08:29:26 -0700

Changed in glib2.0 (Ubuntu Xenial):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for glib2.0 has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Changed in glib2.0 (Ubuntu):
status: In Progress → Invalid
Beat (beat-c) wrote :

Confirming that with new glib2.0 - 2.48.2-0ubuntu4 in updates repository, I could now easily do the 14.04 to 16.04 upgrade.

Thanks to all who made this fix happen quickly!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers