[regression] Unreadable stack traces since upgrading to gjs 1.52.1 and glib 2.56.1-2ubuntu1

Bug #1764216 reported by Daniel van Vugt on 2018-04-16
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
glib2.0 (Ubuntu)
High
Unassigned

Bug Description

Since Ubuntu updated to gjs 1.52.1-1, our bug tracking systems are unable to automatically retrace crashes. This has created a sudden wave of crash reports that we can't automatically classify.

For example, this is what LP: #1748450/LP: #1505409 looks like now:

#0 raise (sig=<optimized out>) at ../sysdeps/unix/sysv/linux/raise.c:51
        set = {__val = {0, 538, 539, 540, 541, 542, 543, 544, 545, 546, 547, 548, 549, 550, 551, 552}}
        pid = <optimized out>
        tid = <optimized out>
        ret = <optimized out>
#1 0x0000558168af3a6b in dump_gjs_stack_on_signal_handler (signo=5) at ../src/main.c:367
        sa = {__sigaction_handler = {sa_handler = 0x558168af3aa0 <dump_gjs_stack_alarm_sigaction>, sa_sigaction = 0x558168af3aa0 <dump_gjs_stack_alarm_sigaction>}, sa_mask = {__val = {0 <repeats 16 times>}}, sa_flags = 0, sa_restorer = 0x0}
        i = 65
#2 <signal handler called>
No locals.
#3 0x00007f1d3e2bdc41 in ?? ()
No symbol table info available.
#4 0x00007f1d3c854b4d in ?? () from /tmp/apport_sandbox_2dl0glnw/usr/lib/x86_64-linux-gnu/libmutter-2.so.0
No symbol table info available.
#5 0x00007f1d3e2bec7c in ?? ()
No symbol table info available.
#6 0x00007f1d3e30a51f in ?? ()
No symbol table info available.
#7 0x00007f1d3e35fe32 in ?? ()
No symbol table info available.
#8 0xffffffffffffffff in ?? ()
No symbol table info available.
#9 0x00007f1d3e30a451 in ?? ()
No symbol table info available.
#10 0x00005581697262f0 in ?? ()
No symbol table info available.
#11 0xffffffffffffffff in ?? ()
No symbol table info available.
#12 0x00007f1d3e30a464 in ?? ()
No symbol table info available.
#13 0x00007f1d3e30a2f9 in ?? ()
No symbol table info available.
#14 0xffffffffffffffff in ?? ()
No symbol table info available.
#15 0x00007f1d3e30a4be in ?? ()
No symbol table info available.
#16 0x00007f1d3c854b4d in ?? () from /tmp/apport_sandbox_2dl0glnw/usr/lib/x86_64-linux-gnu/libmutter-2.so.0
No symbol table info available.
#17 0xffffffffffffffff in ?? ()
No symbol table info available.
#18 0x00005581697262f0 in ?? ()
No symbol table info available.
#19 0x4cae2c7f65c95f00 in ?? ()
No symbol table info available.
#20 0x0000000000000006 in ?? ()
No symbol table info available.
#21 0x0000558168af3b45 in default_log_handler (log_domain=0x1 <error: Cannot access memory at address 0x1>, log_level=6, message=0x5581697262f0 "Connection to xwayland lost", data=0x0) at ../src/main.c:310
        now = {tv_sec = 1523717020, tv_usec = 986744}
#22 0x00007f1d3e2bef0d in ?? ()
No symbol table info available.
#23 0x00007f1d3c854b4d in ?? () from /tmp/apport_sandbox_2dl0glnw/usr/lib/x86_64-linux-gnu/libmutter-2.so.0
No symbol table info available.
#24 0x00005581697262f0 in ?? ()
No symbol table info available.
#25 0x0000000100000000 in ?? ()
No symbol table info available.
#26 0x0000558168af3af0 in ?? () at ../src/main.c:337

Daniel van Vugt (vanvugt) wrote :

Actually, this looks like a new issue. We still see reports of LP: #1748450 with the old stack trace even with gjs 1.52.1-1

Changed in gjs (Ubuntu):
status: New → Invalid
Daniel van Vugt (vanvugt) wrote :

Although that doesn't make this bug invalid.

Changed in gjs (Ubuntu):
status: Invalid → New
Daniel van Vugt (vanvugt) wrote :

This report:

https://errors.ubuntu.com/problem/7576bbf83cb88a0b3a870e1371dd86416b23c4b3

suggests the wave of unreadable stack traces this morning was perhaps due to an update to glib2.0, because:

/lib/x86_64-linux-gnu/libglib-2.0.so.0.5600.0 (deleted)

So they are almost certainly all duplicates of bug 1748450, un-retracable due to the upgrade procedure of glib2.0. The good news is that the wave of un-retracable crashes should stop after everyone has upgraded.

Changed in gjs (Ubuntu):
status: New → Incomplete
summary: - [regression] Unreadable stack traces since upgrading to gjs 1.52.1
+ [regression] Unreadable stack traces since upgrading to gjs 1.52.1 and
+ glib 2.56.1-2ubuntu1
description: updated
Changed in gjs (Ubuntu):
status: Incomplete → Won't Fix
affects: gjs (Ubuntu) → glib2.0 (Ubuntu)
Steve Langasek (vorlon) wrote :

'regression-update' is for regressions introduced in the -updates pocket of a stable release; removing the tag

tags: removed: regression-update
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers