"gio open /tmp/whatever.mp3" only opens the file (with totem) every other time it is called

Bug #1729012 reported by Jonathan Kamens on 2017-10-31
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
glib2.0 (Ubuntu)
Low
Unassigned

Bug Description

I run "gio open /tmp/whatever.mp3". It silently does nothing, i.e., the mp3 does not play, and yet exits with status 0. I run exactly the same command again. It opens totem to play the mp3. This seems to be repeatable: when I run the command repeatedly, it alternatives between doing nothing and playing the mp3.

I've attached two files showing the output of strace when the command succeeds and fails. I can't figure out what the heck is going on.

ProblemType: Bug
DistroRelease: Ubuntu 17.10
Package: libglib2.0-bin 2.54.1-1ubuntu1
ProcVersionSignature: Ubuntu 4.13.0-16.19-generic 4.13.4
Uname: Linux 4.13.0-16-generic x86_64
ApportVersion: 2.20.7-0ubuntu3.1
Architecture: amd64
CurrentDesktop: ubuntu:GNOME
Date: Tue Oct 31 10:32:44 2017
InstallationDate: Installed on 2017-05-19 (164 days ago)
InstallationMedia: Ubuntu 17.04 "Zesty Zapus" - Release amd64 (20170412)
SourcePackage: glib2.0
UpgradeStatus: Upgraded to artful on 2017-10-20 (10 days ago)

Jonathan Kamens (jik) wrote :
Jonathan Kamens (jik) wrote :
Jonathan Kamens (jik) wrote :

I'm not sure, but this may qualify as `regression-release`, because I actually use xdg-open to open mp3 files, which worked reliably in 17.04 but is failing in 17.10 because of this `gio open` problem.

Sebastien Bacher (seb128) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. The issue you are reporting is an upstream one and it would be nice if somebody having it could send the bug to the developers of the software by following the instructions at https://wiki.ubuntu.com/Bugs/Upstream/GNOME. If you have done so, please tell us the number of the upstream bug (or the link), so we can add a bugwatch that will inform us about its status. Thanks in advance.

Changed in glib2.0 (Ubuntu):
importance: Undecided → Low
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers