GTK Inspector Statistics tab non-functional

Bug #1623763 reported by Michael Gratton on 2016-09-15
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
GTK+
Unknown
Medium
Ubuntu GNOME
Undecided
Unassigned
glib2.0 (Debian)
New
Unknown
glib2.0 (Ubuntu)
Wishlist
Unassigned

Bug Description

Running a GTK+ 3 app with GOBJECT_DEBUG=instance-count enables the Statistics tab in GTK Inspector, but after clicking the Record button it never starts collecting statistics. This makes it difficult to develop and debug memory leaks in GTK programs on Ubuntu.

To reproduce:

1. Start an app with the Inspector and GOBJECT_DEBUG=instance-count set, e.g.:

> GOBJECT_DEBUG=instance-count GTK_DEBUG=interactive gnome-calculator

2. Click the Statistics tab
3. Click the Record button
4. Click around the app a bit

Expected: Object counts go up, pretty graphs showing things
Actual: Object counts stay at 0, pretty graphs showing flat lines

This seems like it is Ubuntu-specific, since when running GTK+ programs installed via Flatpak (and hence using the Flatpak runtime), the above works fine on the same system.

ProblemType: Bug
DistroRelease: Ubuntu 16.04
Package: libgtk-3-dev 3.20.8-1ubuntu0~ppa1 [origin: LP-PPA-gnome3-team-gnome3-staging]
ProcVersionSignature: Ubuntu 4.4.0-36.55-generic 4.4.16
Uname: Linux 4.4.0-36-generic x86_64
ApportVersion: 2.20.1-0ubuntu2.1
Architecture: amd64
CurrentDesktop: GNOME
Date: Thu Sep 15 13:05:19 2016
InstallationDate: Installed on 2015-07-22 (421 days ago)
InstallationMedia: Ubuntu-GNOME 15.04 "Vivid Vervet" - Release amd64 (20150422)
SourcePackage: gtk+3.0
UpgradeStatus: Upgraded to xenial on 2016-03-02 (196 days ago)

Michael Gratton (mjog) wrote :
Michael Gratton (mjog) wrote :

After upgrading to stock Ubuntu GNOME Yakkety, the issue is still present, so it's not related to the PPA.

tags: added: yakkety
removed: gnome3-ppa gnome3-staging
Sebastien Bacher (seb128) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. The issue you are reporting is an upstream one and it would be nice if somebody having it could send the bug to the developers of the software by following the instructions at https://wiki.ubuntu.com/Bugs/Upstream/GNOME. If you have done so, please tell us the number of the upstream bug (or the link), so we can add a bugwatch that will inform us about its status. Thanks in advance.

Changed in gtk+3.0 (Ubuntu):
importance: Undecided → Low

On Tue, Oct 11, 2016 at 2:37 AM, Sebastien Bacher <email address hidden>
wrote:
> Thank you for taking the time to report this bug and helping to make
> Ubuntu better. The issue you are reporting is an upstream one and it
> would be nice if somebody having it could send the bug to the
> developers
> of the software by following the instructions at
> https://wiki.ubuntu.com/Bugs/Upstream/GNOME. If you have done so,
> please
> tell us the number of the upstream bug (or the link), so we can add a
> bugwatch that will inform us about its status. Thanks in advance.

Hi, what makes you think it's an upstream problem?

As I mentioned, it works fine for apps run via Flatpak on the same
computer, so this very much sounds like an Ubuntu/Debian specific issue.

//Mike

--
⊨ Michael Gratton, Percept Wrangler.
⚙ <http://mjog.vee.net/>

Sebastien Bacher (seb128) wrote :

> Hi, what makes you think it's an upstream problem?

there is no patch in the package that is likely to lead to such problem, but could be due to the configure options used or the toolchain, guess it needs debugging by somebody understanding how that debugging option works, which is easier to found upstream than on launchpad.

Michael Gratton (mjog) wrote :

Okay, I see. Upstream bug reported and linked here.

Changed in gtk:
importance: Unknown → Medium
status: Unknown → Confirmed
Changed in gtk+3.0 (Ubuntu):
status: New → Triaged
Jeremy Bicha (jbicha) wrote :

It appears this is actually because glib2.0 is not compiled with --enable-debug so I'm reassigning this to glib2.0 and lowering the importance to wishlist as a new "feature".

I'm also attaching an ancient Debian bug asking for this compile option. Someone that cares about this feature should look into what the impact is of --enable-debug and have a conversation with the Debian maintainers about it.

affects: gtk+3.0 (Ubuntu) → ubuntu
Changed in ubuntu:
importance: Low → Wishlist
affects: ubuntu → glib2.0 (Ubuntu)
Changed in glib2.0 (Debian):
status: Unknown → Won't Fix
Changed in gtk:
status: Confirmed → Unknown
Michael Gratton (mjog) wrote :

Filed a new request in debbugs for --enable-debug

Changed in glib2.0 (Debian):
status: Won't Fix → Unknown
Changed in glib2.0 (Debian):
status: Unknown → New
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.