gnome-system-monitor crashed and libglib2.0-0 needs to be upgraded

Bug #1547534 reported by zerons on 2016-02-19
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
glib2.0 (Ubuntu)
Low
Unassigned

Bug Description

SYSTEM: ubuntu 14.04 LTS
package: libglib2.0-0_2.40.2-0ubuntu1

the bug is in libglib2.0-0/glib/gmarkup.c, function append_escaped_text,
----while (p != end)
should be
----while (p < end)

in the newest version, the commit https://github.com/GNOME/glib/commit/c71b16c3be17113f80693690555c453f31e5f31a

Sebastien Bacher (seb128) wrote :

Thanks, but the bug it points to, https://bugzilla.gnome.org/show_bug.cgi?id=631597 stated it's a NOTGNOME issue and the segfault was not due to glib. Also that commit is in the current Ubuntu version, if you would like to request a stable update for it could you follow https://wiki.ubuntu.com/StableReleaseUpdates and provide at least a testcase to recreate the issue?

Changed in glib2.0 (Ubuntu):
importance: Undecided → Low
status: New → Incomplete
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.