when i delete .trash_1000 folder frm usb nautilus freeses

Bug #1512826 reported by zorin
68
This bug affects 19 people
Affects Status Importance Assigned to Milestone
GLib
Fix Released
Medium
glib2.0 (Ubuntu)
High
Unassigned
Wily
Undecided
Unassigned

Bug Description

when i delete .trash_1000 folder frm usb nautilus freeses on ubuntu 15.10. please help

Revision history for this message
Sebastien Bacher (seb128) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. Please try to obtain a backtrace following the instructions at http://wiki.ubuntu.com/DebuggingProgramCrash and upload the backtrace (as an attachment) to the bug report. This will greatly help us in tracking down your problem.

Changed in nautilus (Ubuntu):
importance: Undecided → Low
status: New → Incomplete
Revision history for this message
zorin (dragoscriste) wrote :

thanks

Revision history for this message
Sebastien Bacher (seb128) wrote :
Download full text (3.4 KiB)

Indeed, it hits an invalid free it seems

==17180== Invalid free() / delete / delete[] / realloc()
==17180== at 0x402D378: free (in /usr/lib/valgrind/vgpreload_memcheck-x86-linux.so)
==17180== by 0x51CC16F: g_free (in /lib/i386-linux-gnu/libglib-2.0.so.0.4600.1)
==17180== by 0x504E049: g_local_file_trash (in /usr/lib/i386-linux-gnu/libgio-2.0.so.0.4600.1)
==17180== by 0x4F9CA8D: g_file_trash (in /usr/lib/i386-linux-gnu/libgio-2.0.so.0.4600.1)
==17180== by 0x80F191F: trash_files (nautilus-file-operations.c:1930)
==17180== by 0x80F191F: delete_job (nautilus-file-operations.c:2113)
==17180== by 0x4FB451A: io_job_thread (in /usr/lib/i386-linux-gnu/libgio-2.0.so.0.4600.1)
==17180== by 0x4FDBB57: g_task_thread_pool_thread (in /usr/lib/i386-linux-gnu/libgio-2.0.so.0.4600.1)
==17180== by 0x51EE833: g_thread_pool_thread_proxy (in /lib/i386-linux-gnu/libglib-2.0.so.0.4600.1)
==17180== by 0x51EDDD9: g_thread_proxy (in /lib/i386-linux-gnu/libglib-2.0.so.0.4600.1)
==17180== by 0x53431A9: start_thread (pthread_create.c:333)
==17180== by 0x5444FDD: clone (clone.S:122)
==17180== Address 0xee721c8 is 0 bytes inside a block of size 24 free'd
==17180== at 0x402D378: free (in /usr/lib/valgrind/vgpreload_memcheck-x86-linux.so)
==17180== by 0x51CC16F: g_free (in /lib/i386-linux-gnu/libglib-2.0.so.0.4600.1)
==17180== by 0x504DE11: g_local_file_trash (in /usr/lib/i386-linux-gnu/libgio-2.0.so.0.4600.1)
==17180== by 0x4F9CA8D: g_file_trash (in /usr/lib/i386-linux-gnu/libgio-2.0.so.0.4600.1)
==17180== by 0x80F191F: trash_files (nautilus-file-operations.c:1930)
==17180== by 0x80F191F: delete_job (nautilus-file-operations.c:2113)
==17180== by 0x4FB451A: io_job_thread (in /usr/lib/i386-linux-gnu/libgio-2.0.so.0.4600.1)
==17180== by 0x4FDBB57: g_task_thread_pool_thread (in /usr/lib/i386-linux-gnu/libgio-2.0.so.0.4600.1)
==17180== by 0x51EE833: g_thread_pool_thread_proxy (in /lib/i386-linux-gnu/libglib-2.0.so.0.4600.1)
==17180== by 0x51EDDD9: g_thread_proxy (in /lib/i386-linux-gnu/libglib-2.0.so.0.4600.1)
==17180== by 0x53431A9: start_thread (pthread_create.c:333)
==17180== by 0x5444FDD: clone (clone.S:122)
==17180== Block was alloc'd at
==17180== at 0x402C19C: malloc (in /usr/lib/valgrind/vgpreload_memcheck-x86-linux.so)
==17180== by 0x51CC048: g_malloc (in /lib/i386-linux-gnu/libglib-2.0.so.0.4600.1)
==17180== by 0x51E54BD: g_strdup (in /lib/i386-linux-gnu/libglib-2.0.so.0.4600.1)
==17180== by 0x504D6B8: find_mountpoint_for (in /usr/lib/i386-linux-gnu/libgio-2.0.so.0.4600.1)
==17180== by 0x504D97D: g_local_file_trash (in /usr/lib/i386-linux-gnu/libgio-2.0.so.0.4600.1)
==17180== by 0x4F9CA8D: g_file_trash (in /usr/lib/i386-linux-gnu/libgio-2.0.so.0.4600.1)
==17180== by 0x80F191F: trash_files (nautilus-file-operations.c:1930)
==17180== by 0x80F191F: delete_job (nautilus-file-operations.c:2113)
==17180== by 0x4FB451A: io_job_thread (in /usr/lib/i386-linux-gnu/libgio-2.0.so.0.4600.1)
==17180== by 0x4FDBB57: g_task_thread_pool_thread (in /usr/lib/i386-linux-gnu/libgio-2.0.so.0.4600.1)
==17180== by 0x51EE833: g_thread_pool_thread_prox...

Read more...

tags: added: rls-x-incoming
Changed in nautilus (Ubuntu):
importance: Low → High
status: Incomplete → Triaged
Revision history for this message
Sebastien Bacher (seb128) wrote :

That was a glib issue, I sent it upstream with a patch on https://bugzilla.gnome.org/show_bug.cgi?id=757693

affects: nautilus (Ubuntu) → glib2.0 (Ubuntu)
Changed in glib2.0 (Ubuntu):
status: Triaged → Fix Committed
Changed in glib:
importance: Unknown → Medium
status: Unknown → Fix Released
Revision history for this message
zorin (dragoscriste) wrote :

thanks

Revision history for this message
Iain Lane (laney) wrote :

SRU uploaded to wily, xenial fix will come with the next upstream development release (soon). Please check it once it's available.

[ For SRU verification purposes, this falls under the GNOME MRE, so explicit verification isn't necessary for it to be v-done. ]

Changed in glib2.0 (Ubuntu Wily):
status: New → In Progress
Revision history for this message
petersaints (petersaints) wrote :

How long is it supposed to take for the SRU to be made available. According to the last post it was uploaded to wily on 10 days ago. Does it usually take that long or has something gone wrong with the distribution process in the meantime?

Revision history for this message
Sebastien Bacher (seb128) wrote :

it's not uncommon for it to take over a week since the team doing the reviews is small and tend to be busy

Revision history for this message
petersaints (petersaints) wrote :

Ok. I thought that once was uploaded to wily as an SRU that it was already approved and it would start to be rolled to mirrors and users across the globe. I don't know exactly how the workflow is organized.

Sorry for bothering, I was just concerned that it something wrong had happened.
Thank you for you reply. I'll keep waiting for news :)

Revision history for this message
thisisanoldone (thisisanoldone-deactivatedaccount) wrote :

When the update gets pushed out to users, will this bug report be closed? It's been 20 days now and that's the only thing keeping me from using Ubuntu 15.10 (as all my main user folders such as desktop, images, etc. are all symbolic links to another partition)

Revision history for this message
Brian Murray (brian-murray) wrote : Please test proposed package

Hello zorin, or anyone else affected,

Accepted glib2.0 into wily-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/glib2.0/2.46.2-1ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in glib2.0 (Ubuntu Wily):
status: In Progress → Fix Committed
tags: added: verification-needed
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package glib2.0 - 2.47.3-3

---------------
glib2.0 (2.47.3-3) experimental; urgency=medium

  * debian/patches/0001-gtypes.h-move-G_STATIC_ASSERT-to-function-scope.patch:
    Another cherry-pick. Should fix g-ir-scanner.

 -- Iain Lane <email address hidden> Sun, 29 Nov 2015 18:45:29 +0000

Changed in glib2.0 (Ubuntu):
status: Fix Committed → Fix Released
Revision history for this message
Rodrigo Renie (dmenor) wrote :

The fix in glib2.0 - 2.47.3-3 solved the problem for me!

Revision history for this message
Helio Neto (remiariro) wrote :

glib2.0 2.46.2-1ubuntu1 from wily-proposed fixed it for me. Thanks a lot!

tags: added: verification-done
removed: verification-needed
Revision history for this message
thisisanoldone (thisisanoldone-deactivatedaccount) wrote :

Oh yeah that did fix it. The only problem remaining now is that when the folder is used as the Desktop, the files won't go to the trash bin. But that's no big deal as such.

Thanks!

Revision history for this message
Sebastian Wiesendahl (swiesend) wrote :

The update from `wily-proposed` to glib2.0 (2.46.2-1ubuntu1) is fixing that nautilus does not crash any more, but I can't move the files actually to the trash. I get a message that I only can cancel or skip the attempt or delete the file, but I really like to move it to the trash.

As in https://bugs.launchpad.net/ubuntu/+source/nautilus/+bug/1510587 I am pointing with an symbolic link to the actual resource from within my home folder to a mounted ext4 file system.

Is this a bug or rights problem?

I mount the file system like this in my /etc/fstab:

# <file system> <mount point> <type> <options> <dump> <pass>
LABEL=Data /mnt/data ext4 defaults 0 2

This are my rights on /mnt/data:
$ ll /mnt/data/
drwxr-xr-x 5 root plugdev 4096 Jan 15 12:32 ./
drwxr-xr-x 5 root root 4096 Okt 19 11:14 ../
drwx------ 2 root plugdev 16384 Jan 15 12:16 lost+found/
drwxr-xr-x 3 root plugdev 4096 Jan 15 12:14 user/

and on the underlying folders I have these rights:
$ ll /mnt/data/user/sebastian
drwxrwx--- 18 sebastian sebastian 4096 Jan 18 16:43 ./
drwxr-xr-x 3 root plugdev 4096 Jan 15 12:14 ../

Revision history for this message
Victor Passapera (vpassapera) wrote :

The proposed packages (libglib2.0-0/wily-proposed libglib2.0-bin/wily-proposed) fix both this and bug #1510587.

Thank you.

Iain Lane (laney)
tags: removed: rls-x-incoming
Revision history for this message
fsch (fsch) wrote :

For me, the proposed packages also fix the problem, both when trying to delete ~/.local/share/Trash or the .Trash-1000 directory on external media.

Thank you for the fix.

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package glib2.0 - 2.46.2-1ubuntu1

---------------
glib2.0 (2.46.2-1ubuntu1) wily; urgency=medium

  * No-change backport of stable update to wily. (LP: #1514475)
    + Fixes crash when deleting files from trash. (LP: #1512826)

glib2.0 (2.46.2-1) unstable; urgency=medium

  * Fix Vcs-* to point to unstable.
  * New upstream stable release 2.46.2.
    + Fixes cross compilation (Closes: #800610)
  * Drop changes from 2.46.1-2, which are all in this upstream releaee.
  * Drop debian/patches/0001-GDateTime-test-fix-occasional-failures.patch,
    applied upstream.

glib2.0 (2.46.1-2) unstable; urgency=medium

  * Team upload.
  * Cherry-pick patches from upstream glib-2-46 branch to fix incomplete
    documentation (Closes: #659977)
  * debian/gdbus-example-objectmanager-server.c: add missing example file
    from upstream git; it was accidentally omitted from upstream tarballs

 -- Iain Lane <email address hidden> Mon, 09 Nov 2015 15:22:42 +0000

Changed in glib2.0 (Ubuntu Wily):
status: Fix Committed → Fix Released
Revision history for this message
Brian Murray (brian-murray) wrote : Update Released

The verification of the Stable Release Update for glib2.0 has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.