Bookmarks in sidebar no longer using symbolic icons

Bug #1289872 reported by Shaun P on 2014-03-08
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
GLib
Fix Released
Medium
glib2.0 (Ubuntu)
High
Unassigned
gnome-icon-theme-symbolic (Ubuntu)
Low
Lars Karlitski

Bug Description

Using the development release Trusty 14.04. Nautilus 1:3.10.1-0ubuntu7

I noticed a few days ago (around 6 March) that Nautilus stopped using a symbolic icon for a folder under Bookmarks in the sidebar of the Nautilus window. Instead it shows the Humanity theme folder icon.

I tried downgrading to 1:3.10.1-0ubuntu6 which didn't have this problem but after restarting the symbolic icon was still replaced by the humanity folder icon. I tried a fresh ubuntu daily iso on a usb memory stick and got the same result.

Sebastien Bacher (seb128) wrote :

Thank you for your bug report. I can confirm that, the sidebar comes from GTK (the fileselector in e.g gedit have the same issue, reassigning there

affects: nautilus (Ubuntu) → gtk+3.0 (Ubuntu)
Changed in gtk+3.0 (Ubuntu):
importance: Undecided → Low
status: New → Confirmed
Sebastien Bacher (seb128) wrote :

Not sure what changed, are you sure it was working? I don't see any recent change in nautilus or gtk which could explain that

Sebastien Bacher (seb128) wrote :
affects: gtk+3.0 (Ubuntu) → ubuntu
Changed in ubuntu:
importance: Low → High
affects: ubuntu → glib2.0 (Ubuntu)
Changed in glib2.0 (Ubuntu):
status: Confirmed → Triaged
Changed in glib:
importance: Unknown → Medium
status: Unknown → New
Changed in gnome-icon-theme-symbolic (Ubuntu):
importance: Undecided → Low
status: New → Fix Committed
assignee: nobody → Lars Uebernickel (larsu)
Changed in glib:
status: New → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-icon-theme-symbolic - 3.10.1-1ubuntu1

---------------
gnome-icon-theme-symbolic (3.10.1-1ubuntu1) trusty; urgency=medium

  * debian/patches/git_directory_symbolic.patch: symlink directory
    symbolic icon, thanks Lars Uebernickel (lp: #1289872)
 -- Sebastien Bacher <email address hidden> Tue, 11 Mar 2014 18:29:06 +0100

Changed in gnome-icon-theme-symbolic (Ubuntu):
status: Fix Committed → Fix Released
Shaun P (sigmagammapi) wrote :

That was fixed pretty fast! Thanks.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.