per-session gsettings overrides

Bug #1222053 reported by Tim Lunn on 2013-09-07
22
This bug affects 2 people
Affects Status Importance Assigned to Milestone
GLib
Expired
Medium
glib2.0 (Ubuntu)
Wishlist
Unassigned

Bug Description

There have been several occasions now where Ubuntu GNOME has had to patch code, that could in theory instead be handled by per-session gsettings overrides. A recent example is the background plugin in gnome-settings-daemon (LP: #1219148), this should be loaded under unity, gnome-flashback sessions but not gnome-shell session. A per-session override would make this possible without any patches to the codebase.

As I understand it the overrides are processed by glib-compile-schemas so perhaps we would have to recompile schemas on each login to achieve this? Any thoughts on how we can achieve this?

Tim Lunn (darkxst) on 2013-09-07
description: updated
Martin Pitt (pitti) wrote :

Compiling schemas on every login is a waste of both CPU time and also disk space. Perhaps instead of /usr/share/glib-2.0/schemas/gschemas.compiled glib could first look into /usr/share/glib-2.0/schemas/$SESSION/gschemas.compiled and if that doesn't exist, fall back to the standard path?

desrt (desrt) wrote :

Worth noting that it's already possible to add new directories to the schema search path via GSETTINGS_SCHEMA_DIR.

Changed in glib2.0 (Ubuntu):
importance: Undecided → Wishlist
Changed in glib:
importance: Unknown → Medium
status: Unknown → Confirmed
Changed in glib:
status: Confirmed → Won't Fix
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in glib2.0 (Ubuntu):
status: New → Confirmed
Changed in glib:
status: Won't Fix → Confirmed
Changed in glib:
status: Confirmed → Expired
Changed in glib2.0 (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related blueprints

Remote bug watches

Bug watches keep track of this bug in other bug trackers.