vlc crashed with SIGSEGV in g_str_equal()

Bug #1157800 reported by Lorenzo De Liso on 2013-03-20
36
This bug affects 5 people
Affects Status Importance Assigned to Milestone
GLib
Fix Released
Medium
glib2.0 (Ubuntu)
Medium
Unassigned

Bug Description

Vlc does not start. From command line:

$ vlc
VLC media player 2.0.5 Twoflower (revision 2.0.5-0-g1661b7d)
Errore di segmentazione (core dump creato)

ProblemType: Crash
DistroRelease: Ubuntu 13.04
Package: vlc-nox 2.0.5-1build1
ProcVersionSignature: Ubuntu 3.8.0-13.23-generic 3.8.3
Uname: Linux 3.8.0-13-generic x86_64
ApportVersion: 2.9.2-0ubuntu1
Architecture: amd64
Date: Wed Mar 20 16:51:12 2013
ExecutablePath: /usr/bin/vlc
InstallationDate: Installed on 2013-02-23 (24 days ago)
InstallationMedia: Ubuntu 12.10 "Quantal Quetzal" - Release amd64 (20121017.5)
MarkForUpload: True
ProcCmdline: /usr/bin/vlc
ProcEnviron:
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=it_IT.UTF-8
 SHELL=/bin/bash
SegvAnalysis:
 Segfault happened at: 0x7f52c3325be6: movdqu (%rdi),%xmm1
 PC (0x7f52c3325be6) ok
 source "(%rdi)" (0x7f52bd39354a) in non-readable VMA region: 0x7f52bd36f000-0x7f52bd56f000 ---p /usr/lib/x86_64-linux-gnu/libQtGui.so.4.8.4
 destination "%xmm1" ok
SegvReason: reading VMA /usr/lib/x86_64-linux-gnu/libQtGui.so.4.8.4
Signal: 11
SourcePackage: vlc
StacktraceTop:
 ?? () from /lib/x86_64-linux-gnu/libc.so.6
 g_str_equal () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
 g_hash_table_lookup () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
 g_quark_from_static_string () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
 ?? () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
Title: vlc crashed with SIGSEGV in g_str_equal()
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lp lpadmin plugdev sambashare sudo

Lorenzo De Liso (blackz) wrote :
information type: Private → Public

StacktraceTop:
 g_str_equal (v1=<optimized out>, v2=<optimized out>) at /build/buildd/glib2.0-2.35.8/./glib/ghash.c:1706
 g_hash_table_lookup_node (hash_return=<synthetic pointer>, key=0x7f52bb91554a, hash_table=0x2660800) at /build/buildd/glib2.0-2.35.8/./glib/ghash.c:386
 g_hash_table_lookup (hash_table=0x2660800, key=key@entry=0x7f52bb91554a) at /build/buildd/glib2.0-2.35.8/./glib/ghash.c:1076
 quark_from_string (duplicate=0, string=0x7f52bb91554a "-g-type-private--GTypeFlags") at /build/buildd/glib2.0-2.35.8/./glib/gquark.c:173
 g_quark_from_static_string (string=string@entry=0x7f52bb91554a "-g-type-private--GTypeFlags") at /build/buildd/glib2.0-2.35.8/./glib/gquark.c:239

Changed in vlc (Ubuntu):
importance: Undecided → Medium
tags: removed: need-amd64-retrace
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in vlc (Ubuntu):
status: New → Confirmed
Rémi Denis-Courmont (rdenis) wrote :

This looks identical to LP#1105417. This looks like a problem in gobject internals, even VLC does not use gobject (directly). Hence, this is most probably a bug in a library used by VLC. Unfortunately, the stack trace is busted.

Looking at the ProcMaps, we can see that there's just the VLC core, the VLC ALSA audio output plugin, the VLC Qt4 GUI plugin and the VLC SDL video output plugin. The first two definitely do not use gobject. The presence of SDL is quite peculiar (and deprecated in upstream VLC).

Does the problem still occur if vlc-plugin-sdl is UNINSTALLED?

Lorenzo De Liso (blackz) wrote :

Rémi, I still experience the issue with vlc-plugin-sdl uninstalled

Rémi Denis-Courmont (rdenis) wrote :

Then by elimitation, it's a problem with the Qt4 GUI. This code path must be coming from some UI plugin underneath Qt4.

affects: vlc (Ubuntu) → qt4-x11 (Ubuntu)
tags: added: trusty
affects: qt4-x11 (Ubuntu) → glib2.0 (Ubuntu)
Changed in glib:
importance: Unknown → Medium
status: Unknown → New
Changed in glib:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.