Update to 2.34.4

Bug #1154657 reported by Iain Lane on 2013-03-13
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
glib2.0 (Ubuntu)
Undecided
Unassigned
Precise
Undecided
Unassigned

Bug Description

[ Description ]

GLib stable point release fixes many bugs, including the important crasher bug #1154370. It also makes bash completion work.

Overview of changes from GLib 2.32.3 to 2.32.4
==============================================

* Bugs fixed:
 639771 g_dir_read_name() can also return NULL on error
 660851 Breakage of code due to changes in the GThread...
 666386 Empathy doesn't open Redirect URI with particu...
 671545 Constify collect and lcopy strings in GTypeVal...
 672329 memory leaks in gutils.c and glib tests
 672548 g_utf8_validate: @str shouldn't end up annotat...
 672889 GLib.utf8_validate does segfault
 673253 Not strict enough autconf test for libelf
 674452 SEGFAULT in gio contenttype test
 674777 What's the (transfer) of g_variant_lookup()?
 675309 gkeyfile: Fix annotations for g_key_file_load_...
 675446 gfile: Plug memory leak in g_file_make_directo...
 675832 Incomplete gsettings bash auto-completion
 676265 GNetworkMonitor leaks a lot of memory
 676277 Document that g_app_info_create_from_commandli...
 676397 g_environ_* should work with NULL envp
 676594 [Patch] fix g_reload_user_special_dirs_cache
 676816 Add more GLIB_AVAILABLE_IN_*
 677235 Clarify the comment at the top of gmarshal.list
 677782 Install bash completion files in /usr/share
 677817 g_key_file_to_data adds extra blank lines in so...
 677952 Missing annotation for GDBusConnection signal "...
 678052 g_wakeup_acknowledge is called too often.
 678066 gdbus codegen does not work with python3
 678273 unicode othercasing is wrong in gregex
 678333 gdbus-codegen code causes warnings under -Wfloa...
 678758 GTlsInteraction unlocks an unlocked mutex
 678881 Test failures in /socket/timed_wait in some cas...
 678941 /contenttype/guess test case failure
 678944 gio returns the wrong default applications for ...
 678949 wrong definition of ulong_bool for 64 bit big e...
 678959 /mainloop/timeouts race condition: assertion fa...
 679258 The 'Since' tag for G_SOURCE_CONTINUE and G_SOU...
 679671 Misc fixes for g_dbus_node_info_new_for_xml
 679813 Documentation bug on http://developer.gnome.org...

[ Test case and regression potential ]

This update is under the GNOME MRE. Install GLib and run your system for a week or so. If you see any regressions, this SRU has failed. If not, it's OK.

Iain Lane (laney) on 2013-03-13
Changed in glib2.0 (Ubuntu):
status: New → In Progress
status: In Progress → Fix Released
Changed in glib2.0 (Ubuntu Precise):
status: New → In Progress

Hello Iain, or anyone else affected,

Accepted glib2.0 into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/glib2.0/2.32.4-0ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in glib2.0 (Ubuntu Precise):
status: In Progress → Fix Committed
tags: added: verification-needed
Brian Murray (brian-murray) wrote :

The verification calls for seeing if there are any regressions, it is possible to use errors.ubuntu.com for this with the following url:

https://errors.ubuntu.com/api/1.0/most-common-problems/?format=json&version=2.32.4-0ubuntu1&package=glib2.0&period=year&limit=10&first_appearance=True

This will tells us if there are any crashes that were first reported about the version of the package in precise-proposed. While there is one new bucket it is only reported by one system so I would disregard it.

Brian Murray (brian-murray) wrote :

Given that there are no new crashes, and the bug referenced in the description has been verified - I am changing the tag from v-needed to v-done.

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package glib2.0 - 2.32.4-0ubuntu1

---------------
glib2.0 (2.32.4-0ubuntu1) precise; urgency=low

  * New upstream release (LP: #1154657)
    + GSettings: Don't crash due to incorrect handling of "/" (LP: #1154370)
    + gio: Stop ignoring defaults.list wrongly (LP: #901171)
  * Update watch file to track 2.32 series for Precise
  * debian/control{,.in}: Require libelf-dev >= 0.8.12, per configure.ac
  * gnetworkmonitor_dont_leak_networks.patch: Drop, included in this release.
  * Install bash completion files into /etc/bash_completion.d; overriding an
    upstream change (not appropriate for Precise) to install into
    /usr/share/bash-completion/completions. This change also names the
    completion files correctly (after the commands they are completing for),
    so they will start working now.
 -- Iain Lane <email address hidden> Wed, 13 Mar 2013 10:45:56 +0000

Changed in glib2.0 (Ubuntu Precise):
status: Fix Committed → Fix Released

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers